PDA

View Full Version : No action when laptop lid is closed



roja
September 23rd, 2008, 12:27 AM
I noticed that the screen is not blanked when the lid is closed on my HP 530. When testing the other options for AC power as well as Battery power none of them works (apart from "Do nothing"). It works OK with HH and Sidux running live from CD.
Is it only me?

mrtenl
September 23rd, 2008, 07:11 PM
Hey, I also got a HP 530, and i have the exact same problem.
Default behavior for my laptop in hardy when the screen was closed was to suspend if on battery, and black out the screen when on AC. After the upgrade to ibex, my computer doesn't seem to notice when the screen is closed.

Also, suspend and resume doesn't work, have tried both the 'hibernate' and 'uswsusp' packages.
uswsusp gives me this error:
morten@loltop:~$ s2both
/dev/mem: Permission denied
s2both: Could not lock myself. Reason: Cannot allocate memory
morten@loltop:~$ sudo s2both
[sudo] password for morten:
s2both: Could not stat the resume device file. Reason: No such file or directory

the suspend-command works, but my laptop fails to wake from the suspend.

Nullack
September 24th, 2008, 02:50 AM
Please consider looking for an existing bug on LP about this, and subscribing to show your support. If there isnt an existing bug, you could report a new one.

mrtenl
October 2nd, 2008, 10:11 PM
Where do i search for existing bugs? And how do i report a new one?

ktp
October 2nd, 2008, 10:26 PM
Where do i search for existing bugs? And how do i report a new one?

Here are some links:
https://bugs.launchpad.net/ubuntu
http://www.ubuntu.com/community/reportproblem
https://help.ubuntu.com/community/ReportingBugs

mrtenl
October 3rd, 2008, 12:45 PM
Thanks :)
I could not find any previous, similar bugs, so i reported it. Can be found here: https://bugs.launchpad.net/ubuntu/+bug/277534

mrtenl
October 6th, 2008, 12:51 PM
I noticed that the screen is not blanked when the lid is closed on my HP 530. When testing the other options for AC power as well as Battery power none of them works (apart from "Do nothing"). It works OK with HH and Sidux running live from CD.
Is it only me?

Hej grabben :)
If you could register at launchpad and confirm the bug i posted, we may have a chance of it being fixed in the final 8.10 release.
https://bugs.launchpad.net/ubuntu/+bug/277534