View Full Version : [ubuntu] 8.04 Install Deadends at "initramfs"

September 22nd, 2008, 08:27 PM
I'm trying to install Ubuntu 8.04 from a CD, but the "install" path stops and presents an "initramfs" prompt.

Per one thread, I've enabled AHCI for SATA hard drives, but then the computer won't boot from the CD-ROM. I directed it to the CD-ROM via the boot menu, but pressing F6 at the install screen wouldn't allow me to enter the pci=nomsi as instructed by the thread. Proceeding with the install wound up at the initramfs prompt.

(See http://ubuntuforums.org/showthread.php?t=820161).

The computer is self-built. The motherboard is a Gigabyte GA-EP45-DS3L (I've updated the BIOS to F8). The hard drive is a Western Digital SATA. I have Ubuntu 7 two other self-built boxes and haven't seen this before. This is a fresh install to a Linux only workstation.

Please help me fix this or point me to a solution. Thanks.

September 22nd, 2008, 08:40 PM
I am currently having the same issue getting humg up at initramfs...I tried to install Ubuntu via dual booting and run it from a Live CD and I get this error bot ways.

September 22nd, 2008, 09:24 PM
I got that error repeatedly until I figured out that I had a "sketchy" CD drive. I was burning poor CDs and I was having read errors.

What worked for me was to burn the <10MB minimal CD (https://help.ubuntu.com/community/Installation/MinimalCD) - it successfully burned the whole thing and I didn't get any read errors. The only downside is that you have to download all the packages from the internet, which might take a while.

Before you try the minimal CD, you should probably choose the "Check CD" option and see if that passes (it probably won't, from the sound of it).

September 22nd, 2008, 09:36 PM
I actually did check it out with the 'check cd' function and it checked out ok. Furthermore, the live cd works perfectly fine in my dell xps m1330 notebook. I called the local guy who put the computer together and he suspects it has something to do with the video card, but I don't think that's it. My video card is a NVDIA GeForce 6200 TurboCache has anyone else had bad luck with this vid card?

September 22nd, 2008, 11:22 PM
Okay, I've (mostly) resolved this. The problem might be the motherboard's IDE controller (but, I'm not technical, that's a guess).

In the BIOS, I've set the following options:

SATA AHCI Mode: Enabled
SATA Port0-3 Native Mode: Enabled

Note that these options might be specific to this motherboard. FYI, its Onboard IDE Controller flag is set to Enabled, but this was the default shipped with the board. Also note the board's BIOS was updated.

The install process now runs successfully and without incident. The system doesn't boot from CD, despite the drive's priority over the hard drive, but I'll tackle that another day.

September 22nd, 2008, 11:42 PM
What version of BIOS are you running? I am Phoenix and I can't find where these options are. Can you direct me?

September 22nd, 2008, 11:48 PM
I'm using version F8, downloaded from Gigabyte's website. Don't know how to check for version info past that.

On mine, these options are in the BIOS (hit DELETE after power on/reset, before boot starts), under Integrated Peripherals.

September 23rd, 2008, 12:00 AM
I had a similar problem initially caused by the presence of an unused adaptec scsi card in my machine. Even though there were no attached devices its' presence seemed to confuse the Ubuntu installer about the device naming/numbering and so it wasn't finding the CDROM at that point even though it was available as the BIOS had booted the initial phase of the installer from it. As soon as I removed the scsi card the install went fine. I'm not saying your problem is the same but could be a similar device naming issue.

September 23rd, 2008, 12:04 AM
Take a look at this thread: