PDA

View Full Version : [ubuntu] Lots of problems



Brennagan
September 22nd, 2008, 02:04 PM
My goal is to eventually install Ubuntu on an external hard drive. Ive done a lot of stuff so far with some advice from other board members.

First off some information. My internal hard drive has vista installed. My external hard drive is 80 gbs and completely empty.

Right now i continually get error 17 whenever i try to boot up without the external hard drive in so how can i fix that. And if I do have it plugged in and select vista i get another menu that shows windows vista and 2 ubuntus that dont work so how can i fix that?

Thanks in advance for all the help

Brennagan
September 23rd, 2008, 03:58 AM
I installed ubuntu on my external hard drive and everything is fine except when i actually try to boot linux but making it first in priority it shows the menu with safe mode and such but any of them i select i get a grub error 17. How do i fix this? Im kind of a noob at this so the more detailed the better thanks in advance.

overdrank
September 23rd, 2008, 04:22 AM
Hi and please do not make multiple threads on the same issues. I have given you all the info I had on the issue in your previous thread on installation. I have moved your thread to ABT Absolute Beginner Talk. Good luck! :)

willca
September 23rd, 2008, 05:16 AM
I just wonder, when you installed Ubuntu onto your external drive...where did you tell it to install the bootloader to? root or mbr?

From experience, I would rather use Grub than use Windows own bootloader. So basically I would have installed it on the 1st drives MBR if given a choice.

kansasnoob
September 23rd, 2008, 05:57 AM
My goal is to eventually install Ubuntu on an external hard drive. Ive done a lot of stuff so far with some advice from other board members.

First off some information. My internal hard drive has vista installed. My external hard drive is 80 gbs and completely empty.

Right now i continually get error 17 whenever i try to boot up without the external hard drive in so how can i fix that. And if I do have it plugged in and select vista i get another menu that shows windows vista and 2 ubuntus that dont work so how can i fix that?

Thanks in advance for all the help

Well first, if you're hardware savvy, you should have done this:

http://www.pendrivelinux.com/2008/04/14/ubuntu-804-usb-hard-drive-install/#more-372

If you're not hardware savvy you should have someone else do it, but we're past that.

Now you need to restore Vista's bootloader. Make sure your external drive is disconnected before doing this:

If you have no disc you can get one here:

http://neosmart.net/blog/2008/windows-vista-recovery-disc-download/

Instructions here:

http://support.microsoft.com/kb/927392

or here:

http://www.winvistatips.com/fix-mbr-a116.php

You want to "fix boot" and "fix mbr"!

Then we'll have to see if Ubuntu boots upon restarting with the external drive plugged in.