PDA

View Full Version : Audio volume OSD constantly adjusting



rekado
September 22nd, 2008, 10:09 AM
Yesterday (September 21, 2008) I installed the current 8.10 alpha release via "upgrade -d" on my notebook with an Intel HDA sound chip.

Some things are fixed now (such as the broken CPU frequency scaling that I was facing before and some minor issues when booting and shutting down), and I'm happy to say that Ibex has improvements which are subtle but noticable and very useful.

One thing is bothering me, though. When trying to adjust the audio volume via Fn keys the OSD appears and even though I already let go of the key, the volume is still being adjusted gradually till the limit values. Unfortunately upon reaching either maximum or minimum value the OSD does not disappear - it seems as if the key hangs and the command is still submitted. This makes the OSD flicker.
Furthermore I cannot open the main menu anymore from that moment on. Also clicking on the shutdown-applet in the panel does not open the shutdown screen. It all works before adjusting the audio volume via Fn keys, though.

Only killing the X-session with Ctrl+Alt+Backspace resets the OSD and upon logging in another time it all is as it was before.

This bug is reproducable whenever I touch any of the volume adjustment hotkeys (also hotkeys for mute!).

I already filed a bug at launchpad.
Did anyone else face this issue before?
Do you happen to know how to configure the OSD for audio volume?

rekado
September 25th, 2008, 09:52 AM
Still remains even after installing all recent updates.

Sophont
September 25th, 2008, 03:32 PM
Are you sure it's not just your key that's faulty?

You could burn a Hardy live iso and boot that. If the problem is still there it's likely your key that's broken, otherwise it's a bug.

rekado
September 25th, 2008, 05:02 PM
I've been using Ubuntu since a long time. Right after I upgraded to Intrepid the keys showed this behavior. I don't have an empty CD here at the moment but I sure will try.

rekado
September 25th, 2008, 05:24 PM
So, there is more to it:

I ran xev in the terminal to check if the command is sent repeatedly. It is not. When running xev and performing either shortcut the OSD appears increments or decrements one step and disappears again. However, the panel still becomes unusable. Also typing in the address bar of firefox won't work anymore, Alt+Tab doesn't switch windows anymore (I do not use Compiz) etc.

Another thing is that without running xev the constant change of the OSD can be interrupted by pressing Esc. Still I would lose interaction with the system as described above.

So it's definitely not the keys.

rekado
September 26th, 2008, 01:16 PM
I filed a bug:
https://bugs.launchpad.net/ubuntu/+bug/273009

rekado
October 6th, 2008, 10:52 AM
Even after a complete reinstall with the current Intrepid Ibex Beta ISO the problem remains.

djcslip
October 15th, 2008, 06:02 AM
Exactly the same here - any ideas?

rekado
October 15th, 2008, 09:40 PM
You could subscribe to the bug in launchpad and comment there to confirm the bug and draw the developers' attention to it.

noOneSpecial
October 15th, 2008, 10:23 PM
Sounds like this bug
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/271706

rekado
October 16th, 2008, 10:04 PM
Sounds like this bug
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/271706

Seems that you are right. The bug description sounds very similar. I marked my bug as a duplicate. Comments on the other bug report suggest that this is caused by the new driver evdev.

noOneSpecial
October 17th, 2008, 12:01 AM
Yeah looks that way. My volume keys are doing the same thing. Ubuntu was the only distro I'd tried where they worked, oh well.. no big deal to change the key combos for now. :)