PDA

View Full Version : [ubuntu] Linux and Live CD stopped working after installing new RAM



BryantArms
September 21st, 2008, 04:31 AM
A strange thing happened when I upgraded my RAM:

When I replaced my two half-gig RAM sticks in my acer aspire 9410 with two 2-gig RAM sticks the pclos 2007 I have dual booted with vista stopped booting. Vista still works and it uses 3 of the 4 gigs of new RAM.

I have been preparing to install ubuntu in place of pclos and I thought I should update my ram before I do the install. When pclos stopped working after the upgrade, that seemed to vindicate my strategy. But then I noticed something weird.

What is really weird is that the ubuntu 8.04.1 live CD that used to work before the RAM upgrade won't work now. And the pclos gnome 2008 and Knoppix live CDs I have laying around won't work anymore too. But my optical drive seems to be working well.

What is going on? Is linux not able to handle more than a couple of gigs of RAM?

cariboo907
September 21st, 2008, 06:27 AM
When you installed the ram, did you by any chance change the boot order in your bios, or use the default setting option, as that will change the boot order.

Jim

BryantArms
September 22nd, 2008, 02:31 AM
I did not change anything in the bios when I changed my ram. I checked the boot order and it is the same as I remember. It boots from the cd first, then the hd, and then a few other things begining with usb stuff. I have had booting from network disabled.

By the way, I changed the ram back to 1gig from 4gig when I began having a problem with vista booting too. Vista began acting the same as pclose; just a black screen. When I put the old ram back in pclos booted as it used to do. And when I tried to boot into vista a screen popped up saying that the hibernation file was lost and that windows could only boot by sacrificing any saved data. Then vista booted normally. Why did that screen enabling me to go on only show up after I put the old ram back into the computer?

I figured that my child who was watching a movie must have put the computer into hibernation while using vista and I didn't know it. So I screwed things up for vista when I tried to start everything normally. But I'm only guessing. My daughter is only 1.5 years old so she cannot explain herself well enough to confirm my suspicion.

Anyway; Is the RAM defective? How can I check that? Does memory test do that? I started to do that test but it was taking so long and I began to wonder if it was testing the hd so I stopped it.

Or is linux unable to handle that much ram?

I know I am asking for a lot of answers. But I do need the extra ram to make vista work decently. And I need windows for for a gaming and entertainment platform. I also really want to become confident with linux so that I can depend on it to do everything else I want out of my computers.

Any help you can offer with enlightening me will be appreciated.

Thanks in advance.

Bryant

djdarrin91
November 12th, 2008, 06:07 AM
Same thing has happened to me i had 256mb ram and all was well and i upgraded to 2gigs now no linux will start or run. did you find out why this happened to you?