PDA

View Full Version : [ubuntu] [SOLVED] Noob needs help with conky settings



I wanted to leave
September 21st, 2008, 01:30 AM
I managed to install conky and copy a script to conkyrc and run it.
See screenshot
But it seems I have a conflict with compiz when I restart Ubuntu.
Instead of displaying as in the screenshot, it appears/disappears as do my panels, open gnome windows etc
How do I fix this?


Please provide complete answers for a noob thanks

Dr Small
September 21st, 2008, 01:33 AM
Please re-explain the problem again.

I wanted to leave
September 21st, 2008, 01:38 AM
That was quick, thanks.
Ok you can see it works in the screenshot if I load conky after a reboot via the terminal. But when I go to sessions and add conky to start on boot, and then reboot the desktop, I get a flashing on and off of conky, my panels, and any open gnome windows etc.
It seems like a conflict with compiz?
Hope Ive explained it better

mc4100
September 21st, 2008, 01:40 AM
Could you post the contents of:

cat ~/.conkyrc
Only post the stuff before TEXT.

Edit: also, if you "killall conky" after login, and then launch it again "conky", do you still have the same issues?

I wanted to leave
September 21st, 2008, 01:41 AM
Output

bra10n@bra10n-desktop:~$ cat ~/.conkyrc
background yes
use_xft yes
xftfont Bitstream Vera Sans:size=7
xftalpha 0.8
update_interval 3
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
double_buffer yes
draw_shades no
draw_outline yes
stippled_borders no
border_margin 0
border_width 1
default_color white
default_shade_color black
alignment bottom_left
minimum_size 1262
gap_x 26
gap_y 26
use_spacer none

no_buffers yes
uppercase yes

treehouse
September 21st, 2008, 01:45 AM
What command are you using to execute conky at startup?

mc4100
September 21st, 2008, 01:46 AM
This should fix your problem:

Remove conky from Sessions.
Create a new text file in gedit:


#!/bin/bash
sleep 30
conky &
exit 0

Save this as, say, ".conky-delay.sh".
Make it executable.
Add this to Sessions.

I wanted to leave
September 21st, 2008, 01:46 AM
No if I load it via the terminal after the desktop starts all is good as per the screenshot.

I wanted to leave
September 21st, 2008, 01:48 AM
What command are you using to execute conky at startup?

conky
conky

Is this right?

mc4100
September 21st, 2008, 01:49 AM
The problem is you need to wait until compiz is loaded, which means adding:

conky
To the start-up programs isn't enough when using compiz -- see my previous post on how to fix this.

I wanted to leave
September 21st, 2008, 01:50 AM
This should fix your problem:

Remove conky from Sessions.
Create a new text file in gedit:


#!/bin/bash
sleep 30
conky &
exit 0

Save this as, say, ".conky-delay.sh".
Make it executable.
Add this to Sessions.


thanks but could you explain this more for a noob

treehouse
September 21st, 2008, 01:51 AM
This should fix your problem:

Remove conky from Sessions.
Create a new text file in gedit:


#!/bin/bash
sleep 30
conky &
exit 0

Save this as, say, ".conky-delay.sh".
Make it executable.
Add this to Sessions.



Do this thing ^

If for some reason it doesn't load correctly change the line 'conky &' to 'conky -c ~/.conkyrc &' replacing '~/.conkyrc' with the location of your config file if it isn't in the home directory.

mc4100
September 21st, 2008, 01:53 AM
Remove conky from System -> Preferences -> Sessions, so it doesn't start when you log in:
Select the one that says conky, and click remove. Close the window when you're done.
Create a new text file in gedit:
In Applications -> Accessories -> Text Editor, paste the following into the window:


#!/bin/bash
sleep 30
conky &
exit 0

File -> "Save as", and copy/paste ".conky-delay.sh" into the "name".
Click "Save". Close the window when you're done.
Click Places -> Home Folder
Press CTRL+H, look for ".conky-delay.sh"
Right-click it, go to Properties, and then the permissions tab, in the file browser, and make it executable.
Add this (".conky-delay.sh") to System -> Preferences -> Sessions:
Name: Conky
Command:

~/.conky-delay.sh
Log Out, and then back in, waiting 30 seconds, to test if it's working.

Is this better? I can provide complete step-by-step on clicking one thing after another with screenshots, if this isn't enough.

mc4100
September 21st, 2008, 02:06 AM
I've update the above post but as treehouse suggests, if:

#!/bin/bash
sleep 30
conky &
exit 0 Doesn't work, try replacing it with:

#!/bin/bash
sleep 30
conky -c ~/.conkyrc &
exit 0

I wanted to leave
September 21st, 2008, 02:08 AM
Remove conky from System -> Preferences -> Sessions, so it doesn't start when you log in:
Select the one that says conky, and click remove. Close the window when you're done.
Create a new text file in gedit:
In Applications -> Accessories -> Text Editor, paste the following into the window:


#!/bin/bash
sleep 30
conky &
exit 0

File -> "Save as", and copy/paste ".conky-delay.sh" into the "name".
Click "Save". Close the window when you're done.
Click Places -> Home Folder
Press CTRL+H, look for ".conky-delay.sh"
Right-click it, go to Properties, and then the permissions tab, in the file browser, and make it executable.
Add this (".conky-delay.sh") to System -> Preferences -> Sessions:
Name: Conky
Command:

~/.conky-delay.sh
Log Out, and then back in, waiting 30 seconds, to test if it's working.

Is this better? I can provide complete step-by-step on clicking one thing after another with screenshots, if this isn't enough.

Cheers mc4100 all fixed. None more surprised than both of us!
Thanks for your help & patience

mc4100
September 21st, 2008, 02:10 AM
You're very welcome; and should make the tread as "solved", in thread tools, since your problem is fixed, and it helps other users find useful posts.

Dr Small
September 21st, 2008, 02:10 AM
I can provide complete step-by-step on clicking one thing after another with screenshots, if this isn't enough.

For this reason, it is generally easier to just explain a few commands to run, and be done with it.

mc4100
September 21st, 2008, 02:13 AM
For this reason, it is generally easier to just explain a few commands to run, and be done with it.
I'll admit, it could have been done quicker with a few ""touch"'s here, and some "echo"'s there, (throw in some "chmod"s for good measure), but it's good to explain things properly so people can get a feel for how they can configure their system graphically, then progressing onto learning the Command Line.
At which point, it shall be, Lesson One: Shell Scripts. ;)

I wanted to leave
September 21st, 2008, 02:23 AM
Explanations were fine :KS
I'm just a noob