PDA

View Full Version : [ubuntu] Turn off track stick



Cl0ud9
September 17th, 2008, 11:31 PM
The track stick on my Dell laptop has developed a mind of it's own making it very difficult to get any work done. I can't seem to find any way of turning it off. Any suggestions?

gr3yhatt3r
February 9th, 2009, 06:36 AM
I'm having the same problem. I am dual booted with Vista and have been able to disable the track stick on the vista partition but I have been trying forever to disable it in the Ubuntu partition. I'm new to linux so any help would be greatly appreciated.

sudden0utburst
July 12th, 2010, 05:56 PM
uh. im brand new to ubuntu but im a quick learner n figured this out here ya go it helped me-
go to system
, preferences, assistive technologies nfind mousepad.. urwelcome peace!

jdh4321
July 10th, 2011, 01:07 AM
Disabling the track stick in Ubuntu


To list all available input devices:

Open terminal and use....

⎡ Virtual core pointer id=2 ⎜
↳ Virtual core XTEST pointer id=4 ⎜
↳ Wacom Graphire2 4x5 eraser id=9 ⎜
↳ Wacom Graphire2 4x5 cursor id=10 ⎜
↳ Wacom Graphire2 4x5 id=11 ⎜
↳ AlpsPS/2 ALPS DualPoint TouchPad id=14 ⎜
↳ Macintosh mouse button emulation id=15 ⎜
↳ DualPoint Stick id=13

⎣ Virtual core keyboard id=3
↳ Virtual core XTEST keyboard id=5
↳ Video Bus id=6
↳ Power Button id=7
↳ Sleep Button id=8
↳ AT Translated Set 2 keyboard id=12

In this example its "DaulPoint Stick" or "id=14

Then Use:

xinput -set-prop "DualPoint Stick" "Device Enabled" 0

Its just a switch and when you reboot your Laptop you may have to Re-Input
the command...

Just save it to a note so you can copy and paste in terminal...

The best way may be to detach the Stick all together..



Hope this helps...

gtippitt
February 19th, 2013, 02:10 PM
I have a wireless keyboard with mouse touchpad that drives me crazy when I'm typing and bump it. The touchpad is fine when surfing, but when I'm doing serious typing, I want to disable the keyboard's pointing device and use a cordless mouse instead.

The post above helped me find the link below that had lots more info on the xinput command.

http://cederlys.wordpress.com/2010/07/13/disabling-the-track-stick-in-ubuntu/


I created a launcher to disable the touchpad with
==> xinput -set-prop "pointer:2.4 GHz RF Receiver" 146 0

and other launcher to enable the touchpad with
==> xinput -set-prop "pointer:2.4 GHz RF Receiver" 146 1

Good luck,
Greg