PDA

View Full Version : [ubuntu] Not all updates enable



chanfle
September 16th, 2008, 05:55 PM
hello all
today appear on my computer have 43 updates but noy i can select on the box for update....appear disable
how i can select this updates....??
thank you
I use Ubuntu 7.10
Regards...

manishtech
September 16th, 2008, 09:28 PM
You can use the command line equivalent for the same. Dont worry command-line isnt so geeky or tough. Its just a matter of choice and additional option. The command for it is


sudo apt-get upgrade

Casper Hansen
September 16th, 2008, 10:13 PM
You can use the command line equivalent for the same. Dont worry command-line isnt so geeky or tough. Its just a matter of choice and additional option. The command for it is


sudo apt-get upgrade

Don't you have to run


sudo apt-get update

first?

Or is it just me who's run?

Pumalite
September 16th, 2008, 10:24 PM
sudo apt-get update
sudo apt-get dist-upgrade

chanfle
September 17th, 2008, 01:41 AM
sudo apt-get update
sudo apt-get dist-upgrade

hi all
hhhmmm....in my update manager appear the new updates but i can't select or unselect the box....
how i can fix that????

Pumalite
September 17th, 2008, 02:34 AM
Run the commands I gave you in the Terminal

manishtech
September 17th, 2008, 08:27 AM
Don't you have to run


sudo apt-get updatefirst?

Or is it just me who's run?

I know we should run update first, but I hardly do so.

Pumalite
September 17th, 2008, 11:29 AM
Bad habit

chanfle
September 17th, 2008, 06:16 PM
ok...when i type

sudo apt-get upgrade
appear this

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
amarok amarok-xine bind9-host dnsutils evolution evolution-common
evolution-plugins firefox firefox-gnome-support gimp gimp-data gimp-python
gstreamer0.10-esd gstreamer0.10-plugins-good kdelibs-data kdelibs4c2a
libbind9-30 libgnutls13 libisccfg30 libpoppler-glib2 libruby1.8 libsmbclient
libxine1 linux-generic linux-headers-generic linux-image-generic
linux-restricted-modules-generic ntfs-3g openssh-client python-libxml2
python2.5 python2.5-minimal ruby1.8 samba-common smbclient ssh-askpass-gnome
transmission-cli transmission-gtk xserver-xorg-core yelp
0 upgraded, 0 newly installed, 0 to remove and 40 not upgraded.
So...this is updates i can't install....

regards...

manishtech
September 17th, 2008, 06:31 PM
so first do a

sudo apt-get update

lswest
September 17th, 2008, 06:33 PM
Chances are these packages are missing a dependency and aren't being installed. You can force it, but I recommend just waiting til the dependencies are all there (they get packaged at different rates).

chanfle
September 17th, 2008, 06:36 PM
so....what i need to do...???

lswest
September 18th, 2008, 06:36 AM
so....what i need to do...???

Wait and check the updates later today, or tomorrow, and it should all work again.

Pumalite
September 18th, 2008, 12:59 PM
The second command is:
sudo apt-get dist-upgrade

lanr01
September 18th, 2008, 05:03 PM
so first do a

sudo apt-get update

when I try to do this, I get this error msg: IN fact anything I try to do in the terminal i get this error msg..


rick@Main:~$ sudo apt-get dist-upgrade
[sudo] password for rick:
rick is not in the sudoers file. This incident will be reported.
rick@Main:~$

Pumalite
September 18th, 2008, 05:15 PM
http://www.techotopia.com/index.php/Managing_Ubuntu_Linux_Users_and_Groups
http://ubuntuforums.org/showthread.php?t=865922
http://www.reallylinux.com/docs/usersubuntu.shtml