PDA

View Full Version : [ubuntu] Limited Display 800x600 problem



ycnano
September 15th, 2008, 09:29 PM
Hello,
I ve installed ubuntu and faced a problem with limited screen resolution to 640x480 and 800x600. My laptop has got NVIDIA GeForce Go 6150 driver with 1280 x 800.
I have tried to alter xorg-conf as prescribed in the similar problem thread.
But invain in my scnario. In System>administration>harwdware driver showing nothing and displays " no proprietary driver are in use on the system"

laptop:~$ xrandr -q
Screen 0: minimum 640 x 480, current 800 x 600, maximum 800 x 600
default connected 800x600+0+0 0mm x 0mm
800x600 61.0*
640x480 60.0

Looking for any solution from advance users.
Thanks and Regards

ajmorris
September 16th, 2008, 05:26 AM
hi there,
can you please run
sudo apt-get install nvidia-glx-new
and also paste your /etc/X11/xorg.conf file here. And the Output of sudo glxinfo.


AJ

ycnano
September 16th, 2008, 11:10 AM
Hi AJ,
I have installed nvidia-glx-new.
The below command and output are copied after installing the nvidia-glx-new.
Here are the details of glxinfo:
------------------------
name of display: :0.0
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x21 16 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x3a 32 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
-----------------------------------
Please find the xorg.conf details
----------
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Synaptics Touchpad"
EndSection
-______________________________________________


Re,
YC

tuxxy
September 16th, 2008, 11:13 AM
Heres a guide to gettin a 6600 card running, maybe it will be useful for your 6150

http://ubuntuforums.org/showthread.php?p=5795582#post5795582

bumanie
September 16th, 2008, 11:21 AM
I recently had my resolution stuck at 640x480. Booted into recovery mode and chose "attempt to fix xserver" that reconfigured everything. You could also try
sudo xfix in terminal.

ycnano
September 16th, 2008, 12:10 PM
Sorry doesnot find any command xfix.
I may need to try some other solution.

ycnano
September 16th, 2008, 12:12 PM
I tried with the link you have sent.
But while installing Nvidia by EnvyNG, it is throwing error "Nvidia card not found" while doing its compatibility check.
Again I am stuck.

Re,
YC

alienexplorers
September 16th, 2008, 12:50 PM
Have you tried running envyng and first deleting any nvidia drivers you have installed. Then run a manual install and pick the 96.xx.xx driver.
reboot after completion. Run from terminal:

gksudo nvidia-settings
to set up your screen resolution.

bumanie
September 16th, 2008, 01:02 PM
Are you using ubuntu 8.04? xifx is the updated method of the old 'dpkg-reconfigure xserver-xorg' so I am not sure why it doesn't seem to recognize the command. Did you try booting into recovery mode? My resolution issue and another forum member fixed our resolution problems by choosing 'attempt to fix xserver'.

rockerphil
September 16th, 2008, 01:43 PM
i had similar problems of having my resolution stuck at a very low and undesirable resolution. here's what worked for me. open up a terminal and run this:


sudo dpkg-reconfigure -phigh xserver-xorg

hope this helps,

Phil

ycnano
September 16th, 2008, 03:30 PM
I have tried this step many times but so far no solution.
YC

ajmorris
September 17th, 2008, 07:46 AM
strange, your xorg.conf file seems to be incomplete, could you please back it up, and add then edit it, to add to the top of the file, a new section:


Section "Module"
Load "glx"
Load "dbe"
Load "extmod"
Load "freetype
EndSection


I also don't like how the configuration tools in ubuntu configure the xorg.conf file, as you cant edit the graphics device section, without editing the whole thing, because of this "Configured Video Device" bit. So, if the above doesnt work, you might like to try configuring xorg.conf with nvidia-xconfig (installed by apt-get install nvidia-xconfig). If the problem is not rectified by this, and displayconfig-gtk is of no help to you, we may need to write the graphics device section manually, to enable the nvidia GLX module, and also argbxvisuals.

AJ

Kellemora
September 18th, 2008, 02:46 AM
Hi Ycnano

If perchance you are still stuck, you might try what I did in my article below.

My monitor had several resolutions, but ONLY one sometimes two would appear in the selection list, and IF I selected any other than what was there, the screen would roll sideways.

Here is my article: Good Luck!

Screen Resolution Problems? Easy fix!
Ubuntu 8.04 Hardy Heron

From a Noob for fellow Noobs!

Preliminary Note:
This document is to address Changing Screen Resolution using Preferences causes Screen to Roll horizontally, vertically or just mess up royally. Also, only 640 x 480 resolution available in Preferences. This fix may or may not allow you to select other available resolutions from the Preferences Option without changing MODE lines in /etc/X11/xorg.conf which I am not addressing here.
If this fix causes log-in screen obesity (HUGE SCREEN), see my other post titled Huge Log-in Screen? Easy fix! Which addresses that problem separately and easily.

To get started we need the Tool called Screens and Graphics.
If it is not available under Applications/Other, then RIGHT CLICK on Applications, select Edit Menu (left click) and wait for the Main Menu screen to open. From the Main Menu, left column (Menus) select 'Other' and a new list of text will appear in the right screen (items). Place a check mark in the box to the left of Screens and Graphics, this will automatically select 'Other' if it was NOT in your drop down list under Applications. Close this window.
You will have to REBOOT for the change to take affect.

Once you're up and running again, left click on Applications/Other/Screens and Graphics.
A log-in screen will appear, type your Normal log-in password. Why it don't ask for Root I don't know.

In the Screens and Graphics Preferences window select Graphics Card first just to check to make sure your correct graphics card is displayed. Normally these entries are correct, but check them anyhow!

OK, now select the Screen Tab and get things set up to run properly.

Click on the little Monitor icon to the right of Model: It may currently say Plug n Play. A new (Choose Screen) window opens, from the Left window, select the Manufacturer of your Monitor. The screen on the right will change to the models that manufacturer makes. Scroll through the list to find your Monitors model name and number and/or identification.
If you have an .inf driver for your particular monitor and it is not listed, select add and follow the directions there. I've not found a monitor not already in the listing yet. Then I never have many new things either, that might not be listed long before I get it, hi hi......... IF a Test button comes up, just IGNORE IT, because your screen will mess up royally. After selecting your monitor, select OK! This will bring you back to the Screen and Graphics Preferences screen.
Here you will select the desired resolution you would like your DESKTOP to run in. The proper bandwidth should self-select, but check to make sure it's right for your monitor. A wrong setting could damage your monitor!
Select OK and it will change and ask you if you want to Keep this setting. If all looks OK, select YES.
This change, and all the default parameters for your selected monitor WILL be written to the /etc/X11/xorg.conf file. Also, the Screens and Graphics window may show UNKNOWN for your monitor. The result of this Unknown Monitor or sometimes even if the Monitor is KNOWN and displays correctly the resultant change to the xorg.conf file, may cause your log-in screen to become OBESE (HUGE) and you might not be able to see your log-in boxes.

But don't worry, you KNOW they are there!
Just type in your log-in name, hit enter and type your password, hit enter and wait for the log-in to complete. Your xwindow (Gnome or others) should be at the desired resolution now.

IF you did have the HUGE log-in problem, see my post on Huge Log-in Screen? Easy fix!

The above was tested on the following machines with complete success:
HP Pavilion 753n, 2.53GHz Intel P4, 512mb, Intel 82845G/GL video, Samsung SyncMaster 955df.
e-machines T4165, 1.6GHz Intel P4, 256mb, AGP 3D video, AOC monitor.
Compaq 5420, 1.47GHz Athlon XP1700, Savage 4 AGP video, Samsung SyncMaster 3Ne.


TTUL
Gary/aka Kellemora
9/10/08 rev 9/15/08