PDA

View Full Version : [all variants] can't open threads like this- saved as .php



blesbok
September 15th, 2008, 07:44 AM
many forums' threads get saved as .php and fedora doesn't open them automatically; i think it's the same with ubuntu.
of course, i can save them by adding .htm, i.e. changing the automatic extension to .php.htm or rename them prior to opening them. is there some simple solution to enable such files to be opened automatically in Konqueror or Iceweasel? http://ubuntuforums.org/images/smilies/star.png

Vivaldi Gloria
September 15th, 2008, 12:13 PM
When I choose to save in ff in hardy it automatically saves this page as "showthread.php.html".

k33bz
September 15th, 2008, 12:29 PM
When I choose to save in ff in hardy it automatically saves this page as "showthread.php.html".

Same here

manishtech
September 15th, 2008, 02:01 PM
many forums' threads get saved as .php and fedora doesn't open them automatically; i think it's the same with ubuntu.
of course, i can save them by adding .htm, i.e. changing the automatic extension to .php.htm or rename them prior to opening them. is there some simple solution to enable such files to be opened automatically in Konqueror or Iceweasel? http://ubuntuforums.org/images/smilies/star.png
You mean when you open forum, the pages dont open instead you get a prompt to download the php file?

Archmage
September 15th, 2008, 02:10 PM
This sounds like something can't handle that much internet connections. Are you using P2P?

blesbok
September 16th, 2008, 10:14 AM
http://ubuntuforums.org/images/smilies/star.png

thanks for the replies; sorry this is so late. thought i was reloading the page but only reloaded my saved version! Last time i tried, the box was offline

to clarify, i'm using Gutsy 7.10 and Fedora 8
missed the chance last night to see what Gutsy 7.10 actually does, but Fedora will save this thread as .php by default.

Archmage, i'm not sure what P2P is (expect peer to peer).

manishtech, when i try to open a page saved as .php, Konqueror gives the "Open With" dialogue, rather than just displaying it.

may i add, this very thread, as i view it, has its smilies displayed as links eg."httb://ubuntuphorums.org/images/smylees/star.pmg"

:oops: :confused:

will appreciate any additional help in clearing up this minor irritation

manishtech
September 16th, 2008, 02:53 PM
when i try to open a page saved as .php, Konqueror gives the "Open With" dialogue, rather than just displaying it
Can you open it in firefox atleast?

blesbok
September 17th, 2008, 07:03 AM
manishtech, firefox will offer to open a .php file with a text editor, which is the default action

one can then choose open with => other, select the program from the file system and open it. if there's a suitable option, one can make it the default for every time, but i'm clueless what that option would be :(

the above is what happens on this fedora box but i suspect much the same for ubuntu. last mentioned's action for a php file is to throw the text up in the browser

thanks anyway for following up

manishtech
September 17th, 2008, 08:11 AM
I have faced such problems earlier, but only when I used to run LAMP stack on my system. It happened when the apache-php package was not installed. Additionally its caused when ownership is wrong, then it prompts for Open Dialog.

Am still not able to get why this is coming... :(

1. Is it so in windows also?
2. Is this save box coming only for some specific sites or all php files?

If its coming for all, then its the problem with system, if its coming for some specific, then it can be for server specific

blesbok
September 17th, 2008, 01:00 PM
with Windowsxp, i had no problems opening mynaming.showthread.php threads from sites like this one and unicyclist.com; forums.fedoraforums.org serves its threads as .html but i don't fault anyone on how they offer their files.
in other words, it's not for all sites (Q2)

i do have LAMP installed with fedora -- and it doesn't simply open .php -- but ubuntu 7.10 is pretty much out of the box

would appreciate knowing how to simply check for the apache-php package

PS Manishtech, i checked out your techblog :)

manishtech
September 17th, 2008, 01:15 PM
i do have LAMP installed with fedora -- and it doesn't simply open .php -- but ubuntu 7.10 is pretty much out of the box

You meant opening .php files? php files have to be run directly over the server. You cant directly open then by double-clicking. Well, we are going off topic.


would appreciate knowing how to simply check for the apache-php package
That's a local install which has no relation with the sites you browse on the net. I just stated it because I tried out running a server to check out this problem.


PS Manishtech, i checked out your techblog
Thanks! I dont update it often, nowadays thoughts and ideas have found its way there.

blesbok
September 17th, 2008, 08:24 PM
manishtech, thank you again for the interest

i'll just settle for changing that .php extension on threads i save; it's no major burden

it seems upgrading to hardy could be a solution, but as things stand, it would take over half a gig.

must be going; it's late here (South Africa) :-#

blesbok
September 19th, 2008, 09:54 AM
Eof :)