PDA

View Full Version : [ubuntu] HELP: Full screen switches automatically



ARhere
September 15th, 2008, 04:06 AM
A problem has been plaguing me since 7.04! When in full-screen mode (usually during a game), the application will suddenly switch to windowed mode for a few seconds, and then switch back to full screen. This bug/annoyance is very good at getting me killed when gaming.

It has been happening on 5 different PC with multiple hardware and OS configurations. It just happened while playing Super Tux 2, with nothing else installed besides updates on a new 8.04 build.

Anyone have an idea? Please share if you have the same problems.
-AR

pavel989
September 15th, 2008, 04:07 AM
drivers corrupt, bad hardware, or faulty setup for the game. what were the video cards, drivers, and did u check the settings for the game?

ARhere
September 15th, 2008, 09:29 PM
drivers corrupt, bad hardware, or faulty setup for the game. what were the video cards, drivers, and did u check the settings for the game?

I think I have almost ruled out those possibilities. I does this on 5 different PC's; hardware ranging from hard-core gaming box to a light Atom based PC.

Do me a favor and try it for yourself. Get a fresh install of 8.04,load updates + "I have no tomatoes", and play in full screen. After five minutes it will switch out from full screen to windowed mode, then back again.

-AR

Mornedhel
September 15th, 2008, 09:32 PM
Can confirm on Battle for Wesnoth, Compiz being enabled. Haven't tried without Compiz yet.

Didn't do it on Gutsy, too. With or without Compiz enabled.

ARhere
September 16th, 2008, 12:11 AM
Can confirm on Battle for Wesnoth, Compiz being enabled. Haven't tried without Compiz yet.

Didn't do it on Gutsy, too. With or without Compiz enabled.

Interesting, I did forget to mention that Compiz was enabled on all the boxes. Why would that screw with the game I am not sure, but will test it tonight.

-AR

ARhere
October 11th, 2008, 04:15 PM
Unsolved still and REALLY annoying!

I need bigger Linux heads then myself to please weigh in on this.

<PING> -AR

sdhoigt
October 21st, 2008, 03:03 AM
Same problem here when using Compiz. I notice it in BZFlag, Battle for Wesnoth, Neverball, etc.

Everything stays in fullscreen when not using Compiz.

Xubuntu 8.04. Some Nvidia chipset/series 5200 256 MB card.

SD

ARhere
October 24th, 2008, 03:00 AM
ok... at least we are confirming it.

If I can get a few more confirms then maybe I can subit a bug report; but first we need to establish a commonality or the software developers are going to scratch their heads.

Everyone that confirms this issue, post some general hardware specs please.

-AR

features
October 24th, 2008, 03:26 AM
I have noticed a similar behaviour while playing MAME games in fullscreen mode. I managed to fix it by disabling the screensaver while playing. Maybe this is the source of your problems?

ARhere
November 19th, 2008, 08:33 PM
I have noticed a similar behaviour while playing MAME games in fullscreen mode. I managed to fix it by disabling the screensaver while playing. Maybe this is the source of your problems?

Screen saver? That's an interesting notion. Why would the OS not see you using an app in full screen?

-AR