PDA

View Full Version : [ubuntu] Ubuntu Cannot Mount Internal HD



Gras$hoppa15
September 14th, 2008, 04:41 PM
Hello, I have an inspiron 1520 laptop, It runs xp home, recently i did the microsoft updates and upgraded to SP3 and got all the good stuff. However there was a problem, When i restarted my computer i get an error saying that windows did not start properly, and it gives the following options
Safe mode
safe mode with networking
safe mode with Command prompt
Start from previous config
Start normally

Now, i have chosen EACH one and it has come to a blue screen saying that windows cannot start, it advises to uninstall any anti virus programs and reboot it, However, i can't uninstall it without windows. So then i come to ubuntu, I have gotten ubuntu to load up and all i want to do now is to save some files off my internal HD, and then just reinstall xp itself, However, Ubuntu cannot mount my internal hard drive, It says that windows was not shut down properly and it gives examples on what to do, I can't do anything with windows so i just tried to do the Force mount, However then it says that i cannot mount it because i do not have root, i have tried using Sudo and it still won't work. I have checked my /dev/sda files and it says all of them are unreadable. I really don't want to install ubuntu because i have heard it deletes everything on the hard drive. but if anyone can help me, please post, PS. i am kind of new to linux and using the Terminal, and Reading the codes.