PDA

View Full Version : [ubuntu] my touchpad is on the fritz



PatrickMoore
September 12th, 2008, 02:46 AM
using ubuntu studio. my touchpad randomly clicks iten when i dont want it to this is incredibly annoying. im on a blog and every link is clicked for me even though i dont want to read it. anyone know how i can fix this or should i procure a mouse

PatrickMoore
September 12th, 2008, 04:09 AM
anyone?

chidorex
September 22nd, 2008, 09:02 PM
I have the same issue with my mouse, but in my case this happens with all mouse inputs, that is, with the touchpad and with external usb mice. Basically the mouse left-clicks randomly, which is a nuisance mostly while typing. :mad:

Anybody have an idea on how to resolve this? I run 8.04 Hardy on a Dell Inspiron 1420.

Patrick, have you tried with an external mouse? Does it only happen with the touchpad?

Thanks in advance.

dorite
September 22nd, 2008, 09:38 PM
Fritzy touchpad?

Nearly drove me crazy. I can't tell if you have the same problem that I did: cursor jumps unpredictably -- be composing an e-mail, typing in word-processing -- any program that understands mice and all of a sudden the insertion point would be somewhere it wasn't supposed to be. Never had a problem typing in a terminal.

To shorten a long story: I used (Ubuntu 8.04; from the top panel) System -> Preferences -> Mouse to get to the "Mouse Preferences" window, moved to the Touchpad tab, then UNchecked the "Enable mouse clicks with touchpad" box.

My problems went away. It seems that just brushing the touchpad was enough to move and click with it.

Hope this helps.

anotherdisciple
September 22nd, 2008, 10:00 PM
Try editing your Xorg instead of just turning off tap to click.

Make a backup of your Xorg just in case if you mess something up.


sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

Then edit your Xorg with gedit:


gksudo gedit /etc/X11/xorg.conf

Find your touchpad device section and add this to a new line about "EndSection"


Option "MaxTapTime" "1"

Change 1 to whatever works for you. That is controlling your tap to click sensitivity.

chidorex
September 23rd, 2008, 12:32 AM
Both alternatives sound great. I probably will turn off the touchpad as Dorite suggests to find out if this fixes the problem. Once identified, I might go with your MaxTapTime solution.

Thanks for your help.

anotherdisciple
September 23rd, 2008, 09:47 PM
Good stuff... If either one works can you post which one did and mark this thread as solved please?

Potters Son
September 24th, 2008, 01:21 AM
dorite says:
To shorten a long story: I used (Ubuntu 8.04; from the top panel) System -> Preferences -> Mouse to get to the "Mouse Preferences" window, moved to the Touchpad tab, then UNchecked the "Enable mouse clicks with touchpad" box

I have done that, and half the time I boot my computer, it ignores that command.

I'll try anotherdisciple's solution of editing xorg.conf. It's okay to add the code under the "Input Device" section, right? Under "synaptics touchpad?"

anotherdisciple
September 24th, 2008, 01:23 PM
dorite says:

I have done that, and half the time I boot my computer, it ignores that command.

I'll try anotherdisciple's solution of editing xorg.conf. It's okay to add the code under the "Input Device" section, right? Under "synaptics touchpad?"

Yep, it's okay. That's why I had you make a backup though... if things get really messed up you can just use the old configuration like this:


sudo mv /etc/X11/xorg.conf.backup /etc/apt/sources.list