PDA

View Full Version : USN-643-1: FreeType vulnerabilities



rss-bot
September 11th, 2008, 11:30 PM
Referenced CVEs:
CVE-2008-1806, CVE-2008-1807, CVE-2008-1808


Description:
================================================== ========= Ubuntu Security Notice USN-643-1 September 11, 2008 freetype vulnerabilities CVE-2008-1806, CVE-2008-1807, CVE-2008-1808 ================================================== ========= A security issue affects the following Ubuntu releases: Ubuntu 6.06 LTS Ubuntu 7.04 Ubuntu 7.10 Ubuntu 8.04 LTS This advisory also applies to the corresponding versions of Kubuntu, Edubuntu, and Xubuntu. The problem can be corrected by upgrading your system to the following package versions: Ubuntu 6.06 LTS: libfreetype6 2.1.10-1ubuntu2.5 Ubuntu 7.04: libfreetype6 2.2.1-5ubuntu1.2 Ubuntu 7.10: libfreetype6 2.3.5-1ubuntu4.7.10.1 Ubuntu 8.04 LTS: libfreetype6 2.3.5-1ubuntu4.8.04.1 After a standard system upgrade you need to restart your session to effect the necessary changes. Details follow: Multiple flaws were discovered in the PFB and TTF font handling code in freetype. If a user were tricked into using a specially crafted font file, a remote attacker could execute arbitrary code with user privileges or cause the application linked against freetype to crash, leading to a denial of service.





More... (http://www.ubuntu.com/usn/usn-643-1)