PDA

View Full Version : [ubuntu] Stop gnome panel from migrating?



kdevil
September 10th, 2008, 01:15 AM
I have a dual-monitor setup with an NVidia card, and I'm running into some problems with fullscreen games in Wine. I have TwinView set up with the following metamodes:
"CRT-0: nvidia-auto-select +0+0, CRT-1: 1280x1024 +1680+0; CRT-0: nvidia-auto-select +0+0, CRT-1: NULL"

That last one, with NULL for CRT-1, turns the right screen off so fullscreen games don't try to stretch themselves out onto both monitors. The problem is that when the right screen is turned off, the gnome panel on that screen decides to move itself over to my primary screen, and doesn't move back when the screen goes back on again (when I stop playing the game).

So every time I play a game, when I finish I have to drag that %^&* panel back over to the right screen! Is there any way to stop it from moving when the screen it belongs to is shut off?