PDA

View Full Version : [xubuntu] Trouble with Thunar Desktop icons



eumario
September 7th, 2008, 07:33 AM
Hello,

I'm having a bit of problem with Thunar and the Desktop Icons. launcher files, EG: .desktop, when I try to launch the file, it automatically opens up in Mousepad, instead of launching the application. Anyone have an Idea how I can possibly fix this? I've searched all over the internet, and can't find a single reference to this.

Thanks

kerry_s
September 7th, 2008, 08:18 AM
are they executable?

banewman
September 7th, 2008, 08:30 AM
Have you allowed xfwm to manage the desktop in applications-system settings - desktop?
I think the issue is getting desktop icons yes?
:)
The .desktop files are just text files afaik :)

eumario
September 7th, 2008, 02:26 PM
are they executable?

No, they aren't executable. I double checked and made sure all .desktop launchers are set to 0644, and there's still no luck. Thunar, if you launch them from the Desktop, or Launch them from a File Browsing window, will automatically open them up in Mousepad, as though that is the default association for the file.

eumario
September 7th, 2008, 02:28 PM
Have you allowed xfwm to manage the desktop in applications-system settings - desktop?
I think the issue is getting desktop icons yes?
:)
The .desktop files are just text files afaik :)

No, that's not the problem. Thunar is properly managing the Desktop Icons, cause I can see them, and other files on my desktop just fine, along with Trash, Home, Filesystem, Floppy Drive, even my Sansa E140 MP3 player shows up, no problems. It's the .desktop Launcher's that is having the problem.