PDA

View Full Version : [ubuntu] Xorg.conf projector problem



ndennen
September 3rd, 2008, 01:47 AM
Hello All!!

I am trying to use Ubuntu with a panasonic projector (pt-ax200u). It is not being detected with the auto detect feature and is defaulting to 640x480. I am using a nvidia 8600GT. I was trying to get both a monitor and the projector working, but have been unsuccessful. I am posting my xorg.conf. I have tried to modify xorg.conf and it still defaults to 640x480.

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "Device"
Identifier "Configured Video Device"
Boardname "nvidia"
Busid "PCI:1:0:0"
Driver "nvidia"
Screen 0
Option "NoLogo" "True"
EndSection

Section "Monitor"
Identifier "pt-ax200u"
Vendorname "panasonic"
modeline "1280x720@60" 74.30 1280 1312 1592 1624 720 735 742 757
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "pt-ax200u"
Defaultdepth 24
SubSection "Display"
Depth 24
#Modes "1280x720@60"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
EndSection
Section "Module"
Load "glx"
Load "v4l"
EndSection
Section "ServerFlags"
EndSection

thanks for your help!

Nate

overdrank
September 3rd, 2008, 12:38 PM
Hi and have you tried using the nvidia-settings to adjust?

ndennen
September 3rd, 2008, 10:03 PM
Yes i have tried using the nvidia server settings package. It does the same thing. Without automatic recognition of the monitor, it will only let you do 640x480 max resolution. It wont let me change it to something else - i thought it should let you change it manually, and force it to a resolution and refesh rate, but it does not. It only gives me those 2 options. Any ideas?

-Nate

GooglieS
September 28th, 2008, 10:26 AM
Any news? Did u solve the problem?

ndennen
November 9th, 2008, 12:38 AM
Hi all...

Still having this issue with my projector and Ubuntu. Wondering if anyone else has had any luck.

Thanks,

-Nate

ndennen
November 24th, 2008, 06:09 PM
OK,

I am not going to lie... i have NO idea why this is working now, but it is. I am NOT using the nvidia control pannel.

For some weird reason, ubuntu boot screen does not show up at all on my projector. I have to wait until it loads xserver to see anything. When i broke xserver by playing around with my xorg.conf file too much, i had to use another monitor to log in... I reconfigured xserver and restarted the machine.
When i unplugged the monitor and restarted it came up to a display wizard - this enabled me to choose the display type (generic lcd) and the resolution supported. Now it works! nvidia controls do not work, but i havnt played around with it much more in fear of breaking it!

Hope that helps someone. If you have any further questions please feel free to ask... ill try to be as helpful as possible.

-Nate

Bandit001
April 4th, 2009, 10:30 PM
Have same set up, and same problem. Never got it to work, so i switch back to Win xp . Wish I could get it working with Ubuntu. If you figured out anything else, please post it..
Thanks very much

GooglieS
April 6th, 2009, 05:32 PM
Use digital cable! DVI or HDMI! nVidia drivers detects all settings automaticaly i this case.

Maheriano
April 6th, 2009, 05:35 PM
I'm using the same video card with my projector, worked fine.

lubricus
July 26th, 2009, 11:52 AM
Same projector, different card (9600GT), but the following should still work.

I've set this projector up several times now (upgrading machine, hard drives, fresh jaunty install etc.) and each time I have to re-learn this but it works.

I find the MythTV modeline database (http://www.mythtv.org/wiki/Modeline_Database) very useful for these problems.

I agree with GooglieS, digital cabling is usually easiest, but there are cases where you can't use it. This projector doesn't have a DVI input, so that's out. In the case of my video card, I have a *fake* hdmi port (the card came with a DVI -> HDMI adapter. I suspect this is why my Nvidia driver (ver. 180.44) couldn't read the EDID.

According to the MythTV database, the Nvidia driver modepool (http://www.mythtv.org/wiki/Modeline_Database#NVIDIA_Driver_ModePool) does not have a proper 720p modeline. When I tried to set the resolution via nvidia-settings (remember to run it sudo!), it could never set the resolution.

So, you have to edit the xorg.conf (/etc/X11/xorg.conf) by hand (Note: if you run nvidia settings after this and "save to X configuration file", it will screw things up again.

The Mythtv modeline database has an entry for the PT-AX100U (http://www.mythtv.org/wiki/Modeline_Database#Panasonic_PT-AX100U_Projector), which works just fine for the PT-AX200U.

Edit the entry, restart X with the projector attached and on, and you should be good to go.

Here's my xorg.conf (using my projector and a LCD on a separate X screen)



# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@crested) Sun Feb 1 20:25:37 UTC 2009

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder62) Tue Mar 24 06:15:32 PST 2009
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
Screen 1 "Screen1" RightOf "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Module"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "KTC FP-988D"
HorizSync 31.0 - 80.0
VertRefresh 56.0 - 75.0
EndSection

Section "Monitor"
Identifier "Projector"
VendorName "Panasonic"
ModelName "PT-AX200U"
Option "DPMS"
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 87.0
ModeLine "1280x720@60" 74.160 1280 1308 1344 1672 720 725 730 750 -hsync -vsync
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 9600 GT"
BusID "PCI:1:0:0"
Screen 0
EndSection

Section "Device"
Identifier "Device1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 9600 GT"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultDepth 24
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "DFP: nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Device1"
Monitor "Projector"
DefaultDepth 24
Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "Projector"
# Option "metamodes" "1280x720@60 +0+0"
SubSection "Display"
Depth 24
Modes "1280x720@60"
EndSubSection
EndSection