View Full Version : [ubuntu] [SOLVED] can't install maple 12

September 2nd, 2008, 12:00 AM

recently purchased and downloaded Maple 12 (32-bit) for my Hardy box... i chmod +x'd it and then ran ./ to install.

however, when i did this, this was the output:

jmd9qs@jmd9qs-desktop:~/Desktop$ chmod +x Maple12Linux32Installer.bin
jmd9qs@jmd9qs-desktop:~/Desktop$ ./Maple12Linux32Installer.bin
Preparing to install...
Extracting the JRE from the installer archive...
Unpacking the JRE...
Extracting the installation resources from the installer archive...
The size of the extracted files to be installed are corrupted. Please
try to download the installer again and make sure that you download
using 'binary' mode.
Please do not attempt to install this currently downloaded copy.

can't find anything on their support site or google.... any help guys?

September 2nd, 2008, 12:54 AM
recently purchased and downloaded Maple 12 (32-bit)

did you buy this software on the net and if so did you use FTP to
download it to your machine ?

if yes then simply change the mode of the FTP product from ASCII to Binary as suggested by the given error report

try to download the installer again and make sure that you download
using 'binary' mode.


September 2nd, 2008, 05:37 AM
i did buy the software online, but not via FTP...

any other suggestions?

September 2nd, 2008, 06:44 AM
Don't know if this will help, but...
I just finished installing Maple12 on 40+ machines at work, but I ran the install from a CD, everything went fine . So the maple Linux installer work.
I guess that something went wrong when you downloaded.
Can you re-download?
Or if you know someone with a CD, or a good download you could use that.
As I understand it it's only the license.dat file that differs, and that is generated from your registration key during install. So as long as you use your own reg. key. it ought to be legal. (although I give no guarantees :) )

-- Jon

September 2nd, 2008, 06:52 AM
i don't have an install cd... i'm pretty sure if i try to download again they'll charge me again. i don't know... the download seemed to go fine, so i'm not sure if it is actually corrupted or not.

thanks for your help, though

September 2nd, 2008, 07:18 AM
I think what they charge you for is the registration key, but we have a site license here so I'm not really that familiar with the procedures.

Try mailing them though. Usually maplesoft are quite reasonable people.
And I guess that a bum download happens often enough, that they must have procedures in place.
After all any company ultimately lives off happy customers. :)

-- Jon

September 2nd, 2008, 07:24 AM
Ohh by the way if/when you get it installed, if you use compiz you will need to modify the xmaple script. Just add the following

somewhere above this line:

"${MAPLE}/bin/maple" -x $*

Maple aparently ships with some "funny" java libraries, text mode should work as is.

-- Jon

September 2nd, 2008, 07:28 AM

i am currently waiting for the download to finish (i finally said 'screw it' and came to the same conclusion: i'm paying for the registration key)... i'll update when possible.

by the way, can you tell me where that script is... still kind of a newbie and don't know my way around as well as i would like.

thanks for your continued help!

September 2nd, 2008, 07:47 AM
I am going to asume that you install maple in /opt/maple12 then the executable will be in
/opt/maple12/bin/ in this case you want to edit /opt/maple12/bin/xmaple so it looks like this:


# Copyright (c) 1993-2003 by Maplesoft, a division of Waterloo Maple Inc.
# All rights reserved. Unauthorized duplication prohibited.
# Permission is granted to modify this file to be appropriate
# for use at the installation for which Maple was purchased.

# This script runs Maple with the Java interface.


"${MAPLE}/bin/maple" -x $*
Next you probably want to include the maple-path in your path variable
Assuming that you use bash add the following lines into your ~/.bashrc

export PATH=$PATH:/opt/maple12/bin
Finaly if you want to user maple and latex, there is a number of maple styles for latex in /opt/maple12/etc

-- Jon

September 2nd, 2008, 08:06 AM
ok... the download was sucessfull and the install worked as well...

now, how do i start maple? i tried running maple, then maple 12 via terminal, but didn't work (tried as root, too, still no luck).

i chose the install path to be /root/maple12, and when i navigate to that point, i see all the maple folders and stuff, but can't find an executable icon.

what am i missing here?

September 2nd, 2008, 02:27 PM
If you installed to /root/maple12/
then your xmaple cam be startted from the command line by :


-- Jon

September 2nd, 2008, 04:05 PM
excellent... that worked great! thanks for your help.

September 3rd, 2008, 08:15 PM
You are quite welcome :)