PDA

View Full Version : [ubuntu] another "no sound" - M1330



TimDaniels
September 1st, 2008, 05:31 AM
My M1330 laptop has gone mute. Just test tones can be heard on headphones, loudest with OSS selected, but not at login or with any app. All is fine under Vista - just Ubuntu is mute. I checked muting on the volume control GUI and the LED button strip above the keyboard - nothing indicates muting. This started after a Dell field tech installed a new CD/DVD drive and a Dell phone rep had me install a new driver for it. The audio chip is a SigmaTel STAC9228, but the SigmaTel website doesn't have downloads available anymore. The kernel is 2.6.24.19-generic, and the BIOS is version A12.
1) Where can one get the Linux audio driver for the chip?
2) How does one install it in place of the current driver?
3) What settings should be made in System | Preferences | Sound?

I've done the usual Google and forum searches with no luck.
Any info would be appreciated.

*TimDaniels*

subzero27
September 1st, 2008, 06:19 AM
Have you tried contacting dell ???? maybe they would have an answer.

TimDaniels
September 1st, 2008, 07:21 AM
Have you tried contacting dell ???? maybe they would have an answer.

My laptop is not am "M1330n", i.e. not pre-installed with Ubuntu. It's an "M1330", i.e. pre-installed with Vista, so Dell tech support won't help me with Ubuntu problems. And, yes, I did call Dell, and the tech rep could only point me to Google and these forums.

*TimDaniels*

superm1
September 2nd, 2008, 05:12 AM
There are no "extra" drivers for the IDT audio chips in these machines. The ALSA included hda-intel driver has support for sigmatel codecs already.

If you are having issues, I would try a few things:

Clean up the ALSA state file
1) sudo /etc/init.d/alsa-utils stop
2) Remove /var/lib/alsa/asound.state
3) sudo /etc/init.d/alsa-utils start

Try booting off an Ubuntu 8.04 disk to rule out any configuration related issues
Things should come up by default with audio supported on the 1330.

TimDaniels
September 2nd, 2008, 08:06 PM
The sound is back and the Duck quacks again! You da Man, SuperM1!

What I did was essentilly your 1st suggestion:

sudo /etc/init.d/alsa-utils stop
sudo rm /var/lib/alsa/asound.state
sudo /etc/init.d/alsa-utils start


I also find that the single slider that appears by left-clicking the speaker icon has no effect except muting when the slider nears the bottom of its range. To get a slider that controls the sound level, I have to right-click the speaker icon and select "Open Volume Control", and for a slider to work, the Device type in the Volume Conrol panel must be either
"0: HDA Intel (Alsa mixer)" - for which I must use the "Master" slider with the other 2 sliders all the way up, or
"1: Sigmatel STAC9228 (OSS Mixer)" - which provides just one slider.
Is there a way to make the single slider that appears with a left-click on the speaker icon control the sound level?

*TimDaniels*

superm1
September 2nd, 2008, 08:12 PM
The sound is back and the Duck quacks again! You da Man, SuperM1!

What I did was essentilly your 1st suggestion:

sudo /etc/init.d/alsa-utils stop
sudo rm /var/lib/alsa/asound.state
sudo /etc/init.d/alsa-utils start
I also find that the single slider that appears by left-clicking the speaker icon has no effect except muting when the slider nears the bottom of its range. To get a slider that controls the sound level, I have to right-click the speaker icon and select "Open Volume Control", and for a slider to work, the Device type in the Volume Conrol panel must be either
"0: HDA Intel (Alsa mixer)" - for which I must use the "Master" slider with the other 2 sliders all the way up, or
"1: Sigmatel STAC9228 (OSS Mixer)" - which provides just one slider.
Is there a way to make the single slider that appears with a left-click on the speaker icon control the sound level?

*TimDaniels*
Yeah, just right click it and hit the preferences button. Pick the mixer you want.

TimDaniels
September 3rd, 2008, 06:28 PM
Is there a way to make the single slider that appears with a left-click on the speaker icon control the sound level?
Yeah, just right click it and hit the preferences button. Pick the mixer you want.

That worked! I didn't realize that "select a track" meant "select a slider". I guess I'm not cut out to be an audio engineer. :-)
Thanks, SuperM1.

*TimDaniels*

zaphodz
September 19th, 2008, 05:38 PM
Thanks for this guys :)

Sound works again on my Dell XPS M1330 :)

Much appreciated.

NuSuey
November 24th, 2008, 11:37 PM
Thank you very much ;) helped today when alsa didnt worked for the sound - only oss .. thanks ;)

SnowflakeRV7
January 21st, 2009, 08:54 PM
I just tried this on my XPS 1330 (no headphone output, but internal speakers work), and on the 'sudo /etc/init.d/alsa-utils start' line I got a bunch of "Invalid card number" errors from aumix. Drat. And still no sound out of the headphones.

SnowflakeRV7
February 25th, 2009, 06:32 AM
Still no joy with the headphone output on the Dell XPS 1330 running Ubuntu 8.10. Internal speakers work fine after installing the latest ALSA driver as recommended in other threads. Headphone output doesn't work at all (on either headphone jack) and when I plug in a pair of headphones the internal speakers don't automagically shut off like i'd expect them to.

Is *anyone* else experiencing this? I have never had so much trouble with this laptop as I have once switching from 8.04 to 8.10. The audio and HDMI were completely toasted by the upgrade, forcing a series of hacks to get them going again. Now running latest nVidia drivers to get HDMI out working, and latest ALSA drivers to get internal speakers working (and audio working over HDMI).

Which is anoying because all of this worked out-of-the-box when I installed 8.04 originally.

Sigh. The pains of running Linux sometimes make me wonder if it's worth it. :)

Yumi
March 3rd, 2009, 06:41 AM
Also get the "Invalid Card Number" Error. Any advice?

Michael

giorgio.stefanoni
March 19th, 2009, 08:43 AM
I have the very same problem, is there a way to fix this?

Giorgio

linuzo
April 10th, 2009, 04:48 PM
You need to force ubuntu to use the correct audio driver..

So do sudo nano /etc/modprobe.d/alsa-base

add the following line: options snd-hda-intel model=dell-3stack

Then save and restart alsa.

I was having really low sound and then when you do this and go to the sound manager in gnome you will see PCM and FRONT to be able to boost the sound. Hope this helps.

kernow
April 24th, 2009, 01:42 PM
I still can't seem to get any sound at all, not from speakers or headphnes, I was running hardy which I fixed the sound for no problems for ages. I've just done a fresh install (not upgrade) and now can't seem to get any sound working at all, and can't find any solutions
I'm running ibex now anyone got any other ideas?

dpolancom
June 8th, 2009, 03:38 AM
I finally could hear sounds but when I make the skype's test call I have to shout to hardly hear my voice. Any suggestions about improving the mic's volume?