PDA

View Full Version : [ubuntu] [SOLVED] Banshee doesn't release audio device



shingalated
August 31st, 2008, 01:59 PM
I have the new Banshee 1.2 and I love it, but if a friend sends me a youtube video or something and I pause my music to view it, it plays without sound. In order for the sound to play, I have to exit Banshee, and Firefox and get back in to Firefox. Is there a way to somehow make Banshee release the audio device as soon as it pauses?
Also...I am using flash player 10

lovinglinux
August 31st, 2008, 08:44 PM
I have the same problem pausing a YouTube video and trying to open a local video with any player. If I close the YouTube page the audio device is released.

minky311
August 31st, 2008, 09:26 PM
Could both of you press alt F2 type in gstreamer-properties and tell me what it says next to pipeline under default output?

Dysphoria
August 31st, 2008, 09:33 PM
I have the same issues with many combinations of sound and video, not just the banshee / YouTube example. Default Output Pipeline says "alsasink".

lovinglinux
August 31st, 2008, 09:43 PM
Could both of you press alt F2 type in gstreamer-properties and tell me what it says next to pipeline under default output?

autoaudiosink

minky311
September 1st, 2008, 01:18 AM
Press Alt and F2 type in gstreamer-properties and then press run.
For default output change plugin to alsa and for the devices try each one at a time and test it by trying to open two different programs up at the same time.

shingalated
September 1st, 2008, 06:25 PM
I changed plugin from auto to ALSA, it didn't help. Pipeline is alsasink.

minky311
September 1st, 2008, 07:42 PM
Could you play something in banshee and then pause it, open up firefox in the terminal by going to Applications->Accessories->Terminal and typing in firefox and if there are any errors that appear in the terminal when you visit a website that uses flash like youtube could you post the errors here.

shingalated
September 3rd, 2008, 02:57 AM
I changed the Device from auto to something...digital and it now works perfect :-D

lovinglinux
September 3rd, 2008, 03:06 AM
I changed the Device from auto to something...digital and it now works perfect :-D

Were did you do that?

minky311
September 3rd, 2008, 03:36 AM
I'm pretty sure he pressed alt f2 typed in gstreamer-properties and changed the device there under Default Output.

lovinglinux
September 3rd, 2008, 04:19 AM
Still doesn't work for me.

minky311
September 3rd, 2008, 04:43 AM
I would make sure everything is set to Alsa in System->preferences->sound and then going to gstreamer-properties and trying different devices.

Salomonis
September 3rd, 2008, 11:26 AM
I'm having the same problems. What is it suppose to say in preferences-sound?
in gstreamer-properties it's under ALSA but the device is unsupported and the pipeline is autoaudiosink. the test works.

Salomonis
September 3rd, 2008, 11:28 AM
I take that back. the test works under properties/sound but not under gstreamer- properties. maybe I need more gstreamer codecs?

Salomonis
September 3rd, 2008, 11:47 AM
Ignore my posts got it to work by switching everything to ALSA under properties