PDA

View Full Version : [ubuntu] transcoding AVI files with fuppes (need help)



Tails Prower
August 30th, 2008, 10:14 PM
I've set up fuppes on my ubuntu server to stream media to my PS3. The connection is there, and I can play mpg and mp3 files, but when I navigate to an AVI file, the XMB(ps3 file browser) refers to the title as 'unsupported data' I've scoured forums and done all the edits I can to my fuppes.cfg file, can anyone see a mistake I'm making?





<?xml version="1.0" encoding="UTF-8"?>
<fuppes_config version="0.7.2.3">
<shared_objects>
<dir>/media/launch_base</dir>
<!--<dir>/mnt/music</dir>-->
<!--<itunes>/Users/.../iTunes.xml</itunes>-->
</shared_objects>
<network>
eth0
<interface>192.168.1.75<interface/>
<!--empty or 0 = random port-->
<http_port/>
<!--list of ip addresses allowed to access fuppes. if empty all ips are allowed-->
<allowed_ips>
<!--<ip>192.168.0.1</ip>-->
</allowed_ips>
</network>
<content_directory>
<!--a list of possible charsets can be found under:
http://www.gnu.org/software/libiconv/-->
<local_charset>UTF-8</local_charset>
<!--libs used for metadata extraction when building the database. [true|false]-->
<use_imagemagick>true</use_imagemagick>
<use_taglib>true</use_taglib>
<use_libavformat>true</use_libavformat>
</content_directory>
<transcoding>
<!--[lame|twolame]-->
<audio_encoder>lame</audio_encoder>
<!--[true|false]-->
<transcode_vorbis>true</transcode_vorbis>
<transcode_musepack>true</transcode_musepack>
<transcode_flac>true</transcode_flac>
</transcoding>
<device_settings>
<!--"default" settings are inhertied by specific devices and can be overwritten-->
<!--do NOT remove the "default" device settings-->
<device name="default">
<!--specify the maximum length for file names (0 or empty = unlimited)-->
<max_file_name_length>0</max_file_name_length>
<!--[file|container]-->
<playlist_style>file</playlist_style>
<show_childcount_in_title>false</show_childcount_in_title>
<enable_dlna>true</enable_dlna>
<transcoding_release_delay>4</transcoding_release_delay>
<file_settings>
<!--audio files-->
<file ext="mp3">
<type>AUDIO_ITEM</type>
<mime_type>audio/mpeg</mime_type>
<dlna>MP3</dlna>
</file>
<file ext="ogg">
<type>AUDIO_ITEM</type>
<mime_type>application/octet-stream</mime_type>
<transcode enabled="true">
<ext>mp3</ext>
<mime_type>audio/mpeg</mime_type>
<dlna>MP3</dlna>
<http_encoding>chunked</http_encoding>
<decoder>vorbis</decoder>
<encoder>lame</encoder>
<bitrate>192</bitrate>
<samplerate>44100</samplerate>
</transcode>
</file>
<file ext="mpc">
<type>AUDIO_ITEM</type>
<mime_type>application/octet-stream</mime_type>
<transcode enabled="true">
<ext>mp3</ext>
<mime_type>audio/mpeg</mime_type>
<dlna>MP3</dlna>
<http_encoding>chunked</http_encoding>
<decoder>musepack</decoder>
<encoder>lame</encoder>
<bitrate>192</bitrate>
<samplerate>44100</samplerate>
</transcode>
</file>
<file ext="wav">
<type>AUDIO_ITEM</type>
<mime_type>audio/x-wav</mime_type>
</file>
<file ext="flac">
<type>AUDIO_ITEM</type>
<mime_type>audio/x-flac</mime_type>
<transcode enabled="true">
<ext>mp3</ext>
<mime_type>audio/mpeg</mime_type>
<dlna>MP3</dlna>
<http_encoding>chunked</http_encoding>
<decoder>flac</decoder>
<encoder>lame</encoder>
<bitrate>192</bitrate>
<samplerate>44100</samplerate>
</transcode>
</file>
<file ext="wma">
<type>AUDIO_ITEM</type>
<mime_type>audio/x-ms-wma</mime_type>
<dlna>WMAFULL</dlna>
</file>
<dlna>WMAFULL</dlna>
</file>
<!--image files-->
<file ext="jpg">
<ext>jpeg</ext>
<type>IMAGE_ITEM</type>
<mime_type>image/jpeg</mime_type>
<convert enabled="false">
<!--<dcraw enabled="true">-q 0</dcraw>-->
<ext>png</ext>
<mime_type>image/png</mime_type>
<height>0</height>
<width>0</width>
<!--set "greater" to "true" if you only want to resize images greater than "height" or "width"-->
<greater>false</greater>
<!--set "less" to "true" if you only want to resize images less than "height" or "width"-->
<less>false</less>
<!--set "less" and "greater" to "false" if you always want to resize-->
</convert>
</file>
<file ext="bmp">
<type>IMAGE_ITEM</type>
<mime_type>image/bmp</mime_type>
</file>
<file ext="png">
<type>IMAGE_ITEM</type>
<mime_type>image/png</mime_type>
</file>
<file ext="gif">
<type>IMAGE_ITEM</type>
<mime_type>image/gif</mime_type>
</file>
<!--video files-->
<file ext="mpg">
<ext>mpeg</ext>
<type>VIDEO_ITEM</type>
<mime_type>video/mpeg</mime_type>
</file>
<file ext="mp4">
<type>VIDEO_ITEM</type>
<mime_type>video/mp4</mime_type>
</file>

<file ext="avi">
<type>VIDEO_ITEM</type>
<mime_type>video/x-msvideo</mime_type>
<transcode enabled="true">
<transcoder>ffmpeg</transcoder>
<ext>wmv</ext>
<mime_type>video/x-ms-wmv</mime_type>
<video_codec>wmv2</video_codec>
<audio_codec>wmav1</audio_codec>
<video_bitrate>1800000</video_bitrate>
<audio_bitrate>128000</audio_bitrate>
</transcode>
</file>


<file ext="wmv">
<type>VIDEO_ITEM</type>
<mime_type>video/x-ms-wmv</mime_type>
</file>
<file ext="vob">
<type>VIDEO_ITEM</type>
<mime_type>video/x-ms-vob</mime_type>
</file>
<file ext="vdr">
<type>VIDEO_ITEM</type>
<mime_type>video/x-extension-vdr</mime_type>
<transcode enabled="true">
<ext>vob</ext>
<mime_type>video/x-ms-vob</mime_type>
</transcode>
</file>
<file ext="flv">
<type>VIDEO_ITEM</type>
<mime_type>application/x-flash-video</mime_type>
</file>
<file ext="asf">
<type>VIDEO_ITEM</type>
<mime_type>video/x-ms-asf</mime_type>
</file>
<!--playlists-->
<file ext="pls">
<type>PLAYLIST</type>
<mime_type>audio/x-scpls</mime_type>
</file>
<file ext="m3u">
<type>PLAYLIST</type>
<mime_type>audio/x-mpegurl</mime_type>
</file>
</file_settings>
</device>
<!--If you have more than one device it is a good idea to set the ip address manually as some devices may have conflicting "user agents".-->
<!--It is safe to remove unneeded devices-->
<device name="PS3" enabled="true">
<user_agent>UPnP/1.0 DLNADOC/1.00</user_agent>
<user_agent>PLAYSTATION3</user_agent>
<!--<ip></ip>-->
<enable_dlna>true</enable_dlna>
<transcoding_release_delay>50</transcoding_release_delay>
<file_settings>
<file ext="ogg">
<type>AUDIO_ITEM_MUSIC_TRACK</type>
<transcode enabled="true">
<http_encoding>stream</http_encoding>
</transcode>
</file>
</file_settings>
</device>
<device name="Xbox 360" virtual="Xbox 360" enabled="false">
<user_agent>Xbox/2.0.\d+.\d+ UPnP/1.0 Xbox/2.0.\d+.\d+</user_agent>
<user_agent>Xenon</user_agent>
<xbox360>true</xbox360>
</device>
<device name="Noxon audio" virtual="default" enabled="false">
<!--Please enter the address of your Noxon. Automatic detection is impossible because the Noxon does not send a "user-agent" in it's requests-->
<!--<ip></ip>-->
<playlist_style>container</playlist_style>
<show_childcount_in_title>true</show_childcount_in_title>
</device>
<device name="Telegent TG 100" virtual="default" enabled="false">
<user_agent>dma/1.0 \(http://www.cybertan.com.tw/\)</user_agent>
<user_agent>UPnP/1.0 DLNADOC/1.00</user_agent>
<playlist_style>file</playlist_style>
<max_file_name_length>101</max_file_name_length>
</device>



thanks,
tails

gillani
October 21st, 2008, 05:08 AM
Try adding the following above the playstation setup in the fuppes.cfg

<file ext="avi">
<type>VIDEO_ITEM</type>
<mime_type>video/x-divx</mime_type>
</file>


This fixes most of the avi's but I still have a few (1 out of 20) that still don't play.

Good luck.