PDA

View Full Version : [kubuntu] Nvidia 8400m gs Driver on Dell 1520 Problems



jRadishness
August 28th, 2008, 05:33 PM
Hello, this is my first post and I am a pretty new Linux owner. I have a buddy who has been helping me with my install and so far everything works except the video. I guess I'll start by telling you what I have.

I have a Dell Inspiron 1520.
Kubuntu 8.04
Kernel 2.6.24-19-generic
Nvidia 8400M GS
Even the Card reader and the Bluetooth work fine.

When I installed Kubuntu originally it tried to download what it thought was the proper driver and I got a gray screen when I tried to log in. So I had my friend teach me to use the terminal to switch to the VESA driver long enough to find the proper driver online, and eventually I found the NVIDIA-Linux-x86_64-173.14.12-pkg2.run driver at http://www.nvidia.com/object/linux_display_amd64_173.14.12.html. This driver has worked fine when it works. The problem is that twice now in the last week since I've had Kubuntu installed, I will turn on the computer only to find that the Login Screen won't load. I instead get sent to the terminal where it tells me the screen failed to load. So I change my driver in Xorg back to nv long enough to download the driver from Nvidia and install it again. After the install I reboot and get the Nvidia splash screen and everything works peachy again for a couple days until I boot one day and it fails again.

I guess my question is.. Am I doing something wrong? Is this the wrong driver? Is my xorg probably corrupt?

Anything I can post I will to get this figured out. Thank you in advance for your time and help.

jRadishness
September 2nd, 2008, 04:59 PM
Okay, today when I try to reload the driver it tells me it has successfully finished but I cant get back into the GUI. I have copied my xorg file in case there is something in there that I have wrong. Obviously the driver is set to nv at the moment, but normally it would be "Nvidia" Sorry for copying the whole xorg file, I dont know how to copy into a scrolling window like so many do so nicely. Thank you in advance for any advice you may have.

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder58) Thu Jul 17 18:39:00 PDT 2008


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 150.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nv"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Wolfhere
September 6th, 2008, 03:48 AM
While in vesa mode, download and install EnvyNG. Then from the applications menu, find EnvyNG and either go automatic or manually select the 174.14.12. After a reboot, you should be fine.

I have fought and reinstalled Ubuntu 8.04 several times over the video (through my docking station). Without my laptop docked, the Envy driver load is pretty slick. No dropping out to a terminal session and running the sh command. There is a splash screen that you can disable in the xorg.conf...but leaving it is pretty painless. My video card is Quadro NVS 110N on a D620. I hear that the new kernal fixes or will fix docking/video issues...I will wait.