PDA

View Full Version : [ubuntu] error message: E: dpkg was interrupted,



rm2011
August 24th, 2008, 03:59 PM
Hi,
I am just starting with ubuntu Hardy. It says there are 84 updates available, so i try to install them. When i try to install them i get this error message: E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report


I tried opening terminal and running this, but it says "dpkg requires superuser privilege. I dont now what this means, and can not figue out where to go from here. :confused:

Barrucadu
August 24th, 2008, 04:01 PM
Prefix the command with sudo:

sudo dpkg --configure -a

You will need to type your password. It won't show on the screen, but it is being entered. Just type it and press enter when done.

Ryadt
August 24th, 2008, 04:01 PM
Hi,
I am just starting with ubuntu Hardy. It says there are 84 updates available, so i try to install them. When i try to install them i get this error message: E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report


I tried opening terminal and running this, but it says "dpkg requires superuser privilege. I dont now what this means, and can not figue out where to go from here. :confused:

Do in terminal
sudo dpkg --configure -a

Kevbert
August 24th, 2008, 04:02 PM
What you need to do in terminal is use

sudo dpkg --configure -a
in terminal. While you're at it use

sudo apt-get install -f
to repair any damaged packages as well as

sudo apt-get update

aysiu
August 24th, 2008, 04:03 PM
Or, instead of typing the command, you can also copy and paste it.