PDA

View Full Version : [xubuntu] Screen resolution is off



MISIIM
August 23rd, 2008, 03:09 PM
I have a gateway laptop with a widescreen display.

I have the same issue as this post (http://ubuntuforums.org/showthread.php?p=5519365#). The command
xrandr --output TV --off
worked. However I can't get xorg.conf to work properly.





# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Synaptics Touchpad"
EndSection

libra1780
August 24th, 2008, 03:01 AM
there is no driver specified in your conf so xorg would use vesa whitch does not support widescreen

add this line to you conf at the end of device section



driver "i810"


maybe you would like to set the available video modes as well.. add this to the end of your screen section



Defaultdepth 24
SubSection "Display"
Depth 24
Modes "1280x768@60" "1280x720@60" "800x600@60" "800x600@56"
EndSubSection


your tv-out is not configured so you normally don't have to concern with,.. normally

ohh. i forgot, if you have 7.04 or above use "intel" instead of "i810"