PDA

View Full Version : [gnome] How-to : Solving the "too low refresh-rate reported in gnome" on Nvidia-cards



ZarathustraDK
August 21st, 2008, 02:04 AM
I've finally figured out a problem that has been plaguing me for...well...forever. A lot of people on Nvidia cards know what I'm talking about. You log into Ubuntu and check out the refresh rate, it's too low. Flat-screen users usually get to choose from 50-52 Hz where it should be 60 Hz, and nothing can seem to fix it, apt-get install dpkg-reconfigure xserver-xorg doesn't work, modelines don't work, but it's always the solution you get stuck with in the end. It never worked for me, and I was stuck at that annoying refresh rate which was very visible when running Compiz-fusion.

Then I stumbled across this https://bugs.launchpad.net/ubuntu/+source/linux-restricted-modules-2.6.20/+bug/92599 .

Basically, the fault is within the nvidia-glx-new driver regarding DynamicTwinview (well, the Nvidia guys think it's Gnomes fault). Anyway the solution is simple, add this to your xorg.conf under the device-section:


Option "DynamicTwinView" "false"

Then restart X and voíla.

Here's my xorg.conf for reference :


# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@vernadsky) Thu Jun 5 09:26:53 UTC 2008

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "dk"
EndSection


Section "Monitor"
# HorizSync source: xconfig, VertRefresh source: xconfig
Identifier "Monitor0"
VendorName "Unknown"
ModelName "LG L194WT"
HorizSync 56.0 - 75.0
VertRefresh 28.0 - 83.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "Coolbits" "1"
Option "ConnectedMonitor" "DFP"
Option "DynamicTwinView" "false" <--------- Right there!
VendorName "NVIDIA Corporation"
BoardName "GeForce 7800 GT"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
## Option "TwinView" "0"
## Option "metamodes" "DFP-0: 1440x900_60 +0+0; DFP-0: 1440x900_60 +0+0"
Option "RenderAccel" "True"
Option "AddARGBGLXVisuals" "True"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection


Try it out ):P