PDA

View Full Version : [ubuntu] Svideo screen clone on Hardy problem



viralata00
August 1st, 2008, 11:27 AM
hello,

I want to clone my screen to a TV, and here is my xorg.conf file:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "pt"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
EndSection

Section "Device"
Identifier "SVIDEO"
Driver "i810"
Option "MonitorLayout" "TV,LFP"
Option "FlipPrimary" "True"
Option "TVStandard" "PAL-G"
Option "TVOutFormat" "SVIDEO"
Option "ConnectedMonitor" "TV"
Option "Clone" "True"
BusID "PCI:0:2:0"
EndSection

Section "Monitor"
Identifier "LCD"
Option "DPMS"
HorizSync 30 - 81
VertRefresh 56 - 76
EndSection

Section "Monitor"
Identifier "TV"
HorizSync 30-50
VertRefresh 60
EndSection

Section "Screen"
Identifier "TV"
Device "SVIDEO"
Monitor "TV"
DefaultDepth 24

SubSection "Display"
Depth 24
Modes "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "LCDandTV"
Screen "TV"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Synaptics Touchpad"
Option "AIGLX" "true"
EndSection

Section "ServerFlags"
Option "DefaultServerLayout" "LCDandTV"
EndSection


The laptop LCD works fine with this configuration, but the TV is pitch black. The TV gets something cause it changes from EXT2 to SVHS2.

what is the problem?