PDA

View Full Version : [ubuntu] No sound?



FLCL
July 28th, 2008, 07:07 PM
after i installed virtualbox, and restarted my system i lost all my sound.

I get these messages wen i click the audio icon.
http://imagedash.com/images/jdv1217187097x.png

http://imagedash.com/images/arx1217140254z.png

This is the icon shown:
http://imagedash.com/images/opt1217140116i.png

Can anyone please help me get audio back? :(

ChildOfMana
July 28th, 2008, 07:12 PM
Did you by any chance install something called virtualbox-ose-modules?

FLCL
July 28th, 2008, 07:15 PM
Yeah, i think so. I followed this help document. Im running Hardy 8.04
https://help.ubuntu.com/community/VirtualBox

ChildOfMana
July 28th, 2008, 07:20 PM
Okay. I had more or less the same problem. Fairly easy to fix though so let's have a go...

Firstly though, can you type;


sudo uname -r

into a terminal to see what kernel is currently in use?

Post the output here.

FLCL
July 28th, 2008, 07:22 PM
I get 2.6.24-19-generic

ChildOfMana
July 28th, 2008, 07:26 PM
Hmmmm? That's as it should be - so your problem doesn't lie with the kernel version (which mine did).

Back to basics!

Have you tried a complete purge and re-install?

ChildOfMana
July 28th, 2008, 07:30 PM
Have you tried a complete purge and re-install?

Sorry, I should be more specific - I meant a complete purge of the kernel module you installed.

FLCL
July 28th, 2008, 07:31 PM
No, thats my last resort. Im trying to avoid that bit.

FLCL
July 28th, 2008, 07:42 PM
Do you mean the sound module? Or something else?
If it's the sound module, i believe i have, but i could be mistaken.

ChildOfMana
July 28th, 2008, 07:43 PM
Okay you might be best checking this thread:

http://ubuntuforums.org/showthread.php?t=855544

Check the posts by kansasnoob and see if that turns up any useful info.

I'm afraid I'm no authority on sound in Linux (or anywhere for that matter!!).

It sounded at first like you had exactly the same problem I once had but it seems yours is different.

However, post back here if you can't find a more gentle solution and I'll help you to purge and remove the offending packages.

After that you can check this thread http://ubuntuforums.org/showthread.php?t=770745 out for an alternative way to install and configure virtualbox (which worked for me post-sound crisis).

Sorry I couldn't be of more help.

ChildOfMana
July 28th, 2008, 07:46 PM
You could also try here too;

http://ubuntuforums.org/showthread.php?t=205449

Hope this helps.

FLCL
July 28th, 2008, 07:49 PM
alright, thank you. Ill check back if i cant get anything

kitplayer
July 28th, 2008, 08:30 PM
Comprehensive Sound Problem Solutions Guide v0.5e
http://ubuntuforums.org/showthread.php?t=205449


posted by ChildOfMana

is the best audio solution ive found so far. easy to follow, use, and fixed my prob instantly.

this should be highlighted as the best audio solution for newbies as i have only been using ubuntu for 15mins

FLCL
July 28th, 2008, 09:48 PM
Meh..i already followed it and it didnt work. Tried compiling my own drivers, that failed too.Posted in the thread, no reply yet, it's on page 106. This is a disaster.

What could be the cause of this problem?
Some specs: Asus A7V400-MX mobo, using onboard sound. Soudmax is what the card uses i guess.

-multimedia UNCLAIMED
description: Multimedia audio controller
product: VT8233/A/8235/8237 AC97 Audio Controller
vendor: VIA Technologies, Inc.
physical id: 11.5
bus info: pci@0000:00:11.5
version: 50
width: 32 bits
clock: 33MHz
capabilities: pm cap_list
configuration: latency=0

Also running the command "aplay -l"
returns the following:

aplay: device_list:205: no soundcards found...

So yeah. Please somebody help me. It's horrible without sound.

FLCL
July 28th, 2008, 09:49 PM
oops. *double deleted*

FLCL
July 28th, 2008, 11:30 PM
bump