PDA

View Full Version : [ubuntu] This aumix script won't work with "Run In Terminal"



YAOMTC
July 21st, 2008, 01:49 AM
I have here an aumix script I got from Whiffle last year (it toggles the headphones between muted and unmuted):

#\bin\bash
aumix -Wq |grep -q 100
if [ $? == 0 ]; then
aumix -W mute
else
aumix -W 100
fi
When I open up a terminal and enter ./headphones.sh, the script works. However, if I go to the script in Nautilus and try Open in Terminal, it doesn't do anything. When I set it as Application in Terminal for a panel launcher, it only unmutes, and won't mute. Does anyone know why this might be?

YAOMTC
July 21st, 2008, 07:19 PM
Bump 1/≥7

YAOMTC
July 22nd, 2008, 08:57 PM
Bump 2/≥7

YAOMTC
July 23rd, 2008, 06:26 AM
Bump 3/≥7

mcduck
July 23rd, 2008, 09:11 AM
The "Open in terminal" is not for running scrpits or anything. It simply opens the loaction you are browsing with Nautilus in a terminal.

If you want to run the scipt from Nautilus it should be possible simply by double-clicking the script.

YAOMTC
July 23rd, 2008, 04:40 PM
So there's no way of running a script from the top panel?

YAOMTC
July 23rd, 2008, 08:43 PM
Bump 4/≥7

mcduck
July 23rd, 2008, 09:11 PM
For the launcher, set the type to "application in Terminal" (or whatever it was..), although the script should work even without that, you just can't see anything happening without the terminal window..

YAOMTC
July 23rd, 2008, 09:16 PM
For some reason, as an "Application in Terminal" will only unmute the headphones, whereas if I go into a terminal and enter ./headphones.sh, it'll do both mute and unmute.

YAOMTC
July 24th, 2008, 03:46 AM
Bump 5/≥7

YAOMTC
July 25th, 2008, 12:36 AM
Bump 6/≥7

YAOMTC
July 27th, 2008, 05:10 AM
Bump 7/≥7

Last bump.