PDA

View Full Version : [ubuntu] "Out of frequency" error whilst running games



edd8990
July 8th, 2008, 11:30 PM
Hey guys.

I'm trying to get my Unreal Tournament 2004 fix, but I can't. Whenever I run the game, The screen goes black, and the monitor displays it's "Out of frequency" error. The menu sounds play in the background fine, so the game is running, but I can't get it to run. I had a similar issue running some games under wine a few months, but I bypassed it by running wine in desktop mode, leaving the programs windowed. But now I have some free time, I'd rather fix the problem properly!

I'm running Ubuntu 8.04, My gfx card is an Nvidea 7900GS, and my monitor is a HannsG HN198D. In case it helps, I've posted my xorg.conf below:


# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "auto"
Option "Buttons" "7"
Option "ZAxisMapping" "4 5"
Option "ButtonMapping" "1 2 3 6 7 4 5 6"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
Identifier "nVidia Corporation G71 [GeForce 7900 GS]"
Driver "nvidia"
Busid "PCI:1:0:0"
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
Option "NoLogo" "True"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
Horizsync 31-80
Vertrefresh 55-75
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation G71 [GeForce 7900 GS]"
Monitor "Generic Monitor"
Defaultdepth 24
SubSection "Display"
Depth 24
Modes "nvidia-auto-select"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
Inputdevice "Generic Keyboard"
Inputdevice "Configured Mouse"

# Uncomment if you have a wacom tablet
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
EndSection
Section "Module"
Load "glx"
EndSection


Help would be greatly appreciated :)

Prefix100
July 9th, 2008, 12:19 AM
+1 to the issue above.