PDA

View Full Version : [ubuntu] Important Security Updates won't activate



WonderStivi
July 8th, 2008, 08:50 AM
I've recently reinstalled Ubuntu, and noticed just now that for some reason the important security updates won't let themselves be activated. When I click the check box, it just blinks orange for a fraction of a second, and remains deactivated. Anyone know a fix for this?

Rocket2DMn
July 8th, 2008, 09:01 AM
Can you please post your sources.list file?

cat /etc/apt/sources.list

WonderStivi
July 8th, 2008, 09:03 AM
# deb cdrom:[Ubuntu 8.04 _Hardy Heron_ - Release amd64 (20080423)]/ hardy main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://no.archive.ubuntu.com/ubuntu/ hardy main restricted
deb-src http://no.archive.ubuntu.com/ubuntu/ hardy restricted main multiverse universe #Added by software-properties

## Major bug fix updates produced after the final release of the
## distribution.
deb http://no.archive.ubuntu.com/ubuntu/ hardy-updates main restricted
deb-src http://no.archive.ubuntu.com/ubuntu/ hardy-updates restricted main multiverse universe #Added by software-properties

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
deb http://no.archive.ubuntu.com/ubuntu/ hardy universe
deb http://no.archive.ubuntu.com/ubuntu/ hardy-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://no.archive.ubuntu.com/ubuntu/ hardy multiverse
deb http://no.archive.ubuntu.com/ubuntu/ hardy-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://no.archive.ubuntu.com/ubuntu/ hardy-backports main restricted universe multiverse
deb-src http://no.archive.ubuntu.com/ubuntu/ hardy-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository. This software is not part of Ubuntu, but is
## offered by Canonical and the respective vendors as a service to Ubuntu
## users.
deb http://archive.canonical.com/ubuntu hardy partner
deb-src http://archive.canonical.com/ubuntu hardy partner

deb http://security.ubuntu.com/ubuntu hardy-security main restricted
deb-src http://security.ubuntu.com/ubuntu hardy-security main restricted
deb http://security.ubuntu.com/ubuntu hardy-security universe
deb-src http://security.ubuntu.com/ubuntu hardy-security universe
deb http://security.ubuntu.com/ubuntu hardy-security multiverse
deb http://security.ubuntu.com/ubuntu/ hardy-security restricted main multiverse universe
deb-src http://security.ubuntu.com/ubuntu/ hardy-security restricted main multiverse universe
deb http://no.archive.ubuntu.com/ubuntu/ hardy-proposed restricted main multiverse universe
deb-src http://no.archive.ubuntu.com/ubuntu/ hardy-proposed restricted main multiverse universe #Added by software-properties
deb-src http://security.ubuntu.com/ubuntu hardy-security multiverse

iaculallad
July 8th, 2008, 09:06 AM
Try selecting other Download Servers in your "Software Sources" (try Main Server).

System->Administration->Software Sources, under the "Ubuntu Software" tab.

WonderStivi
July 8th, 2008, 09:11 AM
Tried, but it didn't work...

iaculallad
July 8th, 2008, 09:19 AM
What about commenting the last line in your sources.list file:

This line of text.


deb-src http://security.ubuntu.com/ubuntu hardy-security multiverse

to


#deb-src http://security.ubuntu.com/ubuntu hardy-security multiverse

in


gksudo gedit /etc/apt/sources.list

Save the edited file and drop to your terminal:


sudo apt-get update && sudo apt-get upgrade

Then try to re-check if it enabled your security update.

WonderStivi
July 8th, 2008, 09:22 AM
When you say comment, you mean inserting #?

Edit: Sorry, saw you had already written what to do. A bit distracted as I'm sitting with my new-born son on my arm, home alone for the first time.

Inserted comment, and no change.

iaculallad
July 8th, 2008, 09:23 AM
When you say comment, you mean inserting ##?

Yap, insert the # sign before the line of text.

WonderStivi
July 8th, 2008, 09:28 AM
Did that, and no change.

WonderStivi
July 8th, 2008, 10:31 AM
Is there any way to check if these updates has been installed? If it's just the tick that's missing, then I'm not really worried. I've already verified that I'm running 8.04.1. But I want to make sure I get the security updates.

Elfy
July 8th, 2008, 10:41 AM
I'm the same - the little box won't tick, but I appear to have the security repos in the 3rd party tab

they are in your sources.list as are mine.

and congratulations
A bit distracted...

WonderStivi
July 8th, 2008, 10:43 AM
Then I will settle with this being a visual fault (after the .1 upgrade, perhaps?).

And thank you :)

philinux
July 8th, 2008, 10:45 AM
It's the same in Intrepid Ibex too. Seems to have got caught up in the point release as well. I think it's a bug but not serious, since the security sources are activated.

Elfy
July 8th, 2008, 10:46 AM
Next time I get a security update I can pm you if you like to make sure you did, as I suspect you'll be a bit busy for a while :)

WonderStivi
July 8th, 2008, 11:05 AM
That'd be great :)

Elfy
July 8th, 2008, 11:09 AM
Ok - I'll do that then.

azanutta
July 8th, 2008, 03:07 PM
so, what's the prognosis?
must we wait for a release that fix this bug(?)
...
i don't know but... i haven't updates to download for my hardy for long time....

Elfy
July 8th, 2008, 03:36 PM
Hi - no me neither, nor any proposed so I'd assume that all is well. If there is a bug the fix will turn up sometime over the next 3 years :)

fluteflute
July 8th, 2008, 04:22 PM
Bug Report: https://bugs.edge.launchpad.net/ubuntu/+source/software-properties/+bug/244093

Neo_The_User
July 8th, 2008, 04:24 PM
I've recently reinstalled Ubuntu, and noticed just now that for some reason the important security updates won't let themselves be activated. When I click the check box, it just blinks orange for a fraction of a second, and remains deactivated. Anyone know a fix for this?

OMG! I have the same problem! EXACTLY!

Rocket2DMn
July 8th, 2008, 06:22 PM
That bug has been already been Confirmed, but the triage is incomplete. I will mark is as High priority and upgrade to Triaged status, then a developer should start on it very soon.

ZabiGG
July 9th, 2008, 04:55 AM
Same problem here. Been updating manually for the past few days. Noticed it for the first time two or three days ago. Sources are exclusively standard repos + restricted, all Hardy.

Cheers all,

Z.

WonderStivi
July 9th, 2008, 07:18 AM
I got the BIND-update today, so I guess the security updates are activated. It was a total of 8 security updates. Bug confirmed!

Neo_The_User
July 9th, 2008, 06:40 PM
Same problem here. Been updating manually for the past few days. Noticed it for the first time two or three days ago. Sources are exclusively standard repos + restricted, all Hardy.

Cheers all,

Z.


Updating manually? Explain. How do you update manually?

P.S. Last night on July 7th 2008, I burned Ubuntu 8.04.1 to a CD then installed it. Works fine now.

ibuclaw
July 9th, 2008, 06:49 PM
Not to forget that there is probably a newer package in the "hardy-updates" repository with the security fix embedded in ;)

If security is your absolute policy, just pin the security repo to have the highest priority over all others.

Regards
Iain

ZabiGG
July 9th, 2008, 08:52 PM
@Neo

In case you ever need to, just click

System > Preferences > Administration > Update Manager

Reload and apply

Cheers,

Z.

Neo_The_User
July 12th, 2008, 03:57 PM
@Neo

In case you ever need to, just click

System > Preferences > Administration > Update Manager

Reload and apply

Cheers,

Z.

Yeah but I don't think im getting all the updates I want such as security. I love making updates to the kernel then my video gets all weird then I have to fix it. so much fun! seriously. i enjoy this stuff. P.S. this bug is in 8.04, 8.04.1, 8.10 all with fresh installed (not including 8.10.) you know what i think? somebody hacked into the ubuntu archives or something and replaces it all with junk thats why we can't check the thing because ubuntu is very paranoid with security which drives me crazy. Now what I did was put in like 30 new channels in the repository so now it will scan for like 30 extra things. None of them though relate to security. What I did with security was go into the software sources and go to third-party software and I put in MANUALLY http://security.ubuntu.com/ubuntu/ hardy-security click add. highlight it and click edit. Distribution: hardy-security
Components: restricted main multiverse universe

WHA BOOM!

I also used to have this bug that would always say "malformed release file?" then I installed 8.04.1 and it got rid of it. I always found doing a fresh install working best.

ZabiGG
July 12th, 2008, 04:55 PM
Turns out there is a now a workaround for this bug

here (https://bugs.launchpad.net/ubuntu/+source/software-properties/+bug/244093)

Once the source file is edited, it is advised not to try to check the checkbox until the bug is officially fixed.

Hope this helps!

Cheers,

Z.

zazanu16
July 19th, 2008, 11:46 PM
I`ve got the same problem but now is solved.....thank you for help