PDA

View Full Version : [ubuntu] Firefox hijacks my audio!!!!



animaniac
July 5th, 2008, 07:44 PM
Sometimes when i have a radio stream going in rhythmbox, and pause the playback to browse a website with integrated content, then try to resume playback and no sound.

Rhythmbox behaves as if the playback is working fine.

I have to turnoff Firefox and i think i have had to restart rhythmbox to get playback working again.

Any idea to the cause:confused:

scragar
July 5th, 2008, 07:48 PM
almost certainly pulseaudio, kill pulse audio and see if the problem still occurs:

killall pulseaudio

dje
July 5th, 2008, 07:49 PM
try:

sudo apt-get install libflashsupport

animaniac
July 5th, 2008, 07:59 PM
if its pulsaudio, is it safe to uninstall. or does anything depend on it.

dje: ill try yours first:)

scragar
July 5th, 2008, 08:08 PM
it's perfectly safe to kill pulse audio, it is used to allow sound to be piped through virtual desktops, it is known to cause things to be unable to use audio though if another program is using it at the same time(which would explain how firefox could steal your audio). you cannot uninstall pulse audio, but it can be disabled long term if required.

animaniac
July 5th, 2008, 08:20 PM
after having installed libflashsupport i havn't been able to recreate the error, so 75% possibility of it being fixed since i have not tried too many things yet.

also @ scragar: cool, post the long term way of dissabling it, just incase i need it:). I assume since these things seem to be known i have no need of filing a bug report.

Thanks both of you.

edit: also why have pulseaudio by default? id understand having it in the studio version of ubuntu, but it seems rather pointless on the normal version.

scragar
July 5th, 2008, 08:45 PM
it's expected to not be as buggy as it can be at the moment before the end of hardy's life(3 years), so it's included because otherwise it would proberly never make it in, and ofcourse without people using it to file bugs it wouldn't know of some of the stranger bugs it offers.

easiest method of disabling it is to simply add a new startup program to kill it (System>Preferences>Sessions - add - type: killall pulseaudio in as command).


After looking at the ubuntu wiki it does look like pulse audio has problems with firefox(although I havn't read the details yet, just scaned the page quickly), which may be related.

magiver
July 5th, 2008, 11:51 PM
libflashsupport did the trick for me.
Thank you dude

shamusl
July 10th, 2008, 04:51 AM
it's expected to not be as buggy as it can be at the moment before the end of hardy's life(3 years), so it's included because otherwise it would proberly never make it in, and ofcourse without people using it to file bugs it wouldn't know of some of the stranger bugs it offers.

easiest method of disabling it is to simply add a new startup program to kill it (System>Preferences>Sessions - add - type: killall pulseaudio in as command).


After looking at the ubuntu wiki it does look like pulse audio has problems with firefox(although I havn't read the details yet, just scaned the page quickly), which may be related.

Thanks, this did the trick.

leachyboy2001
August 1st, 2008, 04:24 PM
Kill the pulse processes worked for me too! Thanks

ming0
October 6th, 2008, 08:43 PM
easiest method of disabling it is to simply add a new startup program to kill it (System>Preferences>Sessions - add - type: killall pulseaudio in as command).


Cool, worked for me -- thanks! (btw, is there a "thanks" feature on these forums, or does the software just scan for the word "thanks" in the text?)

scragar
October 6th, 2008, 08:45 PM
Cool, worked for me -- thanks! (btw, is there a "thanks" feature on these forums, or does the software just scan for the word "thanks" in the text?)

little medal style button on bottom right of each post.

techflat
October 17th, 2008, 08:54 AM
try:

sudo apt-get install libflashsupport

Thanks, this did the trick for me. Niiiice!

minimals
October 18th, 2008, 05:37 PM
sudo apt-get install libflashsupport
thats good solution.....thnks dje

Michal77
May 18th, 2009, 02:38 PM
In Juanty there is no more libflashsupport. Instead of it, it has to be installed flashplugin-nonfree-extrasound


sudo aptitude install flashplugin-nonfree-extrasound

It works for me.
M.