PDA

View Full Version : [all variants] can't get 8800gt to work



supersonicdarky
July 2nd, 2008, 10:55 PM
just got my 8800gt (2 actually even tho i ordered one, lucky me) but have had no luck getting it to work.

I tried:
- envy
- nvidia-glx-new
- drivers from nvidia site

nothing worked at all. i'm stuck atm with 640x480 res. I tried running nvidia-xconfig multiple times. the only improvement is that I have 1680x1050 framebuffer now. is there anything else I can try? perhaps update video bios (atm 62.92.16.00.a3)?

I was ready for some tinkering but I thought things would go more smoothly than this :(

xorg.conf

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder58) Thu Jun 5 00:08:24 PDT 2008

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Default Screen" 0 0
InputDevice "Generic Keyboard" "CoreKeyboard"
InputDevice "Configured Mouse" "CorePointer"
EndSection

Section "Module"
Load "glx"
Load "v4l"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "Emulate3Buttons" "true"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
VendorName "Plug 'n' Play"
ModelName "Plug 'n' Play"
Gamma 1
ModeLine "640x480@60" 25.2 640 656 752 800 480 490 492 525 -hsync -vsync
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
BoardName "vesa"
Screen 0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultDepth 24
Option "NoLogo" "True"
SubSection "Display"
Virtual 640 480
Depth 24
Modes "640x480@60"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

adding 1680x1050 does nothing

stchman
July 2nd, 2008, 11:04 PM
just got my 8800gt (2 actually even tho i ordered one, lucky me) but have had no luck getting it to work.

I tried:
- envy
- nvidia-glx-new
- drivers from nvidia site

nothing worked at all. i'm stuck atm with 640x480 res. I tried running nvidia-xconfig multiple times. the only improvement is that I have 1680x1050 framebuffer now. is there anything else I can try? perhaps update video bios (atm 62.92.16.00.a3)?

I was ready for some tinkering but I thought things would go more smoothly than this :(

xorg.conf

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder58) Thu Jun 5 00:08:24 PDT 2008

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Default Screen" 0 0
InputDevice "Generic Keyboard" "CoreKeyboard"
InputDevice "Configured Mouse" "CorePointer"
EndSection

Section "Module"
Load "glx"
Load "v4l"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "Emulate3Buttons" "true"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
VendorName "Plug 'n' Play"
ModelName "Plug 'n' Play"
Gamma 1
ModeLine "640x480@60" 25.2 640 656 752 800 480 490 492 525 -hsync -vsync
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
BoardName "vesa"
Screen 0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultDepth 24
Option "NoLogo" "True"
SubSection "Display"
Virtual 640 480
Depth 24
Modes "640x480@60"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

adding 1680x1050 does nothing

Ok, what version of Ubuntu are you running?

If running Hardy then do this:


sudo apt-get install nvidia-glx-new

The nvidia-glx-new for Gutsy and earlier is the 100.xx drivers that DO NOT support the 8xxx series cards.

If running Gutsy or Feisty then download Envy Legacy 0.9.10 and do the following:

http://albertomilone.com/nvidia_scripts1.html

1. Remove the nvidia driver
2. Manually install the nvidia driver and select the 169.12 driver
3. Let Envy configure your xorg.conf file.
4. Reboot the computer.

Let me know if this works.

supersonicdarky
July 2nd, 2008, 11:45 PM
Actually I got it to work!

For those interested:
- run the usual way to configure X (sudo dpkg-reconfigure -phigh xserver-xorg)
- now it loaded for me in normal res (1680x1050) but w/ vesa
- edit xorg.conf and add in the things from the nvidia-xconfig one (if none availible, click here (http://en.wikipedia.org/wiki/Xorg.conf))
- copypasta things like Driver "nvidia", the whole composite and module sections and the subsection in Screen
- restart X (ctrl+alt+backspace)
- enjoy your shiny new gpu ;)