PDA

View Full Version : [ubuntu] External HD - "Can't Mound - No User Priviledge"



DapperMe17
July 2nd, 2008, 09:33 AM
Hello,

I'm working on an external HD that has 2 NTFS partitions...sda5 & sda6.

However, when I turn the external HD on, I'm presented with a "Can't Mount-no priviledge" warning box for each of the two partitions.

I'd love to have these auto-mount.

I think my problem lies with the fstab file.

I can manually mount both partitions as "media/disk", which appears to be the name for both of the drives in fstab ??? When I manually mount "disk" both drives appear on my desktop. However, the same data appears in both drives, no matter which of the two I try to open.

When I manually unmount "disk", I have to run the command "twice", in order to close both drives. Wierd...but again, I think my fstab is wrong.

Details...

sudo fdisk -l

Disk /dev/hda: 40.0 GB, 40007761920 bytes
255 heads, 63 sectors/track, 4864 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xae32ae32

Device Boot Start End Blocks Id System
/dev/hda1 * 1 2167 17406396 7 HPFS/NTFS
/dev/hda2 2168 2435 2152710 82 Linux swap / Solaris
/dev/hda3 2436 3327 7164990 83 Linux
/dev/hda4 3328 4729 11261565 b W95 FAT32

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xcb0a2670

Device Boot Start End Blocks Id System
/dev/sda1 2 19457 156280320 f W95 Ext'd (LBA)
/dev/sda5 2 5228 41985846 7 HPFS/NTFS
/dev/sda6 5229 7905 21502971 7 HPFS/NTFS


sudo blkid


/dev/hda1: UUID="0000649A00001B58" TYPE="ntfs"
/dev/hda2: TYPE="swap" UUID="ad10c4c1-f699-493d-aa8f-09faef6f26bc"
/dev/hda3: UUID="b3f86e43-239d-485d-9f72-735bfa55cec2" SEC_TYPE="ext2" TYPE="ext3"
/dev/sda5: UUID="13BEE72822B231ED" TYPE="ntfs" LABEL="External1"
/dev/sda6: UUID="14CDAF450033D0DB" TYPE="ntfs" LABEL="External2"
/dev/hda4: UUID="4633-DE83" TYPE="vfat"


sudo gedit /etc/fstab


# /etc/fstab: static file system information.
#
# -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
# Entry for /dev/hda3 :
UUID=b3f86e43-239d-485d-9f72-735bfa55cec2 / ext3 defaults,errors=remount-ro 0 1
# Entry for /dev/hda1 :
UUID=0000649A00001B58 /media/hda1 ntfs-3g defaults,locale=en_US.UTF-8 0 1
# Entry for /dev/hda4 :
UUID=4633-DE83 /media/hda4 vfat defaults,utf8,umask=007,gid=46 0 1
# Entry for /dev/hda2 :
UUID=ad10c4c1-f699-493d-aa8f-09faef6f26bc none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto,exec 0 0
/dev/sda5 /media/disk ntfs-3g defaults 0 0
/dev/sda6 /media/disk ntfs-3g defaults 0 0



Any help would be great!
Thanks

DapperMe17
July 2nd, 2008, 11:06 PM
There's got to be someone "smart" out there...?!

DapperMe17
July 7th, 2008, 10:52 PM
bump

DapperMe17
July 8th, 2008, 08:43 PM
Any?

dabl
July 8th, 2008, 08:54 PM
I have more questions than answers ...

1. What version of Ubuntu are you running? Because the libata hard disk driver does not use "hdx" since Feisty or Edgy - all hard drives are "sdx" now.

2. You say
However, when I turn the external HD on, I'm presented with a "Can't Mount-no priviledge" warning box for each of the two partitions.but you should not be turning the drive on after the computer is booted, if you hope to automatically mount it. To automatically mount it at boot time, you need mount lines in /etc/fstab, similar to the ones you have now for /dev/hda1.

3. You can use the information that you got from fdisk and blkid to write new mount lines in /etc/fstab, for example:

UUID=13BEE72822B231ED /media/sda5 ntfs-3g defaults,locale=en_US.UTF-8 0 2

{ this assumes you have manually made the mount point /media/sda5 }

or, you can mount by label:

LABEL=External1 /media/sda5 ntfs-3g defaults,locale=en_US.UTF-8 0 2

Hope this helps a bit. :)

Car60n
July 8th, 2008, 08:57 PM
ok try this
1>create a folder for sda5 and mount it

sudo mkdir /media/sda5 && sudo mount /dev/sda5 /media/sda5
2>do the same for sda6

sudo mkdir /media/sda6 && sudo mount /dev/sda6 /media/sda6
3>now if you want to automatically mount it on login

sudo gedit /etc/rc.local
4>add these two lines to the file and save and exit

mkdir /media/sda5 && sudo mount /dev/sda5 /media/sda5
mkdir /media/sda6 && sudo mount /dev/sda6 /media/sda6

that should do it for you...
i know you can use fstab for automount, but i prefer this method..
hope it helps..

DapperMe17
July 8th, 2008, 09:50 PM
Thanks for both replies!...I'll give it a try!