View Full Version : [ubuntu] Linksys WUSB54G (rt2570) question

June 26th, 2008, 02:20 AM
I haven't been able to find a solution to this problem. I am trying to install the patched rt2570 drivers from http://homepages.tu-darmstadt.de/~p_larbig/wlan/.

However, make gives me the following error:

tom@tom-laptop:/usr/src/rt2570-k2wrlz-1.6.1/Module$ sudo make && make install
make[1]: Entering directory `/usr/src/linux-headers-2.6.24-19-generic'
CC [M] /usr/src/rt2570-k2wrlz-1.6.1/Module/rtusb_main.o
/usr/src/rt2570-k2wrlz-1.6.1/Module/rtusb_main.c: In function ‘usb_rtusb_probe’:
/usr/src/rt2570-k2wrlz-1.6.1/Module/rtusb_main.c:1964: error: implicit declaration of function ‘SET_MODULE_OWNER’
/usr/src/rt2570-k2wrlz-1.6.1/Module/rtusb_main.c:1984: error: ‘struct net_device’ has no member named ‘weight’
/usr/src/rt2570-k2wrlz-1.6.1/Module/rtusb_main.c:2015: error: too few arguments to function ‘first_net_device’
make[2]: *** [/usr/src/rt2570-k2wrlz-1.6.1/Module/rtusb_main.o] Error 1
make[1]: *** [_module_/usr/src/rt2570-k2wrlz-1.6.1/Module] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.24-19-generic'
rt2570.ko failed to build!
make: *** [module] Error 1

I'm sort of new at this, any help at all would be greatly appreciated.

June 26th, 2008, 02:42 AM
Please see post #3 here: http://ubuntuforums.org/showthread.php?t=838124&highlight=rt2570

June 26th, 2008, 03:19 AM
No go on those, either. make install completes, then modprobe gives an error, saying the module is not found.

tom@tom-laptop:~/rt2570-cvs-2008062520/Module$ sudo make install
2.6 module install
make -C /lib/modules/2.6.24-19-generic/build SUBDIRS=/home/tom/rt2570-cvs-2008062520/Module modules_install
make[1]: Entering directory `/usr/src/linux-headers-2.6.24-19-generic'
INSTALL /home/tom/rt2570-cvs-2008062520/Module/rt2570.ko
make[1]: Leaving directory `/usr/src/linux-headers-2.6.24-19-generic'
/sbin/depmod -a
*** Update /etc/modprobe.d/ralink alias for rausb0
tom@tom-laptop:~/rt2570-cvs-2008062520/Module$ modprobe rt2570
FATAL: Module rt2570 not found.

June 26th, 2008, 12:36 PM
It works for me when I do:
sudo modprobe rt2570

June 26th, 2008, 10:43 PM
Doesn't matter either way; still gives Module rt2570 not found.

June 26th, 2008, 11:10 PM
After you:
sudo updatedband let it think a few moments, does:
locate rt2570.kogive an entry like this?
/lib/modules/2.6.24-19-generic/extra/rt2570.koI am wondering if it actually got installed in the right spot, although I can't imagine a reason why not.

This is about the only compile I have done in months, and I do quite a few, that made, installed and modprobed without a single warning.

June 27th, 2008, 07:51 AM
It gives:

tom@tom-laptop:~$ sudo updatedb
[sudo] password for tom:
tom@tom-laptop:~$ locate rt2570.ko

I really appreciate your trying to figure this out. I'm usually not the type to have to ask for help; I'm pretty good about figuring things out. This has had me completely stumped, though.

June 27th, 2008, 08:01 AM

Have you tried installing as per the above - post# 34 I think.

This has worked for me.

June 27th, 2008, 08:48 AM
Yup, that's pretty much step for step what I did.

June 27th, 2008, 09:15 AM

Here is another link to installing rt 2570 which got me up and running initially. I also installed "rutilt"

June 27th, 2008, 02:13 PM

I don't quite understand this. You compiled with the kernel headers for:
Entering directory `/usr/src/linux-headers-2.6.24-19-generic'
However, the module shows up in:
/lib/modules/ did kernel come from?

In any case, we can probably cheat this up a bit by copying the module to the 2.6.24-19-generic location:
sudo cp /lib/modules/ /lib/modules/2.6.24-19-generic/extra/rt2570.ko
sudo depmod -a
sudo modprobe rt2570Let us know.

June 27th, 2008, 03:13 PM
You asked "Where did kernel come from?"

I note that is mentioned in post #3 i.e

I am interested in seeing the final resolution to this problem. My knowledge of linux is very limited so am learning all the time!

June 27th, 2008, 09:45 PM
chili: That did it, thanks a lot bro.

I've never had that happen before compiling something.