PDA

View Full Version : [all variants] Need help to understand PHP compatibility



Monica Gomez
June 21st, 2008, 06:15 AM
Hello,

I am not an expert, and i have no idea of programation.
But i need to know the following thing.
My web site is built in PHP4., Don't know the exact version, and when i wanted to hosted it in a Hosting un Canada that use PHP5, my web design company told me it was impossible because i need to redesign all the site, reprograming it in PHP5 so i can upload the files in the new server..
Obviously they add a quote, very high..
A few minutes ago, i had the confirmation of my actual web hosting, that the version used of PHP was 5.2, and no site with version of PHP4 can have any problem..so the problem was a fraude from my web site design and programing company? I do not know if you use to have these kind of post here, but i really need help and i do not understand anything about programation or web design. I hope somoene can help me to understand this.
Thanks :)

canthus13
June 21st, 2008, 06:26 AM
It really seems to depend on the exact version. Doing a quick Google search on PHP backward compatibility reveals some issues. The best way to find out seems to be to test it and see what breaks. Supposedly, though, a well-written PHP4 script should have no problems with PHP5.

--Me