PDA

View Full Version : [ubuntu] Wrong Keyboard Layout



skymera
June 20th, 2008, 04:19 PM
Hi

I've selected United Kingdom and Dell keyboard from the keyboard options yet it's still not the right layout. or not workign right.

All the keys are jumbled up, any idea how to fix?

Qrikko
June 20th, 2008, 04:23 PM
$> gnome-keyboard-properties

should give you the interface to set up your keyboard :)

check if it is correct when you do, I for example had to use Finnish keyboard (I am Swedish) for a long while before it was "correct" so easiest I think is to use that and find something that work better :)

Hope it can help you.

skymera
June 20th, 2008, 04:27 PM
I used that, United Kingdom is selected which is correct but all symbols are mixed around.

skymera
June 22nd, 2008, 12:25 PM
Reconfigured Xorg and selected GB, selected UK as my layout and still not right :(

Troll_the_Great
June 22nd, 2008, 12:30 PM
What do you mean "Don't feed the trolls!" Do you have something against trolls?Are you a troll hater?:lolflag::lolflag::lolflag:

rockerphil
June 22nd, 2008, 12:36 PM
i'm a bit more command line oriented, so this is what i'd do. in terminal run this:


sudo dpkg-reconfigure xserver-xorg

it'll have an option to select your keyboard layout, but it should auto-detect it. hope it helps

skymera
June 22nd, 2008, 12:45 PM
What do you mean "Don't feed the trolls!" Do you have something against trolls?Are you a troll hater?:lolflag::lolflag::lolflag:

I was called a troll for saying i liked Dream Linux.

Troll_the_Great
June 22nd, 2008, 01:04 PM
Why?What is dream linux?By the way, my nickname comes form the Norse mythology, I'm not an internet troll.

skymera
June 23rd, 2008, 07:13 PM
Ok Dream Linux is just another distro based on Debian.

Anyone know about the keyboard solution?

markbuntu
June 23rd, 2008, 08:29 PM
You can get keytouch and keytouch editor and make your own custom keyboard configuration.

A lot of those manufacturer keyboard things are wrong or for only one patricular keyboard which is most likely not yours. The manufacturers change keyboards and layouts all the time, even within the same model and don't really tell anyone.

sydbat
June 23rd, 2008, 08:33 PM
System > Preferences > Keyboard > Layout tab.

OliW
March 13th, 2010, 02:58 AM
Did you ever fix this? My keyboard is set as UK everywhere but as of 10 minutes ago, it's behaving like a US keyboard.

It's a shame that nobody read your posts (and saw what you had tried) but I've also reconfigured xserver and used the gnome tool.

Edit: Turns out I overlooked the fact I installed kernel 2.6.24 (yeah, barely RC2 and fully of buggage). My bad.