PDA

View Full Version : [ubuntu] 8.04 visible to Internet but not to Wired LAN



coramill
June 20th, 2008, 04:52 AM
I am new to Linux and am having trouble integrating the Ubuntu OS computer into an existing mixed (WinXP, Millenium, Win9X) Microsoft Windows Network. I have used this wired LAN in the past to test and burn in several Windows computers and have never had trouble seeing the added computer.

After connecting the new computer in place of an existing Windows unit. I was able to connect to the Internet and to set up E-mail with no problem. However I cannot see the Ubuntu machine from either direction over the LAN.

All Windows computers on the LAN have no passwords (except for login) and all drives and printer are shared with full R/W permissions and without passwords.

At this point I have not drilled on the Linux machine much lest I add to the problem by not knowing what I'm doing. I have included below the ipconfig dump from the WinXP pro machine as well as several areas of the Linux machine--Desktop Icon properties and Samba. in the hopes that the problem is just a neophyte issue. I did try to assign a name to the unit (JMILLS4) and a password which was required after naming it and workgroup domain name (WORKGROUP).

I have read the Official help guide from Ubuntu at:
http://doc.ubuntu.com/ubuntu/switching/->
preparing-settings-network.html

And after collecting the information I do not see any instructions as to what I should do with it.

This issue is probably just an operator not knowing what he's doing, but any help would be greatly appreciated.

System Details:

Newly built desktop:
MoBo Asus P5E-VM HDMI
(Without WiFi option)
Vendor installed OS: Ubuntu 8.04
Router: D-Link DI 524




Information from WinXP Pro ipconfig /All File:

Windows IP Configuration

Host Name . . . . . . . . . . . . : JMILLS3
Primary Dns Suffix. . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection 18:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek RTL8029(AS) PCI Ethernet

Adapter #2
..Physical Address. . . . . . . . . : 00-40-33-53-E0-A7
..Dhcp Enabled. . . . . . . . . . . : Yes
..Autoconfiguration Enabled . . . . : Yes
..Autoconfiguration IP Address. . . : 169.254.42.137
..Subnet Mask . . . . . . . . . . . : 255.255.0.0
..Default Gateway . . . . . . . . . :

Ethernet adapter Local Area Connection 19:

..Connection-specific DNS Suffix . :
..Description . . . . . . . . . . . : D-Link DFE-530TX+ PCI Adapter
..Physical Address. . . . . . . . . : 00-50-BA-49-39-40
..Dhcp Enabled. . . . . . . . . . . : Yes
..Autoconfiguration Enabled . . . . : Yes
..IP Address. . . . . . . . . . . . : 192.168.0.100
..Subnet Mask . . . . . . . . . . . : 255.255.255.0
..Default Gateway . . . . . . . . . : 192.168.0.1
..DHCP Server . . . . . . . . . . . : 192.168.0.1
..DNS Servers . . . . . . . . . . . : 192.168.0.1
..Lease Obtained. . . . . . . . . . : Monday, June 16, 2008 5:20:21 PM
..Lease Expires . . . . . . . . . . : Monday, June 23, 2008 5:20:21 PM




Information from the Ubuntu 8.04 OS machine

Wired Network Connection Icon
..Connection Information
....Active Connection Information
........Interface Ethernet (eth0)
........Speed 100 Mb/s
........Driver At|1

........IP Address: 192.168.0.102
........Broadcast Address: 192.168.0.255
........Subnet Mask: 255.255.255.0
........Default Route: 192.168.0.1
........Primary DNS: 192.168.0.1
........Secondary DNS: 0.0.0.0
........Hardware Address: 00:1F:C6:0C:F8:32

Places (drop down on top tool bar)
..Network
....Network-File Browser
........Windows Network Icon
..........Properties
............Basic Tab
................Name: Windows Network
................Type: unknown Type
................Contents: 1 item, with size 0 bytes
................Location: network:///
................Volume: unknown
................Free Space:unknown

................Modified: unknown

............Emblems tab
................None checked

............Permissions tab
................The permissions of "Windows Network" could not be determined

............Open With tab
................No applications selected





Information from /etc/samba/smb.conf

#
# Sample configuration file for the Samba suite for Debian GNU/Linux.
#
#
# This is the main Samba configuration file. You should read the
# smb.conf(5) manual page in order to understand the options listed
# here. Samba has a huge number of configurable options most of which
# are not shown in this example
#
# Any line which starts with a ; (semi-colon) or a # (hash)
# is a comment and is ignored. In this example we will use a #
# for commentary and a ; for parts of the config file that you
# may wish to enable
#
# NOTE: Whenever you modify this file you should run the command
# "testparm" to check that you have not made any basic syntactic
# errors.
#

#======================= Global Settings =======================

[global]

## Browsing/Identification ###

# Change this to the workgroup/NT-domain name your Samba server will
part of
workgroup = WORKGROUP

# server string is the equivalent of the NT Description field
server string = %h server (Samba, Ubuntu)

# Windows Internet Name Serving Support Section:
# WINS Support - Tells the NMBD component of Samba to enable its WINS
Server
; wins support = no

# WINS Server - Tells the NMBD components of Samba to be a WINS Client
# Note: Samba can be either a WINS Server, or a WINS Client, but NOT
both
; wins server = w.x.y.z

# This will prevent nmbd to search for NetBIOS names through DNS.
dns proxy = no

# What naming service and in what order should we use to resolve host
names
# to IP addresses
; name resolve order = lmhosts host wins bcast

#### Networking ####

# The specific set of interfaces / networks to bind to
# This can be either the interface name or an IP address/netmask;
# interface names are normally preferred
; interfaces = 127.0.0.0/8 eth0

# Only bind to the named interfaces and/or networks; you must use the
# 'interfaces' option above to use this.
# It is recommended that you enable this feature if your Samba machine
is
# not protected by a firewall or is a firewall itself. However, this
# option cannot handle dynamic or non-broadcast interfaces correctly.
; bind interfaces only = true



#### Debugging/Accounting ####

# This tells Samba to use a separate log file for each machine
# that connects
log file = /var/log/samba/log.%m

# Cap the size of the individual log files (in KiB).
max log size = 1000

# If you want Samba to only log through syslog then set the following
# parameter to 'yes'.
; syslog only = no

# We want Samba to log a minimum amount of information to syslog.
Everything
# should go to /var/log/samba/log.{smbd,nmbd} instead. If you want to
log
# through syslog you should set the following parameter to something
higher.
syslog = 0

# Do something sensible when Samba crashes: mail the admin a backtrace
panic action = /usr/share/samba/panic-action %d


####### Authentication #######

# "security = user" is always a good idea. This will require a Unix
account
# in this server for every user accessing the server. See
# /usr/share/doc/samba-doc/htmldocs/Samba3-HOWTO/ServerType.html
# in the samba-doc package for details.
; security = user

# You may wish to use password encryption. See the section on
# 'encrypt passwords' in the smb.conf(5) manpage before enabling.
encrypt passwords = true

# If you are using encrypted passwords, Samba will need to know what
# password database type you are using.
passdb backend = tdbsam

obey pam restrictions = yes

; guest account = nobody
invalid users = root

# This boolean parameter controls whether Samba attempts to sync the
Unix
# password with the SMB password when the encrypted SMB password in the
# passdb is changed.
unix password sync = yes

# For Unix password sync to work on a Debian GNU/Linux system, the
following
# parameters must be set (thanks to Ian Kahan
<<kahan@informatik.tu-muenchen.de> for
# sending the correct chat script for the passwd program in Debian
Sarge).
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*
\spassword:* %n\n *password\supdated\ssuccessfully* .

# This boolean controls whether PAM will be used for password changes
# when requested by an SMB client instead of the program listed in
# 'passwd program'. The default is 'no'.
pam password change = yes

# This option controls how nsuccessful authentication attempts are
mapped
# to anonymous connections
map to guest = bad user

########## Domains ###########

# Is this machine able to authenticate users. Both PDC and BDC
# must have this setting enabled. If you are the BDC you must
# change the 'domain master' setting to no
#
; domain logons = yes
#
# The following setting only takes effect if 'domain logons' is set
# It specifies the location of the user's profile directory
# from the client point of view)
# The following required a [profiles] share to be setup on the
# samba server (see below)
; logon path = \\%N\profiles\%U
# Another common choice is storing the profile in the user's home
directory
; logon path = \\%N\%U\profile

# The following setting only takes effect if 'domain logons' is set
# It specifies the location of a user's home directory (from the client
# point of view)
; logon drive = H:
; logon home = \\%N\%U

# The following setting only takes effect if 'domain logons' is set
# It specifies the script to run during logon. The script must be stored
# in the [netlogon] share
# NOTE: Must be store in 'DOS' file format convention
; logon script = logon.cmd

# This allows Unix users to be created on the domain controller via the
SAMR
# RPC pipe. The example command creates a user account with a disabled
Unix
# password; please adapt to your needs
; add user script = /usr/sbin/adduser --quiet --disabled-password
--gecos "" %u

########## Printing ##########

# If you want to automatically load your printer list rather
# than setting them up individually then you'll need this
; load printers = yes

# lpr(ng) printing. You may wish to override the location of the
# printcap file
; printing = bsd
; printcap name = /etc/printcap

# CUPS printing. See also the cupsaddsmb(8) manpage in the
# cupsys-client package.
; printing = cups
; printcap name = cups

############ Misc ############

# Using the following line enables you to customise your configuration
# on a per machine basis. The %m gets replaced with the netbios name
# of the machine that is connecting
; include = /home/samba/etc/smb.conf.%m

# Most people will find that this option gives better performance.
# See smb.conf(5)
and /usr/share/doc/samba-doc/htmldocs/Samba3-HOWTO/speed.html
# for details
# You may want to add the following on a Linux system:
# SO_RCVBUF=8192 SO_SNDBUF=8192
socket options = TCP_NODELAY

# The following parameter is useful only if you have the linpopup
package
# installed. The samba maintainer and the linpopup maintainer are
# working to ease installation and configuration of linpopup and samba.
; message command = /bin/sh -c '/usr/bin/linpopup "%f" "%m" %s; rm %s'
&

# Domain Master specifies Samba to be the Domain Master Browser. If this
# machine will be configured as a BDC (a secondary logon server), you
# must set this to 'no'; otherwise, the default behavior is recommended.
; domain master = auto

# Some defaults for winbind (make sure you're not using the ranges
# for something else.)
; idmap uid = 10000-20000
; idmap gid = 10000-20000
; template shell = /bin/bash

# The following was the default behaviour in sarge,
# but samba upstream reverted the default because it might induce
# performance issues in large organizations.
# See Debian bug #368251 for some of the consequences of *not*
# having this setting and smb.conf(5) for details.
; winbind enum groups = yes
; winbind enum users = yes

# Setup usershare options to enable non-root users to share folders
# with the net usershare command.

# Maximum number of usershare. 0 (default) means that usershare is
disabled.
; usershare max shares = 100

# Allow users who've been granted usershare privileges to create
# public shares, not just authenticated ones
usershare allow guests = yes

#======================= Share Definitions =======================

# Un-comment the following (and tweak the other settings below to suit)
# to enable the default home directory shares. This will share each
# user's home directory as \\server\username
;[homes]
; comment = Home Directories
; browseable = no

# By default, the home directories are exported read-only. Change the
# next parameter to 'no' if you want to be able to write to them.
; read only = yes

# File creation mask is set to 0700 for security reasons. If you want to
# create files with group=rw permissions, set next parameter to 0775.
; create mask = 0700

# Directory creation mask is set to 0700 for security reasons. If you
want to
# create dirs. with group=rw permissions, set next parameter to 0775.
; directory mask = 0700

# By default, \\server\username shares can be connected to by anyone
# with access to the samba server. Un-comment the following parameter
# to make sure that only "username" can connect to \\server\username
# This might need tweaking when using external authentication schemes
; valid users = %S

# Un-comment the following and create the netlogon directory for Domain
Logons
# (you need to configure Samba to act as a domain controller too.)
;[netlogon]
; comment = Network Logon Service
; path = /home/samba/netlogon
; guest ok = yes
; read only = yes
; share modes = no

# Un-comment the following and create the profiles directory to store
# users profiles (see the "logon path" option above)
# (you need to configure Samba to act as a domain controller too.)
# The path below should be writable by all users so that their
# profile directory may be created the first time they log on
;[profiles]
; comment = Users profiles
; path = /home/samba/profiles
; guest ok = no
; browseable = no
; create mask = 0600
; directory mask = 0700

[printers]
comment = All Printers
browseable = no
path = /var/spool/samba
printable = yes
guest ok = no
read only = yes
create mask = 0700

# Windows clients look for this share name as a source of downloadable
# printer drivers
[print$]
comment = Printer Drivers
path = /var/lib/samba/printers
browseable = yes
read only = yes
guest ok = no
# Uncomment to allow remote administration of Windows print drivers.
# Replace 'ntadmin' with the name of the group your admin users are
# members of.
; write list = root, @ntadmin

# A sample share for sharing your CD-ROM with others.
;[cdrom]
; comment = Samba server's CD-ROM
; read only = yes
; locking = no
; path = /cdrom
; guest ok = yes

# The next two parameters show how to auto-mount a CD-ROM when the
# cdrom share is accesed. For this to work /etc/fstab must contain
# an entry like this:
#
# /dev/scd0 /cdrom iso9660 defaults,noauto,ro,user 0 0
#
# The CD-ROM gets unmounted automatically after the connection to the
#
# If you don't want to use auto-mounting/unmounting make sure the CD
# is mounted on /cdrom
#
; preexec = /bin/mount /cdrom
; postexec = /bin/umount /cdrom

azurepancake
June 20th, 2008, 05:48 AM
I am going to recommend following this guide, http://samba.netfirms.com/. I used it when setting up my Ubuntu file server, in which three Windows XP systems access for their files.

Basically, all you need to do is edit the "/etc/samba/smb.conf" and to add share definitions that point to the certain parts of your Linux directory that you wish to share.

I won't go into too much detail, because the guide explains everything you need to know. If you have anymore questions, just ask.

coramill
June 20th, 2008, 11:05 PM
Thanks for the reply and the setup links.

Before I jump into Samba I would like to be sure that it is not just a problem with my LAN protocols or settings. Since you have a working Linux/WinXP LAN if you could capture ipconfig /all from one of the WinXPs and post it then I could see if there is any obvious differences from mine.

The help guide @ https://help.ubuntu.com/8.04/switching/preparing-settings-network.html implies that 8.04 "... is usually able to automatically detect the settings for your network, it is wise to make a note of relevant network settings in case the network you are trying to connect to cannot be handled automatically."
This raised my concern that there was something unique about my wired LAN that was preventing the Hardy machine from seeing or being seen on the LAN.
And before I dive in and start drilling on the Samba file I need some confidence that I am not just going to muck it up with needless and possible irreversible (short of a reinstall) changes.

Regards

kestrel1
June 20th, 2008, 11:26 PM
Is the Linux machine in the same workgroup as the Windows machines?

azurepancake
June 21st, 2008, 03:54 AM
Is the Linux machine in the same workgroup as the Windows machines?

Kestrel has a good point. I know that most of the time, Windows operating systems normally use the name "MSHOME" as there workgroup and by default, the smb.conf file sets the workgroup as simply "WORKGROUP". Also, when you first try to connect to your Linux system from Windows, try using the 'Run' program (Start-->Run - I believe). Then simply type \\192.168.0.102

You'll want to double check your workgroup on the Windows systems and change it accordingly on the smb.conf.

From my perspective, everything looks A-OK with your TCP/IP settings on the Windows system.

To play on the safe side, you should backup the smb.conf file and either copy over the contents to a new one or create it from scratch. From my experience with Samba, it is very difficult to cause irreversible effects to it when your only editing the smb.conf file.

Once you have everything configured the way you like, you should create users on the Linux system that match the user names and passwords of the users on the Windows systems. Do this with the following command..


sudo adduser <username>

Then make each individual user a samba user with the following command..


smbpasswd -a <username>

Now you can assign those users to groups on the Linux system and appropriately set permissions on files and directories.

All this information is in the guide in my previous post. I am just trying to give you a grasp on how samba works with the Windows systems (I was clueless when I first started configuring samba). In all actuality it is a very simple process.

Good luck!

BLTicklemonster
June 21st, 2008, 04:02 AM
Once I got this machine shared, I couldn't see it from the xp boxes, so knowing that my box is

bill-desktop

I did a search in xp for computers and entered bill-desktop and it came up. I then dragged a link to the desktop and was done with it.

dwhitney67
June 21st, 2008, 04:07 AM
Thanks for the reply and the setup links.

Before I jump into Samba I would like to be sure that it is not just a problem with my LAN protocols or settings. Since you have a working Linux/WinXP LAN if you could capture ipconfig /all from one of the WinXPs and post it then I could see if there is any obvious differences from mine.

The help guide @ https://help.ubuntu.com/8.04/switching/preparing-settings-network.html implies that 8.04 "... is usually able to automatically detect the settings for your network, it is wise to make a note of relevant network settings in case the network you are trying to connect to cannot be handled automatically."
This raised my concern that there was something unique about my wired LAN that was preventing the Hardy machine from seeing or being seen on the LAN.
And before I dive in and start drilling on the Samba file I need some confidence that I am not just going to muck it up with needless and possible irreversible (short of a reinstall) changes.

Regards

Coramill -

What is the IP address of your Linux system? Run this to find out:

$ ifconfig eth0
Yes, that is an 'f'; not a 'p' as in Windoze land.

Once you have the IP address, can you ping your Linux system from another system? Can your Linux system ping them?

$ ping aaa.bbb.ccc.ddd
where aaa.bbb.ccc.ddd is something like 192.168.1.10

P.S. The commands above will need to be run in a gnome-terminal.

coramill
June 21st, 2008, 05:39 AM
Is the Linux machine in the same workgroup as the Windows machines?

As far as I can tell. During the initial startup of the new machine I stumbled into a dialog with 8.04 and filled out the blanks so that now the smb.config file contains the following entry:

#======================= Global Settings =======================

[global]

## Browsing/Identification ###

# Change this to the workgroup/NT-domain name your Samba server will
part of
workgroup = WORKGROUP

Regards

coramill
June 21st, 2008, 06:38 AM
Coramill -

What is the IP address of your Linux system? Run this to find out:

$ ifconfig eth0
Yes, that is an 'f'; not a 'p' as in Windoze land.

Once you have the IP address, can you ping your Linux system from another system? Can your Linux system ping them?

$ ping aaa.bbb.ccc.ddd
where aaa.bbb.ccc.ddd is something like 192.168.1.10

P.S. The commands above will need to be run in a gnome-terminal.

Thanks for the info.

I tried running the Ubuntu IP address (\\192.168.0.102) on the WinXP machine but only got a message that the "Network path was not found". I was able to successfully ping both ways error free. Since they can ping each other the problem must lie in the setup.

Regards

coramill
June 21st, 2008, 06:47 AM
Once I got this machine shared, I couldn't see it from the xp boxes, so knowing that my box is

bill-desktop

I did a search in xp for computers and entered bill-desktop and it came up. I then dragged a link to the desktop and was done with it.

Thanks,

That may be my issue since I haven't done anything overtly to share the Linux machine. Since all of the Windows units have everything shared and nothing passworded I just assumed that Ubuntu would see the LAN even if nothing was shared on Ubuntu.

Regards

dwhitney67
June 21st, 2008, 06:52 AM
So if you are able to ping a windows system from your Linux box, and the windows box is able to ping the Linux machine, then it seems to me that they see each other.

Last week, for the first time ever, I played around with samba. After installing it on my Ubuntu system, I was able to setup the sharing of a folder. All I had to do is right click on the folder, and setup the "sharing options".

I did not have to play around with the Samba config file. The default configuration was fine for my needs. I believe the default workgroup is MSHOME.

Now I am able to see the shared-folder on my other linux systems. To do that, I ran Places -> Connect to Server...

From the pop-up dialog box, I selected Windows Share, I provided the IP address of the server, and the name of the shared folder (which does not necessarily have to be the same as the actual folder).

coramill
June 21st, 2008, 05:25 PM
So if you are able to ping a windows system from your Linux box, and the windows box is able to ping the Linux machine, then it seems to me that they see each other.

Last week, for the first time ever, I played around with samba. After installing it on my Ubuntu system, I was able to setup the sharing of a folder. All I had to do is right click on the folder, and setup the "sharing options".

I did not have to play around with the Samba config file. The default configuration was fine for my needs. I believe the default workgroup is MSHOME.

Now I am able to see the shared-folder on my other linux systems. To do that, I ran Places -> Connect to Server...

From the pop-up dialog box, I selected Windows Share, I provided the IP address of the server, and the name of the shared folder (which does not necessarily have to be the same as the actual folder).

Thanks for the pointers,

My workgroup on the Windows LAN is "WORKGROUP"

(I'm not sure what and means)
But, I drilled on your suggestions as follows:

Places v
..Connect to Server
...Service Type: ^v Windows Share
...Server: JMILLS3
...Optional Information
...Share: 192.168.0.100
...Folder: -
...User Name: -
...Domain Name: -
<Connect>

OS answered:
Can't display location "smb://jmills3/192.168.0.100/"
Failed to mount windows share

I drilled on the various entries in the Connect to Server dialog but couldn't find the open sesame combination.

JMILLS3 is listed under ipconfig as the Host Name. Perhaps that is not the same as the Server name. If so I have no idea of what the server name (if it even exists) is.

Regards

BLTicklemonster
June 21st, 2008, 09:27 PM
Thanks,

That may be my issue since I haven't done anything overtly to share the Linux machine. Since all of the Windows units have everything shared and nothing passworded I just assumed that Ubuntu would see the LAN even if nothing was shared on Ubuntu.

Regards

I just installed hardy 64, and to share a folder, I first went to the folder I wanted to share, right clicked on it, went to sharing options, and clicked on share this folder. I had to install some sharing stuff, so I did, then I closed the share dialog (look, this is out of order, but it's the steps I took, lol) and went to system, administration, users and groups, clicked unlock, and entered my password, then went to manage groups, scrolled down to samba share, clicked it, clicked properties, and put a check mark next to root. Ok, close close close, etc. log out, log in, go back to the folder I want to share, right click it, go to sharing options, and I put a check mark on everything there. Went to the xp box across the room, searched for bill-desktop, and there I was. No username or password needed. Simple as pie, but a bit more work than windows, but I can deal with it. Easiest way Ubuntu has had yet.

dwhitney67
June 21st, 2008, 11:08 PM
JMILLS3 is listed under ipconfig as the Host Name. Perhaps that is not the same as the Server name. If so I have no idea of what the server name (if it even exists) is.

The host name is not relevant... it is the IP address. A host name is in essence an alias associated with the IP address.

For a samba folder, I would expect to see something like smb://<ip-addr>/<folder>

On your linux system, if you prefer to identify your windows machine by name, you can edit the /etc/hosts file to insert the IP address and the associated alias. Something like:


192.168.1.10 Machine1
192.168.1.11 Machine2
Thus when setting up a samba connection, then you can state something like smb://Machine1/<folder>. But until this association is set up, you must use the raw-form of the IP address.

P.S. I have no idea how Win XP or Vista do it, but back when Win2000 was the rage, a file called 'lmhosts' was used to store associations between IP address and a host name.

jimrz
June 21st, 2008, 11:19 PM
This may sound silly, but have you actually installed samba? The default install only provides the smb client, samba server must be installed after. Once samba is installed you will need to setup your shared folders if you want your win boxes to actually see anything.

BLTicklemonster
June 22nd, 2008, 12:21 AM
I think if he'd (try to) follow what I just put up there, he'd have no problems.

Heck, I've been around for a while, and this is the first time it's worked for me simply yet. Period. Ever.

dwhitney67
June 22nd, 2008, 12:30 AM
I agree... Samba was not that difficult to set up. I think that the OP needs to understand the difference between a host name and an IP address. Once he's got that down, then everything else will fall into place.

coramill
June 22nd, 2008, 01:15 AM
I just installed hardy 64, and to share a folder, I first went to the folder I wanted to share, right clicked on it, went to sharing options, and clicked on share this folder. I had to install some sharing stuff, so I did, then I closed the share dialog (look, this is out of order, but it's the steps I took, lol) and went to system, administration, users and groups, clicked unlock, and entered my password, then went to manage groups, scrolled down to samba share, clicked it, clicked properties, and put a check mark next to root. Ok, close close close, etc. log out, log in, go back to the folder I want to share, right click it, go to sharing options, and I put a check mark on everything there. Went to the xp box across the room, searched for bill-desktop, and there I was. No username or password needed. Simple as pie, but a bit more work than windows, but I can deal with it. Easiest way Ubuntu has had yet.


Thanks for the information.

I think I am making some headway after the following steps:

On Ubuntu machine

Places v
..Computer click
....Filessystem Icon 2click
......home 2click
........jmills4 rt click
..........Sharing option click
............File manager
..............Share this folder tick

OS Message:

Sharing service is not installed
..install service click
....Password: PW entered
......<OK> click

Downloading progress window:
..changes applied
....Successfully applied all changes
......Close click

Back to File manager:
..Folder sharing
....Share this folder ticked box
....Allow other people to write in this folder ticked box
......Create share click

OS message:

Nautilus needs to add some permissions to your folder to share it
..Add permissions automatically click

Back to File Manager:
'net usershare' returned error 255: net usershare: cannot open user share directory /var/lib/samba/usershares. Error
Permission denied
You do not have permission to create a usershare. Ask you administrator to grant you permission to create a share
..Create share click

Back to Nautilus needs to add some permissions:
The folder "jmills4" needs the following extra permissions for sharing to work.
-write permission by others
..Add permissions automatically click


Now Ubuntu is stuck in a circular loop between File manager flagging error 255 and sending me to Nautilus for extra permissions.


After doing this dance several times I stopped the effort to create a shared folder (jmills4) and returned to the WinXP machine to see if the WORKGROUP had any new comers and I think some progress has been made.

I see a new item listed:
Name..................................Comments
ubuntu server (samba, Ubuntu)(Ubuntu) ubuntu server(Samba, Ubuntu)

But when I double click this address (\\Ubuntu)
I only get a shared printer icon named PDF
and a Printers and Faxes Icon

This is better than nothing but still no joy.

regards

coramill
June 22nd, 2008, 04:51 AM
I just installed hardy 64, and to share a folder, I first went to the folder I wanted to share, right clicked on it, went to sharing options, and clicked on share this folder. I had to install some sharing stuff, so I did, then I closed the share dialog (look, this is out of order, but it's the steps I took, lol) and went to system, administration, users and groups, clicked unlock, and entered my password, then went to manage groups, scrolled down to samba share, clicked it, clicked properties, and put a check mark next to root. Ok, close close close, etc. log out, log in, go back to the folder I want to share, right click it, go to sharing options, and I put a check mark on everything there. Went to the xp box across the room, searched for bill-desktop, and there I was. No username or password needed. Simple as pie, but a bit more work than windows, but I can deal with it. Easiest way Ubuntu has had yet.

Best way to network that I've found so far http://www.europe.eclipse.co.uk/Ubun...in-network.htm

I went to your suggested help guide but several times the author warns:

"...(8.04 is not covered by this version of the guide)

After a basic install while connected to your pre-existing Windows network, internet access from the Ubuntu PC should work straight away.

Internet access by the Ubuntu PC is essential to this process.

By default, a lot of networking capability on the Ubuntu machine is already working:

In Places > Network, you will see the 'Windows Network' icon.

D/clicking on it will take you to [the name of your windows network], in my case mshome

D/clicking on mshome will display all the Windows pc's currently on your network, and you can click on their icons to see their shared folders and files.

You will find that, 'straight out of the box', from your Ubuntu PC you can transfer files between the Ubuntu Desktop (and other folders) & Windows Shared folders"


And his comment that out of the box Ubuntu can see shared Windows folders is not true at least in my case and for 8.04.

Regards

BLTicklemonster
June 22nd, 2008, 05:12 AM
Oh man, I need to change that in my sig! Ignore it.

System, administration, users and groups, clicked unlock, and entered my password, then went to manage groups, scrolled down to samba share, clicked it, clicked properties, and put a check mark next to root. NOW go share a folder and look for it from your xp box.

dwhitney67
June 22nd, 2008, 05:14 AM
Back to File Manager:
'net usershare' returned error 255: net usershare: cannot open user share directory /var/lib/samba/usershares. Error
Permission denied
You do not have permission to create a usershare. Ask you administrator to grant you permission to create a share

I had the same problem... did a little Googling, and found that the way to resolve this is to log out, and log back in. Alternatively, you can modify user/groups to remove yourself from the samba (?) group, and then re-add yourself to it. Frankly, logging out and back in seemed easier.

Anyhow, once you do either of these options, you should be styling, and you can share your Linux folders (err, directories).

coramill
June 22nd, 2008, 08:00 PM
Oh man, I need to change that in my sig! Ignore it.

System, administration, users and groups, clicked unlock, and entered my password, then went to manage groups, scrolled down to samba share, clicked it, clicked properties, and put a check mark next to root. NOW go share a folder and look for it from your xp box.

Thanks you are a Prince.

I followed you clear and precise instructions and repeated my last failed efforts to share a folder and got the same dreaded

"File Manager:
'net usershare' returned error 255: net usershare: cannot open user share directory /var/lib/samba/usershares. Error
Permission denied
You do not have permission to create a usershare. Ask you administrator to grant you permission to create a share"

Then I tried rebooting the Ubuntu machine and was informed:

"User's $HOME/.dmrc file is being ignored. This prevents the default session and language from being saved. File should be owned by user and have 644 permissions. User's $HOME directory must be owned by user and not be writable by others."

So I must have been trying to share an unsharable (system?) folder.

Then I tried sharing the public folder and now I can browse the PDF shared printer the Printers and Faxes and the shared public folder.

Now I need to undo the efforts to share $HOME/jmills4 since I now get a nag every time I reboot Ubunto.

Any idea as to how I fix $HOME/.dmrc so that it is not ignored during startup?

Also I still cannot browse the Windows Network from Ubuntu when I try:
Places>Network>
Windows Network Icon>Properties

..Windows Network Properties
.
....Basic tab
......Name: Windows Network
......Type: unknown type
......Contents: 1 item, with size 0 bytes
......Location: network:///
......Volume: unknown
......Free space: unknown
......Modified: unknown
.
....Emblems tab
......none ticked
.
....Permissions tab

......The permissions of "Windows Network" could not be determined
.
....Open With tab
......No applications selected

I then tried to browse the Windows Network from Ubuntu:

Places>Network>Windows Network Icon 2click>WORKGROUP open
Location: smb://workgroup/
followed by a long pause
Then an empty pane labled Windows shares on workgroup

Any additional help will be greatly appreciated.

Regards

dwhitney67
June 22nd, 2008, 08:40 PM
Any idea as to how I fix $HOME/.dmrc so that it is not ignored during startup?


Set the ownership (and group) of the .dmrc file to your account's user-id. For instance, if the user is 'superman':

$ chown superman:superman ~/.dmrc
If you need to change permissions on a directory and its contents, then supply the -R option to chown.

Btw, on my Ubuntu system, the .dmrc has read-write permissions for the user only; not for the group or the world. To fix that on your system:

$ chmod 600 ~/.dmrc

coramill
June 22nd, 2008, 11:58 PM
Set the ownership (and group) of the .dmrc file to your account's user-id. For instance, if the user is 'superman':

$ chown superman:superman ~/.dmrc
If you need to change permissions on a directory and its contents, then supply the -R option to chown.

Btw, on my Ubuntu system, the .dmrc has read-write permissions for the user only; not for the group or the world. To fix that on your system:

$ chmod 600 ~/.dmrc


Thanks that solved the log in nag (chmod 600 ~/.dmrc).

Now since I have one way communications from Windows-->Linux I could probably live with this, but I really would like to use my shared printer from the Ubuntu machine and I'm guessing that there is no point to trying that trick until I can at least browse my Windows LAN from the Linux-->Windows side.

Places>Network>Windows Network icon (Location:network:///) 2click>WORKGROUP

icon (Location:smb:///) 2click> Location:smb://workgroup/> then a long pause and an empty pane with none of the shared resources from the Windows LAN visible.

I verified that I could ping the WinXP machine (System> Administration> Network Tools> Ping tab>192.168.0.100> Ping button)

Under the Devices tab (System> Administration> Network Tools> Devices tab) shows Network device: Loopback Interface (lo)

I changed the Network device: to Ethernet Interface (ethO) but when I close and revisit the Network device: is reset to Loopback.

Changing it to Network device:Ethernet Interface (ethO) and then clicking the Configure button gets a Ubuntu message:

"The interface does not exist
Check that it is correctly typed and that it is correctly supported by your system."

I don't know if this means anything or not

Regards

dwhitney67
June 23rd, 2008, 12:16 AM
I changed the Network device: to Ethernet Interface (ethO) but when I close and revisit the Network device: is reset to Loopback.

why in pray tell did you do that?? Your loopback device should be 'lo'. The 'eth0' interface is usually assigned to the wired network port. Something like 'wlan0' is assigned to the wireless network port.

It bemuses me that you are just reaching for anything to resolve your system's issues.

I understand you have a printer physically connected to the Linux machine. Is this correct?

Have you attempted to share it? Go to System -> Administration -> Printing.

Select the printer you want to share, then click on the "Policies" tab. The printer should be Enabled, Accepting Jobs, and Shared.

Under the "Access Control" tab, ensure that "Allow printing for everyone except these users:" is selected.

That should be it... select "Apply" on the lower-right corner of the Printer Configuration window.

dwhitney67
June 23rd, 2008, 12:21 AM
Changing it to Network device:Ethernet Interface (ethO) and then clicking the Configure button gets a Ubuntu message:

"The interface does not exist
Check that it is correctly typed and that it is correctly supported by your system."

Is your eth0 interface available? The quickest way I know to find out is to run 'ifconfig' from a terminal:

$ /sbin/ifconfig eth0
If it is not enabled (that is, it does not exist), then you have regressed a step or two. Did you change any of the configuration files that load kernel drivers to support your wired network port?

Anyhow, let me know what the result is after running the 'ifconfig'.

BLTicklemonster
June 23rd, 2008, 01:25 AM
Did you go to

System

Administration

Users and Groups

and then click Unlock and enter your password,

then go to

Manage Groups

and then browse down to sambashare

and then put a check mark next to root then press okay?

You do that, and should be able to share a folder without seeing


You do not have permission to create a usershare. Ask you administrator to grant you permission to create a share"

You're using Hardy, right? I shared to my xp boxes without having to edit a single in an editor. All clicking and button pushing, just like God Hisself intended it.

coramill
June 23rd, 2008, 04:07 AM
why in pray tell did you do that?? Your loopback device should be 'lo'. The 'eth0' interface is usually assigned to the wired network port. Something like 'wlan0' is assigned to the wireless network port.

It bemuses me that you are just reaching for anything to resolve your system's issues.

I understand you have a printer physically connected to the Linux machine. Is this correct?

Have you attempted to share it? Go to System -> Administration -> Printing.

Select the printer you want to share, then click on the "Policies" tab. The printer should be Enabled, Accepting Jobs, and Shared.

Under the "Access Control" tab, ensure that "Allow printing for everyone except these users:" is selected.

That should be it... select "Apply" on the lower-right corner of the Printer Configuration window.


No the printer is attached to the WinXP machine.

I tried very explicitly click by click to show what I did. That was to change the default Network device: "Loopback Interface (lo)" to "Network device: to Ethernet Interface (ethO)" in the hopes that was why Ubuntu fails to show the shared Windows resources

And you are right if I knew what I was doing I wouldn't be randomly drilling trying to stumble on to what is causing the problem. I believe it is something relatively simple but beyond my current level of expertise.

I have, thanks to the help received here, resolved half of my problems in that I can now browse from Windows to Ubuntu but I still see no shared Windows resources in Ubuntu when I go down the following path:

Places> Network> Windows Network icon (Location:network:///) 2click> WORKGROUP icon (Location:smb:///) click> Location: smb://workgroup/> then long pause and an empty pane with none of the shared resources from the Windows LAN visible.

Also I do not understand what is indicated by "Bracket B Bracket" and Bracket /B Bracket" also you must be posting with some setting I don't have because when I cut and paste from your text "Go to System -> Administration -> Printing" the brackets and the B's disappear.

Regards

dwhitney67
June 23rd, 2008, 04:18 AM
Have you made the printer that is connected to the WinXP machine shareable? If you have not already done this, right-click on the printer icon, and you will see a menu choice where you can designate it as shareable.

On the Linux machine:

1- Goto System -> Administration -> Printing
2- Ensure that "Show printers shared by other systems" is checked
3- Click on "New Printer"
4- Select "Windows Printer via Samba"
5- Click on the "Browse..." button to search for your WinXP's shared printer
6- Once you have the printer, select it and ... (I don't have Windoze machine so I don't know what comes next)
7- Click on the "Forward" button
8- ... (If I recall, you must now tell Linux what type of printer it is)

That's all. If I had a WinXP system I could provide more details, but I have no such system in my residence.

coramill
June 23rd, 2008, 04:25 AM
Is your eth0 interface available? The quickest way I know to find out is to run 'ifconfig' from a terminal:

$ /sbin/ifconfig eth0
If it is not enabled (that is, it does not exist), then you have regressed a step or two. Did you change any of the configuration files that load kernel drivers to support your wired network port?

Anyhow, let me know what the result is after running the 'ifconfig'.


I Ran "$ /sbin/ifconfig eth0" and got:

eth0......Link encap:Ethernet...HWaddr 00:1f:c6:0c:f8:32
..........inet addr:192.168.0.102
..........Bcast:192.168.0.255...Mask:255.255.255.0
..........inet6 addr: fe80::21f:c6ff:fe0c:f832/64 Scope:Link
..........UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
..........RX packets:41781 errors:0 dropped:0 overruns:0 frame:0
..........TX packets:13909 errors:0 dropped:0 overruns:0 carrier:1
..........collisions:0 txqueuelen:1000
..........RX bytes:2753338 (2.6 MB) TX bytes:1016577 (992.7 KB)

I'm thinking this means no harm no foul to "Network device: Ethernet Interface (ethO)" but it still is not default when I go to Network Tools Loopback is always showing and I cannot Configure the (eth0) Ubuntu error message says it doesn't exist.

Regards,

dwhitney67
June 23rd, 2008, 04:41 AM
It looks like your eth0 device is working properly. For the printer issue you are having, you should not have to mess with the settings in the Network Tools (System->Admin->Network Tools) nor Network (System->Admin->Network).

From your Linux system's command line, you should be able to ping other systems in your network, and you should also be able to ping outside systems too.


$ ping 192.168.0.1 # router
$ ping 192.168.0.101 # other system?
$ ping www.ubuntu.com

If each of these work, then your network interface (presumably eth0) is working just fine.

coramill
June 23rd, 2008, 04:46 AM
Did you go to

System

Administration

Users and Groups

and then click Unlock and enter your password,

then go to

Manage Groups

and then browse down to sambashare

and then put a check mark next to root then press okay?

You do that, and should be able to share a folder without seeing



You're using Hardy, right? I shared to my xp boxes without having to edit a single in an editor. All clicking and button pushing, just like God Hisself intended it.


Yes I'm using 8.04 and the box next to root was checked, however my intention is not to share a folder from 8.04 to Windows--that is now working. What I cannot do is to browse the Windows shared assets while I'm on the Hardy machine. I would like to share and browse from both directions.

Regards,

coramill
June 23rd, 2008, 05:14 AM
Have you made the printer that is connected to the WinXP machine shareable? If you have not already done this, right-click on the printer icon, and you will see a menu choice where you can designate it as shareable.

On the Linux machine:

1- Goto System -> Administration -> Printing
2- Ensure that "Show printers shared by other systems" is checked
3- Click on "New Printer"
4- Select "Windows Printer via Samba"
5- Click on the "Browse..." button to search for your WinXP's shared printer
6- Once you have the printer, select it and ... (I don't have Windoze machine so I don't know what comes next)
7- Click on the "Forward" button
8- ... (If I recall, you must now tell Linux what type of printer it is)

That's all. If I had a WinXP system I could provide more details, but I have no such system in my residence.

Step 5- is the problem when I Browse for the WinXP shared printer I only WORKGROUP shows in the pane with no other shared resources. I have 3 WinXX machines on this network and all of them can browse and print. No passwords just an open system.

Regards,

coramill
June 23rd, 2008, 05:21 AM
It looks like your eth0 device is working properly. For the printer issue you are having, you should not have to mess with the settings in the Network Tools (System->Admin->Network Tools) nor Network (System->Admin->Network).

From your Linux system's command line, you should be able to ping other systems in your network, and you should also be able to ping outside systems too.


$ ping 192.168.0.1 # router
$ ping 192.168.0.101 # other system?
$ ping www.ubuntu.com

If each of these work, then your network interface (presumably eth0) is working just fine.

Pinging has always worked bidirectionally. The proximate issue is that I cannot see anything when I click on Ubuntu's WORKGROUP icon. I get an empty pane where I should (unless I completely misunderstand the way the Ubuntu GUI works) see my shared drives on three other WinXX machines as well as a common printer hanging on the WinXP computer.

Regards

coramill
June 23rd, 2008, 05:33 AM
Have you made the printer that is connected to the WinXP machine shareable? If you have not already done this, right-click on the printer icon, and you will see a menu choice where you can designate it as shareable.

On the Linux machine:

1- Goto System -> Administration -> Printing
2- Ensure that "Show printers shared by other systems" is checked
3- Click on "New Printer"
4- Select "Windows Printer via Samba"
5- Click on the "Browse..." button to search for your WinXP's shared printer
6- Once you have the printer, select it and ... (I don't have Windoze machine so I don't know what comes next)
7- Click on the "Forward" button
8- ... (If I recall, you must now tell Linux what type of printer it is)

That's all. If I had a WinXP system I could provide more details, but I have no such system in my residence.


Step 5- is the problem when I Browse for the WinXP shared printer only WORKGROUP shows in the pane with no other shared resources. I have 3 WinXX machines on this network and all of them can browse and print. No passwords

just an open system.

Regards,

dwhitney67
June 23rd, 2008, 05:34 AM
Your understanding is correct... you should be able to double-click on the WORKGROUP icon, and from there see a listing of the shared folders/printer on the WinXP systems.

Since you are not, I can only assume that perhaps the WinXP firewall is not allowing shared folders to be seen.

Are you able to see shared folders from one WinXP system to another?

coramill
June 23rd, 2008, 01:23 PM
Your understanding is correct... you should be able to double-click on the WORKGROUP icon, and from there see a listing of the shared folders/printer on the WinXP systems.

Since you are not, I can only assume that perhaps the WinXP firewall is not allowing shared folders to be seen.

Are you able to see shared folders from one WinXP system to another?

Yes, All three other WinXX machines can browse and use shared resources with no passwords or other hinderances.

I don't know if this is of any importance but this LAN is comprised of a WinXP pro, Win Me and Win98 computers. I can browse the Ubuntu machine now from WinXP but when I went to the WinMe machine and tried I received a request for a password to open the Ubuntu icon. And the only Ubuntu password that I have created was rejected.

Regards

coramill
June 24th, 2008, 02:17 AM
Solved the Ubuntu to Windows access workaround

Places -->Connect to server

Change service type to "Windows Share"
Server: 192.168.0.100
Share: jmills3
Folder: -
User Name: -
Domain Name: -

click "Connect"

(Location: smb://192.168.0.100/jmills3/)

I still cannot browse the LAN from UBUNTU:

Places> Network> Windows Network icon 2click> WORKGROUP icon 2click

Still a long pause and an empty pane with none of the shared resources from the Windows LAN visible.

Regards

coramill
June 24th, 2008, 04:06 AM
This may sound silly, but have you actually installed samba? The default install only provides the smb client, samba server must be installed after. Once samba is installed you will need to setup your shared folders if you want your win boxes to actually see anything.

Good Question.

I don't know. The Ubuntu machine was pre-installed on the newly built computer.

How do I verify if samba is installed. I just assumed that if /etc/samba/smb.conf existed that samba was installed.

Regards

dwhitney67
June 24th, 2008, 07:52 AM
To verify if Samba is running:

$ ps -ef |grep smb
The output should look something like:

root 5266 1 0 Jun23 ? 00:00:00 /usr/sbin/smbd -D
root 5330 5266 0 Jun23 ? 00:00:00 /usr/sbin/smbd -D
...

coramill
June 24th, 2008, 10:39 AM
To verify if Samba is running:

$ ps -ef |grep smb
The output should look something like:

root 5266 1 0 Jun23 ? 00:00:00 /usr/sbin/smbd -D
root 5330 5266 0 Jun23 ? 00:00:00 /usr/sbin/smbd -D
...

I see something like your example so I assume that it was installed by the vendor but perhaps not configured for a wired Microsoft Windows Network.

Regards

jmills4@ubuntu:~$ ps -ef |grep smb

root 5164 1 0 Jun23 ? 00:00:00 /usr/sbin/smbd -D

root 5287 5164 0 Jun23 ? 00:00:00 /usr/sbin/smbd -D

jmills4 6022 1 0 Jun23 ? 00:00:00 /usr/lib/gvfs/gvfsd-smb-browse --spawner :1.4 /org/gtk/gvfs/exec_spaw/3

root 6050 5164 0 Jun23 ? 00:00:00 /usr/sbin/smbd -D

root 6122 5164 0 Jun23 ? 00:00:00 /usr/sbin/smbd -D

jmills4 6146 1 0 Jun23 ? 00:00:00 /usr/lib/gvfs/gvfsd-smb --spawner :1.4 /org/gtk/gvfs/exec_spaw/9

jmills4 6197 1 0 Jun23 ? 00:00:00 /usr/lib/gvfs/gvfsd-smb --spawner :1.4 /org/gtk/gvfs/exec_spaw/10

jmills4 6385 6367 0 04:18 pts/0 00:00:00 grep smb

Bradtek
June 24th, 2008, 11:43 AM
Check in Synaptic if you have samba installed

See Screenshot
http://img182.imageshack.us/img182/1043/screenshot1vp2.png

dwhitney67
June 24th, 2008, 11:26 PM
I just came from my brother's house where his children use a WinXP system with a shared printer, and surprisingly I had the same problem as the OP described. I was unable to see the shared-printer from my Linux laptop.

I examined the obvious things on the WinXP system (is the printer indeed shared, is the firewall permitting shared folders/printers to be seen) and everything looked good.

Then I looked at the IP information for the WinXP system and I noticed that the Subnet Mask was incorrect. Instead of being 255.255.255.0, it was set to 255.0.0.0. Upon correcting the issue, my Linux system was able to see the printer!

So, Coramill, ensure that you verify the following on your WinXP system:
1) Printer is shared
2) Firewall allows in/out traffic for shared folders/printers
3) The IP properties information is correct.

Then on the Linux Box:
1) Use System->Administration->Printing and attempt to add a new printer. The type should be "Windows Printer via Samba".
2) Select the Browse button to find your printer.


If Step 5 still fails (and it did on my Fedora 9 laptop), then just type in the Samba URL manually. I typed something like WORKGROUP/10.0.1.10/HP8150.

The 10.0.1.10 is the IP address of the WinXP system; the HP8150 is the name given to the shared-printer.

coramill
June 25th, 2008, 01:08 AM
Check in Synaptic if you have samba installed

See Screenshot
http://img182.imageshack.us/img182/1043/screenshot1vp2.png

Thanks,

I ran Synaptic and got results similar to yours.

Synaptic Package Manager display for samba
ftp://temp:123456@home.satx.rr.com/Screenshot-Synaptic Package Manager .png


Regards

coramill
June 25th, 2008, 01:24 AM
I just came from my brother's house where his children use a WinXP system with a shared printer, and surprisingly I had the same problem as the OP described. I was unable to see the shared-printer from my Linux laptop.

I examined the obvious things on the WinXP system (is the printer indeed shared, is the firewall permitting shared folders/printers to be seen) and everything looked good.

Then I looked at the IP information for the WinXP system and I noticed that the Subnet Mask was incorrect. Instead of being 255.255.255.0, it was set to 255.0.0.0. Upon correcting the issue, my Linux system was able to see the printer!

So, Coramill, ensure that you verify the following on your WinXP system:
1) Printer is shared
2) Firewall allows in/out traffic for shared folders/printers
3) The IP properties information is correct.

Then on the Linux Box:
1) Use System->Administration->Printing and attempt to add a new printer. The type should be "Windows Printer via Samba".
2) Select the Browse button to find your printer.


If Step 5 still fails (and it did on my Fedora 9 laptop), then just type in the Samba URL manually. I typed something like WORKGROUP/10.0.1.10/HP8150.

The 10.0.1.10 is the IP address of the WinXP system; the HP8150 is the name given to the shared-printer.

Thanks I thought it might a simple fix but it appears the active ethernet adapter (D-Link DFE-530TX+ PCI) has the correct subnet mask.

The Windows Firewall has Files and Printer sharing enabled and as a check the other Win9X machines can print to the shared printer on the WinXP machine.

I'm not sure I would know how to manually change even if it were incorrect. The adapter's TCP/IP protocols are set to obtain IP addresses automatically which greys out the Subnet mask, IP address and Default gateway.

Regards

From WinXP system ipconfig /all > file

Windows IP Configuration

Host Name . . . . . . . . . . . . : JMILLS3
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection 18:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek RTL8029(AS) PCI Ethernet Adapter #2
Physical Address. . . . . . . . . : 00-40-33-53-E0-A7
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Autoconfiguration IP Address. . . : 169.254.42.137
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :

Ethernet adapter Local Area Connection 19:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : D-Link DFE-530TX+ PCI Adapter
Physical Address. . . . . . . . . : 00-50-BA-49-39-40
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.0.100
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1
DNS Servers . . . . . . . . . . . : 192.168.0.1
Lease Obtained. . . . . . . . . . : Monday, June 16, 2008 5:20:21 PM
Lease Expires . . . . . . . . . . : Monday, June 23, 2008 5:20:21 PM

dwhitney67
June 25th, 2008, 01:52 AM
The other thing I discovered is that if the WinXP is suspended/hybernating, then the printer won't show up, much less allow me to print through it to the printer.

Have you tried specifying the Samba URL as: WORKGROUP/192.168.0.100/jmills3

coramill
June 25th, 2008, 05:33 AM
The other thing I discovered is that if the WinXP is suspended/hybernating, then the printer won't show up, much less allow me to print through it to the printer.

Have you tried specifying the Samba URL as: WORKGROUP/192.168.0.100/jmills3

No, I did something similar when I stumbled on to current work around see below:

But I'll give it a shot if you can point me to the correct path where I can specify a URL for Samba.

Regards

Places -->Connect to server

Change service type to "Windows Share"
Server: 192.168.0.100
Share: jmills3
Folder: -
User Name: -
Domain Name: -

click "Connect"

(Location: smb://192.168.0.100/jmills3/)

dwhitney67
June 25th, 2008, 06:05 AM
No, I did something similar when I stumbled on to current work around see below:

But I'll give it a shot if you can point me to the correct path where I can specify a URL for Samba.

Regards

On your Linux box:
1- Select System->Administration->Printing and afterwards select "New" (printer).
2- For the type, select "Windows Printer via Samba".
3- Then enter the Samba URL: WORKGROUP/192.168.0.100/jmills3
4- Then select "Forward"
5- Then select the brand name of the printer
6- Then find a close/exact match for the model number of the printer
7- Finish.
8- Print a test page & cross fingers.

coramill
June 25th, 2008, 07:32 AM
On your Linux box:
1- Select System->Administration->Printing and afterwards select "New" (printer).
2- For the type, select "Windows Printer via Samba".
3- Then enter the Samba URL: WORKGROUP/192.168.0.100/jmills3
4- Then select "Forward"
5- Then select the brand name of the printer
6- Then find a close/exact match for the model number of the printer
7- Finish.
8- Print a test page & cross fingers.


It was a promising try, however I don't see how Hardy can tell which flavor of printer I have. The printer driver which Hardy recommends has a Windows Share name of "HP Laser Jet 8100 PS" for the postscript driver. There are two other versions using pcl5 and pcl6.

I have drilled on several of the entries in Hardy trying "jmills HP Laser Jet 8100 PS" in various combinations but no success.

The postscript version is the default printer but all are shared.

I think this still gets back to the issue that I cannot browse the Microsoft Windows Network. If I can't see the printer hanging off of JMILLS3 then I doubt if Hardy can either.

My work around that lets me access files from the WinXP machine is only masking the real problem.

Regards

dwhitney67
June 25th, 2008, 08:38 AM
Don't worry about what your Ubuntu distro thinks you have... YOU need to tell Hardy specifically which printer you have.

After entering the the SMB Printer URL, click on "Forward". (see the 1st image below)

Then make sure that you "Select printer from database", and select HP from the Makes menu; then click on "Forward" (see the 2nd image below).

The select the model number "LaserJet 8100 Postscript"; make sure the recommended driver (on the right hand side) is selected; then click on "Forward" (see the 3rd image below).

Select any/all of the options you want your virtual printer on Linux to support (i.e. Tray 4 and/or 5, Duplex Unit, etc); then click on "Forward" (see the 4th image below).

Assign a Printer Name that will be used to identify the printer under Linux; provide a Description and Location if you wish; then click on "Apply" (see 5th image below).

That should be it. Now you have created a printer under Linux. Print a test page to verify if it works or not.

coramill
June 25th, 2008, 09:43 PM
Don't worry about what your Ubuntu distro thinks you have... YOU need to tell Hardy specifically which printer you have.

After entering the the SMB Printer URL, click on "Forward". (see the 1st image below)

Then make sure that you "Select printer from database", and select HP from the Makes menu; then click on "Forward" (see the 2nd image below).

The select the model number "LaserJet 8100 Postscript"; make sure the recommended driver (on the right hand side) is selected; then click on "Forward" (see the 3rd image below).

Select any/all of the options you want your virtual printer on Linux to support (i.e. Tray 4 and/or 5, Duplex Unit, etc); then click on "Forward" (see the 4th image below).

Assign a Printer Name that will be used to identify the printer under Linux; provide a Description and Location if you wish; then click on "Apply" (see 5th image below).

That should be it. Now you have created a printer under Linux. Print a test page to verify if it works or not.


Thanks for the exceptionally clear guidance. I have followed your instructions creating and deleting several iterations. Including rebooting both machines and verifing that the printer really works from the WinXP side. But Hardy doesn't print and gives no indication that it is having trouble connecting to the shared printer. I have left it trying over night on the chance that it is very slow, but no joy.

I have included screen shots below of my efforts just in case I have over looked something in my implementation of your explicit tutorial. I'm getting convinced that the issue of not being able to browse the Windows Network is crucial to the problem.

Regards

system-config-printer 0.7.81
(A CUPS configuration tool.)
ftp://temp:123456@home.satx.rr.com/Screenshot-Printer configuration - localhost.png

Windows Printer via SAMBA
ftp://temp:123456@home.satx.rr.com/Screenshot-New Printer-5.png

Select Printer Driver
ftp://temp:123456@home.satx.rr.com/Screenshot-New Printer-6.png

Installed Options
ftp://temp:123456@home.satx.rr.com/Screenshot-New Printer-7.png

Printer Name
ftp://temp:123456@home.satx.rr.com/Screenshot-New Printer-8.png

Printer Configuration Local Host (Settings tab)
ftp://temp:123456@home.satx.rr.com/Screenshot-Printer configuration - localhost-1.png

Printer Configuration Local Host (Policies tab)
ftp://temp:123456@home.satx.rr.com/Screenshot-Printer configuration - localhost-2.png

Printer Configuration Local Host (Access Control tab)
ftp://temp:123456@home.satx.rr.com/Screenshot-Printer configuration - localhost-3.png

Printer Configuration Local Host (Installable Options tab)
ftp://temp:123456@home.satx.rr.com/Screenshot-Printer configuration - localhost-4.png

Printer Configuration Local Host (Printer Options tab)
ftp://temp:123456@home.satx.rr.com/Screenshot-Printer configuration - localhost-5.png
ftp://temp:123456@home.satx.rr.com/Screenshot-Printer configuration - localhost-6.png

Printer Configuration Local Host (Job Options tab)
ftp://temp:123456@home.satx.rr.com/Screenshot-Printer configuration - localhost-7.png
ftp://temp:123456@home.satx.rr.com/Screenshot-Printer configuration - localhost-8.png

dwhitney67
June 25th, 2008, 10:03 PM
I wonder if you need to install Ghostscript? See if you have it already:

$sudo apt-get install ghostscript
You probably do, so don't be surprised if apt-get reports that the latest version of ghostscript is already installed.

The only other thing I can think of is a firewall setting on your Linux machine. Unfortunately, I don't think Ubuntu provides a GUI interface to manage the firewall (if any). My Fedora system does.

dwhitney67
June 25th, 2008, 10:15 PM
Also, I presume that the printer on the WinXP system does not require a user-id and password to gain access to it. Is this correct? If it does, then you will need to supply this information to the Linux printer configuration.

coramill
June 26th, 2008, 01:08 AM
I wonder if you need to install Ghostscript? See if you have it already:

$sudo apt-get install ghostscript
You probably do, so don't be surprised if apt-get reports that the latest version of ghostscript is already installed.

The only other thing I can think of is a firewall setting on your Linux machine. Unfortunately, I don't think Ubuntu provides a GUI interface to manage the firewall (if any). My Fedora system does.

It looks like Ghostscript is installed

ftp://temp:123456@home.satx.rr.com/sudo apt-get install ghostscript.png

I wonder if the share name that the 8100 has shouldn't be included in the "Device URL:" box.

ftp://temp:123456@home.satx.rr.com/HP 8100 PS Sharing tab.PNG

Regards

coramill
June 26th, 2008, 01:27 AM
Also, I presume that the printer on the WinXP system does not require a user-id and password to gain access to it. Is this correct? If it does, then you will need to supply this information to the Linux printer configuration.

No, over the years I have tried to minimize efforts to prevent access by me to mine.

I have run across considerable Internet traffic regarding Windows Network browsing problems with 8.04 and some have claimed reverting to a down rev. version solved the problem. It may be that there is some problem with the vendor's installation of Ubuntu. As green as I am I think I will gain more experience before going that route.

I could move the 8100 to the Ubuntu machine but it only has USB ports and the printer needs a parallel printer port.

Printing will just have to be done by file transfer to the WinXP machine. Fortunately I have Open Office and Gimp on it so I should be OK.

Thanks again for going to considerable effort to solve what may be a not so rare bug.

Regards

dwhitney67
June 26th, 2008, 02:06 AM
As I said yesterday (or was it the day before?), when I visited my brother's house, I was able to set up a printer resource on my Ubuntu 8.04 for a printer that he has shared on his WinXP system. I was even able to see it!

If it is a bug, then perhaps it is with Samba. I just noticed that the workgroup specified in my /etc/samba/smb.conf file is MSHOME, whereas my brother's PC workgroup is WORKGROUP. Maybe these need to be different (to overcome a bug)?

coramill
June 26th, 2008, 03:35 AM
As I said yesterday (or was it the day before?), when I visited my brother's house, I was able to set up a printer resource on my Ubuntu 8.04 for a printer that he has shared on his WinXP system. I was even able to see it!

If it is a bug, then perhaps it is with Samba. I just noticed that the workgroup specified in my /etc/samba/smb.conf file is MSHOME, whereas my brother's PC workgroup is WORKGROUP. Maybe these need to be different (to overcome a bug)?

Sounds like it is worth a shot, but my attempt was blocked by a "could not save smb.conf" warning see screenshot:

ftp://temp:123456@home.satx.rr.com/etc_samba_smb.config.PNG

Regards

dwhitney67
June 26th, 2008, 04:33 AM
You have to edit the file using gksudo to launch gedit and to get the appropriate permissions necessary to make changes to the file:

$ gksudo gedit /etc/samba/smb.conf

coramill
June 26th, 2008, 08:45 PM
You have to edit the file using gksudo to launch gedit and to get the appropriate permissions necessary to make changes to the file:

$ gksudo gedit /etc/samba/smb.conf

Thanks, I changed the workgroup = WORKGROUP to MSHOME and then rebooted both machines but no print test page.

But interestingly enough now when I browse from Microsoft Windows Network from WinXP > Ubuntu I see Mshome as well as Workgroup and the shared public folder is now in Mshome. This oneway communication is hard to understand.

After each reboot of Hardy I loose the desktop Icon for my workaround solution to not being able to browse to the WinXP machine. The setup proceedure implies that it can be bookmarked.

Places -->Connect to server

Change service type to "Windows Share"
Server: 192.168.0.100
Share: JMILLS3
..(Note Share: name is case sensitive "JMILLS3")
Folder: -
User Name: -
Domain Name: -

click "Connect"
tic Bookmark

(Location: smb://192.168.0.100/jmills3/)

ftp://temp:123456@home.satx.rr.com/Screenshot-Connect to Server.png
Where is the bookmark located?

Under Properties for this shared Folder I ticked the Emblem for Shared. Now it shows a bi-direction icon next to the desktop folder. Does this mean anything or is it just a mnemonic to remind you about the desktop Icon?

A click on the Wired Network Connection Icon indicates that Wired Network is selected. Under "Manual Configure" option the connection is set to roaming. And under the Permissions tab the permissions for the WinXP machine could not be determined. Which is further evidence that they are not talking--aleast through the GUI.

ftp://temp:123456@home.satx.rr.com/Screenshot-jmills3 on 192.168.0.100 Properties.png

Regards

dwhitney67
June 26th, 2008, 11:35 PM
Under Properties for this shared Folder I ticked the Emblem for Shared. Now it shows a bi-direction icon next to the desktop folder. Does this mean anything or is it just a mnemonic to remind you about the desktop Icon?

What happens when you double-click on that newly created (desktop) icon?

coramill
June 26th, 2008, 11:50 PM
What happens when you double-click on that newly created (desktop) icon?


It shows all the folders on JMILLS3 shared or not.

ftp://temp:123456@home.satx.rr.com/Screenshot-jmills3 on 192.168.0.100 - File Browser.png

Regards

dwhitney67
June 27th, 2008, 01:39 AM
Ok good. But your Ubuntu system still cannot "see" the shared printer, is that correct?

Do you still have the printer resource that you created on the Ubuntu system? Can you see it from an application such as Firefox or Open Office? Have you tried printing from one of these applications?

coramill
June 27th, 2008, 03:03 AM
Ok good. But your Ubuntu system still cannot "see" the shared printer, is that correct?

Do you still have the printer resource that you created on the Ubuntu system? Can you see it from an application such as Firefox or Open Office? Have you tried printing from one of these applications?

The printer is not visible when trying to browse Microsoft Windows Network from Ubuntu or any other resources for that matter.
Yes the printer is visible from within Open Office on Ubuntu, but the printer remains unresponsive.

Regards,

dwhitney67
June 27th, 2008, 03:24 AM
Well, unfortunately I do not know what else to suggest. Perhaps someone else can lend a hand. You may want to consider starting a new thread, with a title like "Cannot get Ubuntu to see a WinXP Shared Printer". Maybe you might get some better responses that way.

Alternatively, you can search or perhaps post a query on the LinuxQuestions.org forum (http://www.linuxquestions.org/questions/).

Good luck with everything.

coramill
June 27th, 2008, 03:43 AM
Well, unfortunately I do not know what else to suggest. Perhaps someone else can lend a hand. You may want to consider starting a new thread, with a title like "Cannot get Ubuntu to see a WinXP Shared Printer". Maybe you might get some better responses that way.

Alternatively, you can search or perhaps post a query on the LinuxQuestions.org forum (http://www.linuxquestions.org/questions/).

Good luck with everything.

Thank you for all the help and I have certainly added tricks to my tool box.

Regards

dwhitney67
June 27th, 2008, 03:52 AM
You're welcome!