PDA

View Full Version : [ubuntu] Tethering with Treo 700wx over bluetooth



hoborocket
June 19th, 2008, 06:40 AM
Title explains it, really. I have a Treo 700wx, and a laptop without USB support. I followed the instructions found here: http://www.thejoe.com/2007/05/17/bluetooth-pairing-and-tethering-in-ubuntu-feisty/

However, when I open gnome-ppp, it gets to "Dialing #777", sits there for a bit, then dumps me back to the connection window with no error.

The log gives me this:


--> Ignoring malformed input line: ";Do NOT edit this file by hand!"
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATX3
OK
--> Sending: ATZ
OK
--> Sending: AT+CGDCONT=1,"IP","isp.sprint"
OK
--> Modem initialized.
--> Sending: ATM1L3DT#777
--> Waiting for carrier.
OK

I'm quite lost here. What am I doing/not doing wrong? My best guess is the init strings, but what they ARE supposed to be isn't actually documented anywhere.

revjtanton
May 13th, 2009, 08:16 PM
This is a really late bump...but I'm having this problem. I've got a Treo and I can't connect. OBEX is erroring out too. I've got Sprint so I didn't thin OBEX was disabled like it is with Verizon. Maybe I should just wait a few more days and get the Pre? I'm going to do that anyway.

revjtanton
May 14th, 2009, 02:30 AM
I actually figured this out a little while after I asked. PPP is trying to establish a connection via wvdial w/o su privliges. Just adjust /etc/wvdial.conf then run sudo wvdial and it'll work easy...now if only Sprint's 4G network and Pre was made available!