PDA

View Full Version : [ubuntu] screen resolution



nss_120
June 9th, 2008, 12:54 AM
hi, i'm just new here...

I just installed Ubuntu Feisty Fawn and I got no issues installing it on my PC, but the resolution available on the 'screen resolution' preference are 640x480 and 800x600, how can I make it at least 1024x768? My graphics card is ATI Radeon 7000, 64MB vram, and my processor is Pentium 4 2.40Ghz, 512 RAM.

gilforsyth
June 10th, 2008, 05:15 AM
Hello nss_120. Welcome!

If you haven't already, you should check out the ATI Driver Install Wiki. Here's a link to the Feisty page:

http://wiki.cchtml.com/index.php/Ubuntu_Feisty_Installation_Guide

iaculallad
June 10th, 2008, 05:21 AM
hi, i'm just new here...

I just installed Ubuntu Feisty Fawn and I got no issues installing it on my PC, but the resolution available on the 'screen resolution' preference are 640x480 and 800x600, how can I make it at least 1024x768? My graphics card is ATI Radeon 7000, 64MB vram, and my processor is Pentium 4 2.40Ghz, 512 RAM.

Welcome to the forum:

If you can't figure out how the link (guide) above works, Try to post the result of this terminal command:


cat /etc/X11/xorg.conf

johnlvs2run
June 10th, 2008, 06:47 AM
I was about to ask the same thing. My screen is 1440x900, but there are only 3 choices in system > preferences > screen resolution, with the highest at 1280x1024. I put together this computer 2 days ago and had some issues with Ubuntu recognizing the Sata hard drive, finally getting it installed on the hard drive today. There might be some issues with drivers not yet installed.

john@john-computer:~$ cat /etc/X11/xorg.conf
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
EndSection
john@john-computer:~$

Epidemic_HardyBoy
June 10th, 2008, 07:18 AM
If any of these didnt work, your problem may be simple, your Graphics Driver might be out of date

System -> Administration -> Hardware Drivers

Then there should be a graphics driver up there, click the box and your good to go after a restart.

gilforsyth
June 10th, 2008, 07:25 AM
Hi John,
Have you enabled the proprietary NVIDIA driver?

System > Administration > Restricted Drivers Manager
Enable the video driver and reboot.

Alternatively, you can try to install EnvyNG, guide here (http://albertomilone.com/envyngfaq.html#A). I don't have an ATI or Nvidia card so I haven't used this, but it's supposed to automate the installation of your video drivers.

fhmanas
June 10th, 2008, 07:30 AM
open a terminal and reconfigure your X

dpkg reconfigure xserver-xorg

go through the screens until you see the screen resolutions, choose all that you need, the highest one will be seen when you reboot

cocopuffz
June 10th, 2008, 07:59 AM
Try "gksudo displayconfig-gtk" and select your monitor in there. if you don't see it, try the autodetect. It may say Plug and play monitor... worked for me.

This fixed my probs with my Nvidia drivers, xorg.conf file and new LCD.

"dpkg-reconfigure xserver-xorg" worked for me before hardy when I had an ATI card... so you may wanna try that too first.

johnlvs2run
June 11th, 2008, 02:24 AM
Thanks for responses. However, there are still issues with the screen.
Resolution should be 1440x900, but it's 800x600 with no better choices.
system > administration > hardware drivers
Device driver
> Nvidia accelerated graphics driver -- /\ -- not in use.

I enabled the driver at midday, rebooted, and the screen was all haywire.

It stayed that way, regardless what I did, so I had to reinstall unbuntu.
Now I'm back. :) And a bit shy about enabling that driver again.

Is there anything else I can do, and what if it goes haywire again.

iaculallad
June 11th, 2008, 02:48 AM
Thanks for responses. However, there are still issues with the screen.
Resolution should be 1440x900, but it's 800x600 with no better choices.
system > administration > hardware drivers
Device driver
> Nvidia accelerated graphics driver -- /\ -- not in use.

I enabled the driver at midday, rebooted, and the screen was all haywire.

It stayed that way, regardless what I did, so I had to reinstall unbuntu.
Now I'm back. :) And a bit shy about enabling that driver again.

Is there anything else I can do, and what if it goes haywire again.

Try this:

-Create a backup of your current xorg.conf file:


sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.original

-Open it for editing:


sudo gedit /etc/X11/xorg.conf

-Select all text inside your current xorg.conf file and delete it. Replace it with the edited version of your xorg.conf file below. Save it and Restart your GDM.


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
HorizSync 30-110
VertRefresh 50-160
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
EndSection

johnlvs2run
June 11th, 2008, 03:11 AM
Alternatively, you can try to install EnvyNG, guide

In the meantime I tried EnvyNG, got a black screen, and now I'm back on the liveCD again.

Before trying anything else, is there any way to get a screen on the harddrive without reinstalling again?

johnlvs2run
June 11th, 2008, 04:03 PM
I'm having major video issues trying to get 1440x900 resolution instead of 800x600. First the screen came out all streaked, so I had to do a complete reinstall. I then I tried again a different way, ended up with a black screen and couldn't get in to the hard drive again. Now I'm running from the liveCD while trying to figure out how to get into the hard drive. I think also my sound is not working.

Is there any way to get into the hard drive, past the streaked or black screens, without reinstalling again?

Once I get in, is there any other way to get the 1440x900 resolution? Apparently there is an issue with the video and audio drivers, for Nvidia?