PDA

View Full Version : [ubuntu] [SOLVED] NVidia GeForce FX 5200 + Samsung SyncMaster 710 N installation woes



Itsamnaaj
June 8th, 2008, 02:26 AM
PROBLEM DESCRIPTION:

My NVidia GeForce FX 5200 video card and Samsung SyncMaster 710 N monitor are not detected by Ubuntu.

On boot, X shows a popup stating video card + monitor were not detected, subsequently loads in low graphics mode. When I run 'nvidia-settings', it says: "You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run 'nvidia-xconfig' as root), and restart the X server." I wanted to save a binary EDID file (and add the line Option "CustomEDID" "DFP-0:/etc/X11/edid_04_28_2008.bin" to xorg.conf), which is not possible because 'nvidia-settings' malfunctions. When I delete 'xorg.conf' or specify to load vesa drivers, X boots without low graphics mode, but of course without loading the NVidia drivers (and without 3D acceleration, openGL and whatnot).


WHAT I HAVE DONE:

- I have installed the latest drivers for my video card (version: 173.14.05).
- I followed NVidia's installation instruction manual meticulously.
- I used 'read-edid' to acquire my monitor's EDID data and added it to xorg.conf.
- I manually configured xorg.conf.

Below is my xorg.conf file:



# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg
Section "Module"
# Load "GLcore"
Load "glx"
Load "dbe"
Load "v4l"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbVariant" "intl"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "Device"
Identifier "nVidia Corporation NV34 [GeForce FX 5200]"
Driver "nvidia"
EndSection

Section "Monitor"
Identifier "SyncMaster"
VendorName "SAM"
ModelName "SyncMaster"
HorizSync 30-81
VertRefresh 56-75
Mode "1280x1024"
DotClock 108.000000
HTimings 1280 1328 1440 1688
VTimings 1024 1025 1028 1066
Flags "+HSync" "+VSync"
EndMode
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation NV34 [GeForce FX 5200]"
Monitor "SyncMaster"
Option "AddARGBGLXVisuals" "True"
Option "UseDisplayDevice" "DFP"
SubSection "Display"
Depth 24
Modes "800x600" "1024x786" "1600x1200"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
EndSection



MY QUESTION:

How do I configure my xorg.conf or what do I install to make X recognize my GeForce FX 5200 and my SyncMaster 710 N, to enable 3D acceleration and openGL and make 'nvidia-settings' work?

I hope I have been clear and concise. Please don't PM any solutions, contribute to the topic so others like myself may benefit.

Thanks in advance,

- Itsamnaaj

Rocket2DMn
June 8th, 2008, 02:34 AM
You should try using EnvyNG to install the restricted drivers for you, the 173 drivers may not be compatible with your card.
http://www.albertomilone.com/envyngfaq.html#A

You can remove the drivers you install manually with something like

sudo ./name_of_installer.bin --uninstall
Then have X reconfigure to a generic xorg.conf file with

sudo dpkg-reconfigure xserver-xorg -phigh
You should reboot before installing the driver with EnvyNG.

Itsamnaaj
June 8th, 2008, 03:02 AM
Thank you, Rocket2DMn.