PDA

View Full Version : [ubuntu] So irritating : Language Layout Switching Shortcut Has To be set after each Reboot



jarelkamar
June 8th, 2008, 01:21 AM
I have English USA and Arabic Layouts for my keyboard languages . I usually Set Caps Lock to be the shortcut to switch between them . the problem is everytime I reboot the machine or log out the short cut is deactivated somehow and I have to disable and enable CAPS as my choice in they keyboard preferences menu ....

I didn't have this problem in gutsy . I use Hardy heron now and this is almost the only bug irritating me about .. A little help may make my ubuntu experience perfect

Thx in advance

ZabiGG
June 8th, 2008, 05:10 AM
Hi :)

I solved that problem (EN-FR) in System > Preferences > Keyboard > Layouts >

I chose both languages

Then clicked Layout Options

and, in Layout Switching

chose the key combination of my choice (You would choose Caps Lock key changes layout).

Closed everything and was done. I also have SCIM on board.

Hope this helps.

Z.

jarelkamar
June 8th, 2008, 05:12 AM
yeah I do Exactly that ZabiGG but the problem is I have to redo all these steps everytime I reboot the machine or logout .. It keeps restoring itself to the defaults .. ( with no switching )