PDA

View Full Version : [ubuntu] Changing Launched Application Behaviour



linthusiast
June 5th, 2008, 11:35 PM
I know as I write this that it is a stupid question, but still I have to write it because I can't find the answer elsewhere.

Problem
When I launch an application, the default operation (on my Hardy install) is to start the application, but leave it minimized. I want applications to open up in the foreground in their pre-defined startup state, i.e. not minimized. This is actually becoming quite frustrating because I'm developing some Java GUI code write now and testing it is annoying me.

Cheers

cmnorton
June 7th, 2008, 12:32 PM
I liked your question, because it is good to learn new things. I do not know a lot about gnome (or KDE for that matter), and it would be good to learn more..

The only thing that comes to mind is look for an application's config file under your home directory. Also, search these forums for a phrase like gnome desktop settings, and here is another link you might find useful

http://developer.gnome.org/arch/gnome/corecomponents/

Vivaldi Gloria
June 7th, 2008, 01:27 PM
I know as I write this that it is a stupid question, but still I have to write it because I can't find the answer elsewhere.

Problem
When I launch an application, the default operation (on my Hardy install) is to start the application, but leave it minimized. I want applications to open up in the foreground in their pre-defined startup state, i.e. not minimized. This is actually becoming quite frustrating because I'm developing some Java GUI code write now and testing it is annoying me.

Cheers

Didn't your mother teach you not to play around with your compiz settings?

Joke aside, the default hardy behaviour is to start non-minimized. Did you change anything in gconf-editor or compiz-settings?