PDA

View Full Version : [ubuntu] Hardware Acceleration not enabled ATI Mobility Radeon X1600



Dragon45
May 27th, 2008, 05:58 AM
I want to run some FOSS stuff that needs hardware acceleration but glxinfo | grep direct says it's not enabled. Running on an HP laptop.

The xorg.conf:



# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"

# Uncomment if you have a wacom tablet
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
Identifier "Default Layout"
screen 0 "aticonfig-Screen[0]" 0 0
Inputdevice "Generic Keyboard"
Inputdevice "Configured Mouse"
Inputdevice "Synaptics Touchpad"
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
EndSection

Section "InputDevice"
Identifier "stylus"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "eraser"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "cursor"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]"
Busid "PCI:1:0:0"
Driver "ati"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]"
Device "aticonfig-Device[0]"
Monitor "aticonfig-Monitor[0]"
Defaultdepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1900x1200"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "true"
EndSection

Dragon45
May 27th, 2008, 07:00 AM
Last bit of relevant info: running Hardy, fully patched. ATI binary blob drivers.

oedha
May 27th, 2008, 07:07 AM
have you enable ATI restricted driver ?
system - administration - hardware drivers

kesman
May 27th, 2008, 07:08 AM
If that doesn't help, isntall envyng-gtk from synaptic and use it to install ATI drivers.

Dragon45
May 28th, 2008, 05:37 AM
Tried both suggestions, neither worked.

I'm a programmer who wants to resume 3D-enabled work under ubuntu. I do not want to go back to Windows to program, ever.


Can anyone offer any further advice?

oedha
May 28th, 2008, 06:09 AM
mmm.....what if you open terminal and type :==> sudo apt-get install xorg-driver-fglrx
then reboot
if still not OK.....in terminal :==> sudo dpkg-reconfigure xserver-xorg ( what's the new syntax for this ? )
maybe those can help :)

Dragon45
May 29th, 2008, 07:26 AM
I tried dpkg --reconfigure (the actual command was in the xorg conf)

didn't work

tried the other command; didn't work.