PDA

View Full Version : [ubuntu] blue skin in movies



galliard
May 23rd, 2008, 05:45 PM
hello, I have a problem watching movies. in every one of them (even animated) people have blue skin. other colors are also broken but not as much.
today i installed randomly many plugins to have my audioplayer work right, maybe one of those plugins/codecs is responsible for it.

anybody has ideas what should i install/uninstall to have my proper colors back?

regards

nlbs
May 23rd, 2008, 05:54 PM
which player you are trying ?

cor2y
May 23rd, 2008, 06:23 PM
Let me guess Nvidia card using the closed source drivers?
Open up Totem (Application->Sound & Video->Movie Player) and go to the display settings tab (Edit->Preferences) and adjust the HUE setting either to the max or min , then in whatever media player you choose the video should now have the correct color.
This is due to nvidia resetting how the HUE color is displayed in video with their closed source driver (they reversed the settings) and they have no plan to correct this.

el Arm
May 25th, 2008, 02:35 PM
Let me guess Nvidia card using the closed source drivers?

Thanks for this, I was getting the same problem and this fixes it nicely.

There may be more a more complicated interaction that is causing it though. I have been watching videos (avi) happily since Hardy came out but, similar to the OP, yesterday I installed a whole batch of players and other packages in a (so far futile) attempt to get DVD playback working, and today the blue started.

It occured in all players (MPlayer, totem-xine, totem-gstreamer, VLC, xine) so that definitely points to a lower-level issue like the graphics drivers but or course it worked originally and the drivers haven't changed.

For the record, I'm on 8.04 amd64 using the NVIDIA restricted drivers.

pjbgravely
July 20th, 2008, 02:39 AM
I had the color inversion and fixed it with the work arounds. The result was a normal but degraded picture.

Looking through the bug reports I see there are 3 different causes for the same problem.

Sometimes the problem is caused by installing gxine. Something in the configuration files is doing it. The fix is to completely remove gxine.

sudo apt-get purge gxine

Restart X and if that was the cause your problem will be fixed without work arounds.

Paul

jon_herr
December 5th, 2008, 06:36 AM
Use 'smplayer'

sudo apt-get install smplayer

Funny how if it's nvidias fault then it only shows up in Movie Player and not 'vlc' or 'smplayer'... I think the problem is something else... Anyway, smplayer works.