PDA

View Full Version : [ubuntu] vVidia driver problems



pir
May 22nd, 2008, 03:36 PM
I have tried several tutorials, but I can't seem to get my dual monitor setup to work. I have two monitors, both 1440*900. My graphics card is nVidia 8600.

The problem which keeps coming back is

You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.
when trying to run nvidia-settings.

Currently, I think I am very near to the solution, but each time I try to do one step further, it doesn't work anymore.

What is working:
Both monitors give a resolution of 1440*900. There is a cloned output.

I think I am currently using nvidia-glx-legacy.

http://pastebin.com/f4401df1a is my current xorg.conf


ANY HELP IS APPRICIATED! Thanks!

pseudo-random
May 22nd, 2008, 03:41 PM
http://ubuntuforums.org/showthread.php?t=780777&highlight=nvidia+dual+monitors

pir
May 22nd, 2008, 03:48 PM
http://ubuntuforums.org/showthread.php?t=780777&highlight=nvidia+dual+monitors

Another tutorial...
Well, I hope this will work, I'll post here if it worked.

Tnx for the reply ;)

pir
May 22nd, 2008, 04:34 PM
Well, 90% worked, I am now stuck at step 8.

Via $ gsku displayconfig-gtk I should be able to edit the monitor settings of both monitors, but it only shows one monitor.

How can I make my 2nd monitor appear in displayconfig-gtk?

pir
May 23rd, 2008, 02:57 PM
:frown:
It won't work. I am getting really frustrated now :-(

I have just reinstalled my PC with 7.10

It just wont work. Anyone who would like to help me PLEASE I do not know what to do :(

Ringi
May 23rd, 2008, 03:39 PM
I think I am currently using nvidia-glx-legacy.


Then you have install a wrong driver:


If you have a TNT, TNT2, or older GeForce, you may need the nvidia-glx-legacy

Check in Synaptic Package Manager, search: nvidia-glx-legacy

pir
May 23rd, 2008, 06:35 PM
Thnx for the replies.
It works now. I am so happy :)

What I did to get my Dualscreen working on one nvidia card:
-> Clean install of 8.04
-> Activated restricted drivers
-> Installed nvidia-settings

I even got compiz working:)