PDA

View Full Version : [ubuntu] xorg.conf ?



Drakkor
May 19th, 2008, 04:05 PM
Yeah, I was trying to run gparted,but got a fatal message that it found no screens,and then something about xorg.conf. Here is mine:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
EndSection
Section "Module"
Load "glx"
EndSection

mrpena
May 19th, 2008, 04:17 PM
looks like there's no modes in the screen section.


Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
Modes "1024x768"
EndSection


add that and whatever your resolution actually is, lemme know if it works.

philinux
May 19th, 2008, 04:31 PM
If he's running Hardy it wont have any mode section.

See if
System>Prefs>Screen Resolution

Sorts it.

This is my xorg.

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
EndSection
Section "Module"
Load "glx"
EndSection

mrpena
May 19th, 2008, 04:35 PM
If he's running Hardy it wont have any mode section.

See if
System>Prefs>Screen Resolution

Sorts it.

This is my xorg.

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
EndSection
Section "Module"
Load "glx"
EndSection

Ahh, sorry for the misinformation!

Drakkor
May 19th, 2008, 04:45 PM
@ philinux
Isn't my xorg.conf like your's ?
Tried the modes deal,but still no dice with gparted,and then had to remove it because after reboot I only had 800x600 resoulution
:confused: running Hardy

philinux
May 19th, 2008, 05:04 PM
Just checked , your xorg is exactly same as mine.

what happens when you run

System>Prefs>Screen Resolution.

Also what's going on in

System>Admin>Hardware Drivers

Drakkor
May 19th, 2008, 05:14 PM
Here we go

philinux
May 19th, 2008, 05:44 PM
Things look ok there. Is that resolution what you're getting now?

Drakkor
May 19th, 2008, 05:55 PM
Yeah, after taking out the Modes "1024x768" in xorg.conf
which I think screwed up my nvida drivers, I'm back to my original
1024x768 resolution.

philinux
May 19th, 2008, 05:58 PM
So are we there, are you happy. :)

Drakkor
May 19th, 2008, 06:03 PM
I'm back at the beginning, I still can't run GParted !

philinux
May 19th, 2008, 06:25 PM
I would only run gparted on a spare hard drive. I would use the live cd, or gparted boot disk.. Have a copy of super grub ready as well.

mc4man
May 19th, 2008, 06:27 PM
Are you running (trying) gparted from ubuntu or using the gparted live cd?

Drakkor
May 19th, 2008, 06:55 PM
Yeah, I'm trying to run the GParted live CD version 0.3.6-7