PDA

View Full Version : [ubuntu] ubuntu 8.04 server, apache2 and webmin



badman35
May 14th, 2008, 01:22 AM
i have setup ubuntu server 8.04 lts last night and i also installed webmin 1.410. the problem is that the apache sever is running and webmin says it is not. when i click the "start apache" link it says that there is an error. so can somone out there tell me just what is going on?????!!!!!

oh when i installed ubuntu server i installed everything when it asked for what i wanted to in stall....

windependence
May 14th, 2008, 07:50 AM
i have setup ubuntu server 8.04 lts last night and i also installed webmin 1.410. the problem is that the apache sever is running and webmin says it is not. when i click the "start apache" link it says that there is an error. so can somone out there tell me just what is going on?????!!!!!

oh when i installed ubuntu server i installed everything when it asked for what i wanted to in stall....

Do you think maybe you could post the error? This is not much to go on.

-Tim

d2allgr
May 14th, 2008, 08:39 AM
Had the same problem and fixed it as follows:
in /etc/apache2/apache2.conf I changed
PidFile ${APACHE_PID_FILE} to PidFile /var/run/apache2/apache2.pid ,
User ${APACHE_RUN_USER} to User www-data and
Group ${APACHE_RUN_GROUP} to Group www-data .
After that I set the pid location in the module configuration for apache2 in webmin and did an apache2 restart from shell. Worked fine since then.

badman35
May 16th, 2008, 05:56 AM
ok here is the error that i get
Module Index
Error
Failed to start apache : Apache does not appear to be running :

httpd (pid 4698) already running

<- Return to previous page


Ok now can sombody tell me what i need to do to get it to work????

firebottle
June 2nd, 2008, 09:02 AM
Ok now can sombody tell me what i need to do to get it to work????
1. When you enter the apache module in webmin, click 'module config' at the upper left of the page.

2. Scroll down to the 'System configuration' section, and find the setting for 'Path to Apache PID file.'

3. Enter '/var/run/apache2.pid' and hit the 'save' button.


If someone else has a better solution, I'm all ears. :evil:

firebottle
June 2nd, 2008, 09:14 AM
After that I set the pid location in the module configuration for apache2 in webmin
I'm pretty sure that's all you really needed to do.[-X

motin
July 11th, 2010, 09:18 AM
Thanks a bunch!
One of my servers had this issue and it just got annoying after some time. Adjusting the path to pid file in apache2.conf and setting it in webmin apache module system configuration did it.