PDA

View Full Version : [ubuntu] 8.04 upgrade killed my wireless



johncoyne
May 13th, 2008, 09:27 PM
I have a Dell Inspiron 6400 which I bought with Ubuntu 7.04 and which happily upgraded to 7.10.
When I upgraded to 8.04 my wireless internet connection died.

I tried http://linuxtechie.wordpress.com/2008/04/24/making-intel-wireless-3945abg-work-better-on-ubuntu-hardy/

That involved loading Unsupported updates (Hardy backports) and it achieved the (permanent) illumination of the wireless LED, but nothing else.

I tried following the sticky thread on manual configuration of the wireless interface, but I got errors

john@dell:~$ sudo dhclient -r wmaster0
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/wmaster0/
Sending on LPF/wmaster0/
Sending on Socket/fallback
john@dell:~$ sudo ifconfig wmaster0 up
SIOCSIFFLAGS: Operation not supported

Is there a route back to 7.10 for me?

Thanks,
John Coyne, Liverpool England