View Full Version : [ubuntu] [SOLVED] help my tower wont connect to the internet

May 11th, 2008, 08:36 PM
i have been having problems connecting to the internet with my tower that is running ubuntu 8.04 , its connected via Ethernet to my wrt54g which when i connect my laptop to the router via a Ethernet cable it works just fine but when i connect my tower that is running ubuntu it wont work ( but if i boot into windows ( i know odd ) the internet works just fine ( thats the same computer))

here is the output of a bunch of stuff tell me if you need more i will be happy to fetch it

spalla@spalla-desktop:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:50:2c:0a:4c:cf
inet addr: Bcast: Mask:
inet6 addr: fe80::250:2cff:fe0a:4ccf/64 Scope:Link
RX packets:2 errors:0 dropped:0 overruns:0 frame:0
TX packets:11 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:416 (416.0 B) TX bytes:1118 (1.0 KB)
Interrupt:16 Base address:0xd400

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:4074 errors:0 dropped:0 overruns:0 frame:0
TX packets:4074 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:203700 (198.9 KB) TX bytes:203700 (198.9 KB)

spalla@spalla-desktop:~$ netstat -rn
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface U 0 0 0 eth0 U 0 0 0 eth0 UG 0 0 0 eth0
spalla@spalla-desktop:~$ ping
PING ( 56(84) bytes of data.

--- ping statistics ---
246 packets transmitted, 0 received, 100% packet loss, time 245009ms

spalla@spalla-desktop:~$ nslookup www.google.com
;; connection timed out; no servers could be reached


i am also using the opendns servers if that helps

i have no idea were to go from here

May 11th, 2008, 10:07 PM

May 11th, 2008, 10:57 PM
hmm the error for the nslookup makes it seem like you do not have dns set up properly. Try doing an nslookup on a working computer for google and then ping that IP address on your Ubuntu 8.04 tower to see if you can ping a regular IP... if that works then you just need to find your DNS server from a working computer and set that on your Tower

ohh yeah also try pinging, which is your router.. if that works you know your card is working, and since you have a default gateway and you know your router is working, that should be a pretty good sign it is DNS

May 11th, 2008, 11:18 PM
i tried pinging the (opendns's DNS)
but that didnt work, but if i go to firefox and i type for the address it goes strait to the google home page but if i try to ping that address it doesnt work ?

any other ideas ?

May 11th, 2008, 11:28 PM
right click the Network Manager icon at the top right of your screen and go to Connection Information and tell me what you see.. Just because you can not ping something does not mean it is not there.. some sites block pings so it just drops.

May 11th, 2008, 11:38 PM
oh i didnt know that and it says this

interface:Ethernet (eth0)
speed: 100mb/s
driver: via-velocity

ip address:
broadcast address
subnet mask
default route
primary dns
secondary dns
hardware address 00:50:2C:0A:4C:CF

is it possible there is some kind of firewall
i already uninstalled that ufw a while ago is there anything else like that ?

May 12th, 2008, 02:34 AM

May 12th, 2008, 01:41 PM

May 12th, 2008, 02:07 PM
Although you have an IP address associated with your interface, eth0, you are not actually connected to the router:
--- ping statistics ---
246 packets transmitted, 0 received, 100% packet loss, time 245009msBy the way, if it won't reply in 3-4 pings, it sure won't do so in 246. You can control the number of pings by specifying the count:
ping -c3 192,168.1.1I suggest removing all the data here:
ip address:
broadcast address
subnet mask
default route
primary dns
secondary dns
hardware address 00:50:2C:0A:4C:CF
and specifying DHCP. The problem I have with static IP addresses, when you are troubleshooting, is that when you are not connected, you have an IP address; when you are connected, you have an IP address. With DHCP, you only get an IP address when you connect. When you have everything set to DHCP, then do:
sudo dhclient eth0Let us know if you connect or time out. If you need a static IP address for some other reason, let's address that once we actually connect.

May 12th, 2008, 09:51 PM
alright this is what i got
spalla@spalla-desktop:~$ sudo dhclient eth0
[sudo] password for spalla:
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth0/00:50:2c:0a:4c:cf
Sending on LPF/eth0/00:50:2c:0a:4c:cf
Sending on Socket/fallback
DHCPDISCOVER on eth0 to port 67 interval 8
DHCPREQUEST of on eth0 to port 67
DHCPACK of from
bound to -- renewal in 42457 seconds.

and the internet still doesn't work

May 12th, 2008, 11:41 PM
Try checking the physical parts, such as the cable, lights on the router, and port... Try each of these to see if one gives us new info

1. Look at the port where the cable is plugged in to see if there are lights on both the router and the computer.

2.Move the cable to a different port and test to see if it works.

3. Try a new cable and see if it works.

If all of these work fine try taking the cable from your modem and plug it directly into your computer then restart the modem and wait a couple min then test to see if it works.