PDA

View Full Version : [ubuntu] Sync out of range....



joegiampaoli
May 9th, 2008, 04:45 AM
Hi all I'm running Hardy 32 bit with Nvidia drivers
installed with EnvyNG by Alberto Milone, I get a lot of Sync Out Of Range errors when launching mostly all full screen games downloaded from repos, never had this issue in past releases of ubuntu. This is surely something wrong with my video config I believe, I checked xorg.conf but it has totally changed with no resolutions listed, here's my xorg.conf:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Option "AddARGBGLXVisuals" "True"
Defaultdepth 24
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "latam"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

:confused::confused::confused:

Lamb Chop
May 9th, 2008, 08:31 AM
It seems like we're in the same boat :) I'm having the same trouble and I suspect this is the wrong-doing of the new Xorg 7.3 autodetect. You can try setting stuff manually in your /etc/X11/xorg.conf.

joegiampaoli
May 9th, 2008, 08:43 AM
Thx for responding. Well I,ve been doing some readin here and there and it seems that if you add monitor resolutions there it will ignore them. The new xorg.conf.... actually I was hoping for a more complex file with more options, that would be nice....but this file is a joke

PmDematagoda
May 9th, 2008, 08:47 AM
Thx for responding. Well I,ve been doing some readin here and there and it seems that if you add monitor resolutions there it will ignore them. The new xorg.conf.... actually I was hoping for a more complex file with more options, that would be nice....but this file is a joke

The small xorg.conf is part of the new X-Server which aims to be dynamic and to do away with the xorg.conf file. And unfortunately I face this same problem, the games that needs full-screen can't run because of the Sync out of range error, the same games work properly on Ubuntu 7.04 so the issue maybe something with the X-Server itself.

joegiampaoli
May 9th, 2008, 09:05 AM
Thx for confirming before I started tweaking all kinds of things. I guess we'll just have to sit back and wait then till the folks at development see into this.

joegiampaoli
May 21st, 2008, 08:24 AM
BUMP*

Well anyone else with this issue? A simple yes or no will help so I know what is going on with my xorg.conf file, I've been fiddling with it installing and removing drivers, redetecting, etc, and still no good, a lot of fullscreen opengl games and programs keep giving me sync out of range, this didn't happen before.

EDIT: Here's my new xorg.conf after all the fiddlin' maybe smeone would be kind enough to point me out a solution....

Thx.


# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@vernadsky) Tue Mar 4 20:24:34 UTC 2008

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "latam"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "LG L1718S"
HorizSync 30.0 - 83.0
VertRefresh 50.0 - 75.0
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 6200"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "CRT-0"
Option "metamodes" "nvidia-auto-select +0+0"
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Wim Sturkenboom
May 21st, 2008, 09:48 AM
Add option "UseEdidFreqs" "FALSE" to the device section might do the trick. It will make that X ignores the refresh rate info from the monitor
You might have to add resolutions to the screen section and you might have to set the VertRefresh and HorizSync in the monitor section (you already did) to get it all working.

If it does not help, try option "UseEdid" "FALSE".

PS I still use Dapper, so can not test if it works on Hardy.

joegiampaoli
May 21st, 2008, 08:23 PM
Thanks for your help, I tried all the "UseEdid" options in almost every section of my xorg.conf and still no good. I don't know what's going on :confused:

This is driving me nuts.

I left the option of disabling all globad Edid but I'm not sure if it's in the right place, I'll post my xorg.conf with that change, I also added my monitor resolutions, but I'm not sure if it's all setup right since I also have one created by the nvidia-settings manager.


# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@vernadsky) Tue Mar 4 20:24:34 UTC 2008

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "latam"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "CRT-0"
HorizSync 30.0 - 83.0
VertRefresh 50.0 - 75.0
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 6200"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultDepth 24
Option "UseEDID" "FALSE"
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"

# Removed Option "metamodes" "nvidia-auto-select +0+0"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "CRT-0"
Option "metamodes" "1280x1024 +0+0"
SubSection "Display"
Depth 24
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Wim Sturkenboom
May 22nd, 2008, 06:49 AM
You've put the EDID stuff in the default screen and not in screen0 and according to server layout, you're using screen0.
I have always put it in the device section and it works for me on Dapper, so I'm a bit at a loss here.

Maybe you can check the xorg logfile to see what's going on.

Hope you get it right.

Corrupter
May 29th, 2008, 02:39 PM
I'm having a similiar problem however i never have been into the desktop enviroment at all yet. I loaded the server version of unbuntu 8.04 LTS, some other knick-knack packages and what not and got it all configured to my specs. Decided it would be nice to be able to do a few things that are easier in a desktop enviro so i apt-get install ubuntu-desktop goes off perfectly... startx gives me sync out of range. <crap>.

i'm not able to reboot the server atm as i have an active session going on but this happened to me 3-4 times before when i was experimenting with different server configurations and packages so i put it on a back burner. any ideas as to why it would be doing this?

Christor
May 29th, 2008, 06:13 PM
I got the same problem. Some help would be appreciated.

Thanks in advanced Christor.

Wim Sturkenboom
May 30th, 2008, 07:00 AM
any ideas as to why it would be doing this?Hardware not detected properly is a good option.


I got the same problem. Some help would be appreciated.

Thanks in advanced Christor.

To both:
Please start your own threads with specs (video card and monitor) as it gets confusing who replies to who. And if a reply is posted, you have to check if it applies to your problem or the other person's problem.

xorg logfiles might reveal something

joegiampaoli
May 30th, 2008, 07:33 AM
I already posted this in bugs at launchpad, my report was merged with someone elses but anyone having this issue would be good to start placing it there so they are aware a lot more people are having the same issue, here is the link

https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/202208

cyclops-user
June 2nd, 2008, 04:25 PM
I am having the same problem, will try with the EDID option.

Cheers